WPA Enterprise: TTLS/PAP connection problem


Last Updated:

  1. Hilikus

    Hilikus Member This Topic's Starter

    Joined:
    Jun 28, 2010
    Messages:
    7
    Likes Received:
    0
    Hey guys. i'm trying to connect to my school's network, which uses TTLS and PAP as EAP and phase 2 authentication. I'm using an HTC Legend running android 2.1. The phone sees the network, when i try to connect it gives me the options and i select everything as specified but the network just does not connect

    this is what the logs filtered for wpa_supplicant show

    i've highlighted the part that i think is more relevant: the error about identity configuration not being available. That error keeps appearing over and over every time it tries to reconnect

    my laptop running linux connects just fine and it gives me some info that i think i could add to wpa_supplicant.conf but i don't want to root my phone. anyway, here is the info:

    can someone see anything wrong from the logs or suggest something else to try?? the one thing i would like to try would be to import a certificate for the wifi into my phone but i'm not even sure the connection is using one. I thought WPA enterprise always used certificates but in the instructions the university gave me it says to leave "certificate file" empty
     

    Advertisement
  2. anoniemouse

    anoniemouse Well-Known Member

    Joined:
    Jul 3, 2010
    Messages:
    1,514
    Likes Received:
    237
    Make sure you have entered your key correctly & set the correct version of wpa
     
  3. Hilikus

    Hilikus Member This Topic's Starter

    Joined:
    Jun 28, 2010
    Messages:
    7
    Likes Received:
    0
    the key is correct, i have tried this a million times

    where do i select the WPA version?

    thanks
     

Share This Page

Loading...