www.galaxyshelp.com


Last Updated:

  1. Looks like Samsung has launched a dedicated site supporting the Galaxy S - www.galaxyshelp.com

    I contacted their live chat on the site and asked about the GPS issue. Here's a short snip of the conversation

    Ruth: We need to perform soft reset by removing and reinserting the battery. If the issue still persists, check the signal strength. Turn OFF and turn ON the GPS. If the issue still persists, the device need service at the service center.
    Visitor: OK. I'm in a building right now and don't exect to be able to get a signal in here anyway. I've tested the GPS functionality in several ways and have made several changes to GPS settings. Some seem successfull at first but never fully resolve the issue. I'm a member of several forums specific to the Galaxy S and we've all shared our experiences and settings. The community is under the impression that Samsung has acknowledged that it's aware of the problem and is working on a firmware fix. I'm mainly contacting you to verify that that impression is correct. Can you tell me if Samsung knows about the problem and is working on a fix?
    Ruth: Please allow me to go through the inquiry.
    Ruth: As this is the level-1 Tech support I recommend you to contact our Level-2 tier at 1-877-EZ2GALAXY (1-877-392-4252) regarding your query.
    Ruth: You will get the exact information about the issue and firmware update to fix the issue.
    Visitor: OK. Thank you for your help Ruth, I will do just that!

    I'm going to call Tier 2 now :)

    Advertisement
    DT and jgcalderonperez like this.
  2. lilo

    lilo Well-Known Member

    It looks like Samsung does want to make Galaxy S a success and takes support issues seriously. I think it's a very good sign.
  3. Loco Leeep

    Loco Leeep Well-Known Member

    keep us posted
  4. mi04se1

    mi04se1 Well-Known Member

    I got the same response as the op.
  5. I called the Tier 2 number. She seemed to know what I was talking about and now I'm waiting in the queue on Tier 3 support! I'll update when I get off the phone with them.
  6. GalaxyS609

    GalaxyS609 Well-Known Member

    I love how the first thing mentioned in their videos sections is syncing facebook,

    Then you go in and check out their videos and not a single one of them has anything to do with facebook. I wonder who the genius was behind this website.
  7. Baldilocks

    Baldilocks Well-Known Member

    They want you to register your device, but no matter how you try to enter the numbers it always comes back invalid. Worthless. LOL.
  8. Got off the phone with Tier 3 support. He confirmed that Samsung was aware of the problem and is working on a fix. He stated that the fix is being rolled out for the i9000 (European Galaxy S) so he didn't think it'd be too much longer for us in the US.

    He advised to subscribe to the Samsung Twitter (@SamsungService) and Facebook (SamsungService) feeds as they would be the first places to announce the release of the fix. I asked him about the SUPL/CP settings and he stated that Samsung didn't even allow Tier 3 techs to enter the GPS diagnostics! Understandable I guess, Samsung wants to keep that as compartmentalized as possible.

    The coolest thing? He said he was on this board as well and takes note of the issues people are having. That, combined with all the resources Samsung is throwing behind this product line (like a dedicated help site) makes me feel pretty damned good about my purchase!
    Rotorhead, s.m.knipe and t-readyroc like this.
  9. I had already registered my device on Samsung's main page. On this site, I just said I'd already registered and it didn't ask any more about it.
  10. jmreed97

    jmreed97 Well-Known Member

    Worked for me... they want the serial number not the IMEI number...
  11. Baldilocks

    Baldilocks Well-Known Member

    Yes, I know the difference. :)
    I've even gotten a magnifying glass and entered every number and letter and it still comes back as invalid.

    There are quite a few people who have had this problem.
  12. jmreed97

    jmreed97 Well-Known Member

    Thanks for the info, but I haven't seen any verification of someone getting the fix on the Galaxy S forums...

    Hopefully they are close though, as a few people have been told it is rolling out.
  13. jmreed97

    jmreed97 Well-Known Member

    Sorry, I wasn't trying to be a dick... I entered the wrong number first and thought you might have too... I wasn't aware others were having the problem.
  14. Ethere

    Ethere Well-Known Member

    Worked for me the first try. Their website needs a little work, but it still got the right product when I put the IMEI in.
  15. jmreed97

    jmreed97 Well-Known Member

    I stand corrected... Looks like there is verification from CLOVE Technology that the Euro Samsung Galaxy S has the fix ready... Yeah!!!

    Post #254
    http://androidforums.com/samsung-galaxy-s/104872-gps-issues-6.html
    Prim8 and t-readyroc like this.
  16. t-readyroc

    t-readyroc Well-Known Member

    Suh-weet. I guess maybe we'll get it sometime next month then...
  17. The tech also said that Froyo was on schedule to be released for the i9000 in September. He figured it'd take a month or two after that for US carriers to approve of the apps list and lock down what they wanted before we'd get a release for our phones.
  18. jmreed97

    jmreed97 Well-Known Member

    Good... Well that is some confirmation that the "fix" won't be wrapped into froyo.
  19. GalaxyS609

    GalaxyS609 Well-Known Member

    It worked just fine for me and all I did was enter the IMEI number (that is what it asked for on my end)
  20. t-readyroc

    t-readyroc Well-Known Member

    Sorry for a bit OT, but where can I find the "Model code" they're asking for in registration?
  21. I think it's the one that's on the sticker under the battery: SGH-I897
  22. Baldilocks

    Baldilocks Well-Known Member

    I've entered the IMEI number and the S/N Number, neither of them were recognized. I tried the day after I got the phone also, with the same results.

    Finally just gave up trying to register it.
  23. DT

    DT Well-Known Member

    Well, there's Model Name (where you can select SGH-i897), then another drop down called Model Code with these options:

    SEG-I897ZKAATT
    SGH-I897ZKAATT
    SGH-I897ZKMATT

    I'm assuming it's one of the second two (SGH like the model), but I had a siny ZK out to the right of my SN, so that doesn't help to figure out which one!

    I might just pick one and let 'er rip :D
  24. inku

    inku Member

    Registered fine with IMEI number :)
  25. jeremytanner

    jeremytanner Well-Known Member

    I had to use the IMEI code, and I did choose the middle of the model numbers. However, I kept getting the error. I finally re-entered the IMEI code and hit tab, and their background code somehow recognized it as a valid serial finally, even popped up the manufacture date before I hit the button. So yeah, it's checking on the fly when you put it in, and using Firefox at least caused some issues with the coding that kept returning invalid serial for me for a while.

Share This Page