X10 2.1 Update, Phone really slow, advice please :)General


Last Updated:

  1. biffsmash

    biffsmash Well-Known Member This Topic's Starter

    Joined:
    Sep 1, 2010
    Messages:
    103
    Likes Received:
    6
    Hey everyone,

    I recently swapped my own X10 for a HTC Desire for a multiutude of reasons I won't go into, but my GF kept her X10 in anticipation of the 2.1 Update. She has updated the phone now, although it did take two hours and kept failing.

    Anyway, she is happyish with the phone, but I still feel guilty, as it is so terribly slow, and I recommended the phone to her in the first place.

    Anyway onto my question. If anyone has a HTC Desire and an X10, they may have more insight, but basically, the X10, after the update, is really slow.

    I have sat my Desire side by side with her X10, and tried to do simple tasks, like go into settings, or load media scape, or add widgets, etc, and the X10 is sometimes seconds behind the Desire. I am hoping this is due to a bad install of the update but am not sure.

    Everything seems to lag, pressing settings, going into the app drawer, loading the messaging app, and it doesnt always take the same amount of time to load things either. Sometimes going into settings comes up instantly, other times it takes 5 or 6 seconds. Things just seem to hang for no reason. Even scrolling the app drawer and settings screens up and down seem laggy.

    We both have launcher pro installed now too, as I find it to be an amazing launcher, but the X10 with launcher pro is again miles behind speed wise, to the point of, to me anyway, almost unnacceptable lag.

    Anyway, I just wondered if anyone, hopefully with both phones too, could advise me. I dont want to advise her to do the update again if it isn't going to help. I am privately hoping it is not the limitations of the X10 that makes Android 2.1 so slow, but just a bad install, but i'm not holding my breath.

    Sorry to drone on, and I hope this isnt viewed as too much of a rant or X phone verses Y phone lol.

    Thanks

    Biff.
     

    Advertisement
  2. pyromatic18

    pyromatic18 Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    90
    Likes Received:
    8
    From my experience the first 30 minutes or so after the update the x10 will be slow, but later on it actually picks up speed.
     
  3. biffsmash

    biffsmash Well-Known Member This Topic's Starter

    Joined:
    Sep 1, 2010
    Messages:
    103
    Likes Received:
    6
    Hiya,

    Thanks for the reply :)

    I forgot to mention actually that the phone had been one for a day before I got my grubby little hands on it, so I was hoping it would of sped up by now.

    I'll ask her to pull the battery for a few mins and restart it later, see how that goes.

    Cheers,

    Biff.
     
  4. Nutdog

    Nutdog New Member

    Joined:
    Nov 21, 2010
    Messages:
    2
    Likes Received:
    0
    Hey mate, strangely enough I'm in the exact same situation as yourself with my GF also still holding onto hers and I've got the Desire. I have also done the same tests and found the exact same results and like you say they seem intermittent in that sometimes it responds instantly and others are more than a few seconds. Something that seems to happen more often lately when it hangs is that it comes up with Errors and force closes some Android system apps.
    She has had the update for about a week and a half now and tbh...things seem to be getting progressively worse. The next step I think is I'm going to send it back so they can have a look at it..they will probably flash and re-install..then I'll wait and see what happens. Will post response to this thread again if I get better results.
    Update if you find anything else in the meantime.

    ;]
     
  5. X10iUser

    X10iUser Well-Known Member

    Joined:
    Oct 10, 2010
    Messages:
    1,328
    Likes Received:
    332
    Just try reflashing or repairing and see that helps.
     
  6. clockwork58

    clockwork58 Well-Known Member

    Joined:
    Jul 3, 2010
    Messages:
    256
    Likes Received:
    29
    On my device i also disabled animations.
    Settings -> Sound and Display -> Animations
     
  7. alex_ncfc

    alex_ncfc Well-Known Member

    Joined:
    Aug 1, 2010
    Messages:
    57
    Likes Received:
    6
    I've noticed that my X10's lag is ridiculous! But on the flip side, sometimes the animations are swift as anything. The animations were never really there in 1.6 but it was still laggy even then.

    One thing that frustrates me the most is the inbox - it is INSANELY slow! Surely it's not like this for everyone? For instance I will get a new text and select it from my status bar. It can then take a good 10 seconds, and I'm not even joking, to get to the inbox screen which shows the message. Then, sometimes, when I go to type my message, it will lag so much that my typing is way behind, and something totally unrecognisable to what I have typed will come out. Then, also occasionally, when I go to delete what I have written, I only tap delete a few times but it acts as if I am holding the delete button on the screen and removes my entire message!

    The same sort of lag occurs when someone phones. The phone will start vibrating and playing music but nothing will appear on the screen for a good few seconds.

    Does anybody else experience these problems?

    What on earth can I do to speed this thing up? I have hardly any apps running which use up a lot of CPU and I am at a loss with this one.

    Sorry to kind of hijack a post but I feel your pain, it can be incredibly slow!
     
  8. Nutdog

    Nutdog New Member

    Joined:
    Nov 21, 2010
    Messages:
    2
    Likes Received:
    0
    Hey Alex,
    Apart from all the other problems my partner is experiencing she has also indured those of which you mention too. It is a general problem as it's mentioned on loads of other forums too. Nobody really seems to know what to do to fix it besides sending it in and having SE flash and re-install only to have the same problem a few weeks later again. All fingers having been pointing to SE and SE know there is a problem but always answer with useless 'by the book' replies.
    A quick fix that seems to have worked with my partners handset is :

    1) Move all your apps to SD if you haven't already.
    2) Download ATK [Advanced Task Killer] run it and let it close everything.
    3) Restart your phone and run ATK again and then select only the apps you need.

    Seems to work so far. Goodluck
     
  9. rosered

    rosered VIP Member VIP Member

    Joined:
    Jul 4, 2010
    Messages:
    2,129
    Likes Received:
    317
    I read somewhere but I can't find it again that turning off animations helps with lag so might be worth a trial to see if it helps you.

    Can't move apps to sd until we get 2.2 (if ever!) so that is out at the moment.

    On the texting front I use Handcent SMS and prefer it to the stock app but this did get a bit slow when I had a ridiculous number of texts on there (3000+) so I now use SMS backup and restore to back them up to my SD card and then clear down the app on the phone which then speeds it backup again.
     
  10. Ice

    Ice Active Member

    Joined:
    Sep 3, 2010
    Messages:
    27
    Likes Received:
    0
    ATK is all fine and well, but we shouldn't have to be using it. My GF has the x10 and after the update it got as you mentioned, progressively worse. After a re_boot it runs slot smoother bit it has to be done every couple days. Until sony come out with a patch for it or a dev creates a lag fix, ide say we are stuck with it so have to make do as best we can. Its out there im sure. With its 1 ghz cpu, out should be lightening
     
  11. rosered

    rosered VIP Member VIP Member

    Joined:
    Jul 4, 2010
    Messages:
    2,129
    Likes Received:
    317
    Yeah forgot that one, remove battery for 30 seconds so phone does a hard reset is supposed to also help with lag.
     
  12. loopfish

    loopfish New Member

    Joined:
    Nov 30, 2010
    Messages:
    1
    Likes Received:
    0
    Alex - this is exactly the same problem I am suffering, after installing 2.1. It was never like this before the update, even with massively-long text conversations.
    Spoke to a Live Support SE agent, and she suggested re-installing 2.1, so I will give that a go some time.
     
  13. clockwork58

    clockwork58 Well-Known Member

    Joined:
    Jul 3, 2010
    Messages:
    256
    Likes Received:
    29
    I noticed lately my Stock SMS was starting to lag. I was holding off using handcent but I installed it yesterday and spent hours tweaking it.

    I like it. especially the blue LED it gives for when a msg arrives.
    i like BLUE.
     
  14. biffsmash

    biffsmash Well-Known Member This Topic's Starter

    Joined:
    Sep 1, 2010
    Messages:
    103
    Likes Received:
    6
    My girlfriend's X10 was much better after taking out the battery for a minute, but it is quite a bit slower or laggier than my Desire since the update.

    I'm not sure there is any way to improve it, she is happy with the phone and is putting up with the general slowness compared to mine, but it's a shame that such a good phone seems to be bogged down by SE's software.

    We installed ChompSMS as Handcent and the Stock messenging program was lagging behind while typing, and chomp doesnt have that problem.
     
  15. werthers

    werthers Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    262
    Likes Received:
    15
    I too am noticing my x10 is slower it was fine when I first updated pretty nippy but now it's laggy and 3G stopped working too, If I had to pick again I would get a desire I quite liked the X10 but the bugs I keep finding are getting annoying
     

Share This Page

Loading...