1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

x10 mini wont boot after bat emptyGeneral


  1. joviscomp

    joviscomp New Member

    good day to all,but its a bad day for me when my x10 mini wont boot anymore after my battery ran out.. It will only boot while the sim card is not inserted. but the sim card is working with my spare phone. I restored the phone to factory defaults and it booted again with the sim card inserted but it will now boot after 5 minutes or so...

    does anyone here experienced this? is there a fix?

    thanks...

    Advertisement
    :
  2. rosered

    rosered VIP Member VIP Member

    This thread was over on SE's own forum so you are not alone....

    Main: My xperia x10 mini won't turn on!

    It seems that you need to do a repair on SE Update Service or PCCompanion rather than a factory reset on the phone and DON'T let your phone run our of battery ever!! Not entirely practical advice tho really is it!?

    Make sure your contacts are saved somewhere... sd card or synced cos the repair will remove all data on your phone memory (not SD card).

    Let us know if you get sorted, cos it will help others who have the same problem.
  3. joviscomp

    joviscomp New Member

    I was able to do the repair and performed an update and it work. thank you so much for the info, and you're a big help. the link also helped and gave me hopes because i found out that i am not the only one..thank you so much again.. now waiting for the 2.1 upgrade...
  4. MiniDroid

    MiniDroid Well-Known Member

    If your phone run out of battery again, don't try to turn it on.
    Just put the charger in the phone for an hour before you try to turn it on.
    (not just the usb cable from a computer but the one you put in the wall)
  5. joviscomp

    joviscomp New Member

    thanks for the advise sir.. and also i will do my best not to empty the battery again... but my problem now after that happened is the phone will turn on or boot after 5 or more minutes..
  6. MiniDroid

    MiniDroid Well-Known Member

    Seems like a software/hardware fault, and if it won't be fixed by re-flashing with the same/newer firmware I think you should take it back where you baught it to get a new one.
  7. joviscomp

    joviscomp New Member

    i hope its just a firmware fault. because if the sim card is not inserted, it will boot normaly.
  8. chris_guitar

    chris_guitar New Member

    hi there, i tried all possible solutions and nothing worked for me but didnt give up. So i tried my own solution and it worked but use at your own risk , without erasing, rooting/flashing or pulling the phone majorly apart.

    Located left of the camera lens is a little rubber cover that you can pull off/on, under it is the connection where the battery is connected to the phone, carefully pull it down and take it out so its visible,
    As from now you can see three wires red, green, black. from now grab a 9v battery and 9v connector, put the red and black to their respectively colors wires and hold for a few secs, connect the battery back to phone.

    Then turn on phone with charger plugged in. and red light appears. Solved Problem
Loading...

Share This Page