X10 Stuck at "Sony Ericsson" boot screen


Last Updated:

  1. So I did some modding (unfortunately) to the framework-res.apk file and it worked the first time and a few other times but then I changed something and now when I turn on the phone it freezes at the "Sony Ericsson" screen before the logo. What do I do?

    I tried pushing the backup framework file but it says "failed to copy framework-res.apk to /sdcard/framework-res.apk: Permission denied

    however, when I use adb devices, it does show my device as being attached.

    So what can I do now?

    Edit
    I was also able to pull files...

    Also tried manually putting the framework-res.apk in the sdcard and then using adb to copy it to the framework folder. Doesnt work. Saids that the directory cannot be open for read. I guess the device cant read the SD card until it boots up

    Advertisement
  2. powerkiter

    powerkiter Well-Known Member

    You have figured out more than me if your changing the framework stuff.

    Best off posting this on XDA as that is where the guru's lay when it comes to these matters :)

    I'm sure there will be a recovery option so dont stress to much.
  3. huntleth

    huntleth Well-Known Member

    Have you tried booting into safe mode and restoring?
  4. How do you do that? I tried holding the back button while connecting the cable and then the led turned green but then it got stuck on that screen again.

    EDIT
    What can you do in safe mode? As long as I can turn on USB Debugging I should be able to reverse this
  5. powerkiter

    powerkiter Well-Known Member

    Turn the phone on and hold the options button till it starts up.
  6. Wont boot in safe mode...
  7. powerkiter

    powerkiter Well-Known Member

  8. I held button before pressing power button. And I already posted in XDA but its taking a while x_x I have no patience at all now
  9. powerkiter

    powerkiter Well-Known Member

    I feel your pain and this is why I held back from editing the framework as I would love to get the default Android smilies but have no clue when it come to that side of it the root was just clicking on a few icons and it happened.

    Hope you get it sorted :)
  10. vengeance1990

    vengeance1990 New Member

    to boot an X10 into safemode im pretty sure you hold the power button till the phone vibrates the press the volume down key
  11. Chrisbix555

    Chrisbix555 New Member

    I have recently attempted to start a new run with xrecovery and now it has frozen on the se boot up screen i cant go back into xrecovery again it wont let me so i dunno wat to do help!!!!!!!
  12. beau420

    beau420 Well-Known Member

    Probably going to need to run the flashtool and reflash....if it doesn't let you. Try installing an older version and going through all of the steps again.

    If it ever gets completely stuck, always try installing an older version and the starting again.

    Flash again....turn on Unknown Sources and Debug...install 2.3....root....reboot...install xRecovery from Flashtool
    Miss_Sha37 likes this.
  13. Shadowing

    Shadowing New Member

    I'm having the same problem..
    The phone vibrates as normal when I press the power button.
    After a few secs it shows the Sony Ericsson text.
    And then nothing:mad:

    I tried a couple of button combo's while starting the phone but its always the same end result, it being stuck on "Sony Ericsson".
    It does blink the green LED ones when I hold the Volume Down and Back key with the power button, but then its stuck again..

    I did not do anything with flashing, or even rooting.. I just tried to reboot it, cause Maps was acting weird and it hasn't started since.

    Does anyone have any suggestions?

    Im on Andoid 2.3.3.

    Thanks,
    Richard
  14. kirtivsingh

    kirtivsingh New Member

    Brother's
    Just fixed that issue on one of my friends phone.. he was also worried like you guys are..
    Reason for Stuck on Sony Ericsson is that when you forget to check the USB debugging mode in development before flashing using the flash tool, thats why the tool is stuck on open source.
    Resolution like you have selected downgrade kernel from the flash tool.. disconnect cable.. close flash tool. restart it. click flash and this time use upgrade kernel. and connect the phone using back button.
    Phone will boot up again and you can now check the debugging mode in development and start root process again.
    Enjoy
  15. cobanoglu

    cobanoglu New Member

    So true! Thanks! This worked for me.:party:

Share This Page