X8 rebooting with sim inserted, fine without sim.Support


Last Updated:

  1. 1983xxxx

    1983xxxx New Member This Topic's Starter

    Joined:
    Dec 14, 2012
    Messages:
    1
    Likes Received:
    0
    Hi guys,

    I have just starting having trouble with my X8. It keeps rebooting itself and has very bad battery life whenever i use any kind of app e.g. navigator / maps, although it has started doing it sitting idle.

    The phone was upgraded (2.1) some time ago.

    This problem started after a decent car trip a few days ago where i used the navigator, on and off the car charger.

    I have just realised if i remove the sim and start the phone, the problem is gone and the battery is more stable.

    I have always used juice defender app and the battery easily lasted the day through.

    I originally blamed the battery, but now im thinking it has something to do with the sim (australian amaysim prepaid (optus network)). I tried an optus sim and it has the same problem.

    i have also found that if i have the phone connected to the charger, the phone works fine with the sim card in.

    Any info on whether its a network, or a phone problem would be greatly appreciated.

    Cheers, Craig.
     

    Advertisement
  2. tanabe

    tanabe Well-Known Member

    Joined:
    May 3, 2011
    Messages:
    100
    Likes Received:
    8
    are you running DATA (internet) on your phone? that could be the culprit..
    also, use advance task killer to kill running apps.
     

Share This Page

Loading...