Xoom WiFi connects but Internet will not workSupport

Last Updated:

  1. kirkeb

    kirkeb New Member

    My new Motorola Xoom connects to a WiFi network, but none of the Internet applications work. The browser, Skype..., nothing can connect to the Internet, while the Wifi status tells me the name of my network and says that I have an excellent signal. I know that my Internet works as my Droid X phone connects without a problem. Help! I am travelling overseas and need my new Xoom to connect.

  2. jaiotu

    jaiotu Well-Known Member

    Well... I don't have a XOOM, but my first advice would be for you to try connecting to another network. Just because your DroidX connects doesn't rule out the possibility of a configuration issue on your home wifi. Once that's ruled out, we can look for other possible issues.
    hriverajr, marctronixx and kirkeb like this.
  3. kirkeb

    kirkeb New Member

    I see now that my xoom connects on some networks to the internet but not on others. My android phone connects to the internet when the xoom does not.
  4. marctronixx

    marctronixx Moderator Moderator

    what encryption are you using on these networks? are you using 802.11 G or N?

    what is your experience on public hotspots?
  5. papermonkey01

    papermonkey01 Well-Known Member

    are you sure your X is getting Internet from those wifi networks? Just because you can connect to a wifi network doesn't necessary mean that network has Internet access. (There are a lot of businesses that have wifi networks that aren't hooked up to the Internet)
  6. unknowndroid

    unknowndroid Well-Known Member

    I had rhis same problem when I first got my Zoom on my home network. Droid X worked fine, but Zoom would show connected but not transfer any data. I just rebooted my router and all was fine. Never had to do that with any other devices, but it worked so I'm happy.
  7. unknowndroid

    unknowndroid Well-Known Member

    Doh!! I just noticed that Thumb Keyboard auto corrects Xoom to Zoom....opps
  8. mqureshi79

    mqureshi79 Well-Known Member

    Droid x connects and works, laptop connects and works, xoom connects, doesn't work. Using public wifi, so don't have opportunity to reset router
  9. chisam14

    chisam14 Active Member

    I believe this may be a problem with your router using an authentication server. I know I can't connect my xoom at my gym because the router requires authentication, this is the same problem nooks and other tablets have. Connects fine everywhere else
    marctronixx likes this.
  10. bonzaigirl

    bonzaigirl New Member

    Hey, I have the same problem. It worked fine before. But since I have been to the university library where I actually couldn't connect my xoom to the student wifi, now that I am back to the apartement, it does not work anymore. My Xoom connect itself to the wifi it used to connect to, but internet, skype, nothing works. It says that I don't have any connexion when I do. Help !
    ps: I do not need any password, the wifi are not protected.
  11. marctronixx

    marctronixx Moderator Moderator


    if no luck,

    cold boot (vol up + power key = shutdown)

    remove your wifi network and re-sniff it out. make sure passwords are valid.

    clear cache in stock browser.

    worse case = factory reset.
    bonzaigirl likes this.
  12. bonzaigirl

    bonzaigirl New Member

    Thanks, but I tried the cold boot, I also removed my wifi network and re-sniffed it out again, still no luck. It worked fine one week ago, and the wifi are not protected by any passewords.
    But I guess, before the factory reset, I'm gonna try the wifi in another public place (Starbucks or McDonalds), just to make sure it really doesn't work.
    Thanks again!
    marctronixx likes this.
  13. marctronixx

    marctronixx Moderator Moderator

    its really difficult ti fully diagnose over the internet. it could be something simple that we are missing. but it is strange it worked on your network but no longer does.

    did you reboot your home router? have you checked to see if there are any firmware updates for your router?

    if you dont have your router customized a lot, maybe worth resetting the home router to factory.
  14. bonzaigirl

    bonzaigirl New Member

    Yes I know how difficult it is to fix a computer problem over the internet.
    The thing is, I don't have a home router to reboot, because I'm living on campus, and the college residence provides free wifi. I can't do much about it. I tried different wifi networks but not luck for now. But the semester is almost over! Hopefully it will work elsewhere, in public places when I'm traveling.
    marctronixx likes this.
  15. marctronixx

    marctronixx Moderator Moderator

    ooh i mis understood. reading your first post it sounded like you were on campus and were able to connect, then you went home to your apartment and could not connect.

    i thought they were two separate locations.

    so you are bascially using the same wifi network campus wide and this same network is what you use at your home.


    what band are you on ? 2.4 5?

    what channel? the xoom can only connect to certain channels.

    also since there is no encryption or passwords used, can anyone who is on campus just log on? or do you have to get permission?
  16. bonzaigirl

    bonzaigirl New Member

    Hey, for I don't know what reason, my wifi is working again just fine! Informatics will definitely remain a mystery for me lol.
    Thanks for you help!
    marctronixx likes this.
  17. rbates

    rbates New Member

  18. Chilli71

    Chilli71 Member

    1) I had only two problems with WiFi on Xoom.
    It sometimes somhow hang in a connection that was out of reach and did not search for other networls. Turning WiFi off and on solved the issue (I did not see it yet for quite a while).

    2) I installed NetworkMonitor from the market. It did not work on the XOOM. But when I used the tethered WiFi from my iPhone I had this issue, that Xoom showed good WiFi, iPhone showed Xoom, but I had no internet connection on Xoom. After keeping them 10-20min connected it suddenly worked with the iPhone (at my home network it always worked). -Took some time until I realized a possible relation between the programm and network trouble.
    -> You might look for SW on your Xoom that could have a similar effect.

  19. SinisterEcho

    SinisterEcho New Member

    I've had this happen numerous times on my Xoom, including after I had to factory default it. Here is what works for me every time:
    1) Forget your network.
    2) Turn off wifi on your Xoom.
    3) Power off your router.
    4) Power off your Xoom.
    5) Power on router, then Xoom.
    6) Enable Wifi and join your network.

    This has worked every time for me. Hope this helps.
  20. luv2insanity

    luv2insanity New Member

    Motorola Xoom won't connect to my public connection. It says I have excellent signal strength. I will try to connect to it and while it is obtaining the IP address it looses the signal and stops trying to connect to it. I am unsure of what is going on. It is a public router so I can't reset it. This is the only internet that is available to me right now.
  21. southender

    southender New Member

    I have a Samsung Android tablet. I can connect, but it will require a cell phone number and agreeing to the conditions. The problem is that there is no check box to check. I don't have a cell phone either, since I don't reside in the UK. The result is that I am blocked.

Share This Page