Xperia Arc doesn't power on :-(Support

Last Updated:

  1. su.asanga

    su.asanga New Member

    Hi All,
    I tried to update the phone to 2.3.3 android version using wi-fi connection. It downloaded the update file and then began to install so I placed it down and left it doing its thing. When I came back to the phone was off so I thought it must have finished. When I tried to power the phone on it didn't work. I tried to use SEUS to update the software thinking it had got corrupt during the update but that said it cant update the phone. please someone help me to get rid of this problem.


  2. daveybaby

    daveybaby Well-Known Member

    Do you have an unlocked bootloader? There are quite a few cases over on XDA of people with unlocked bootloaders bricking their phones with OTA updates.

    You may well have to send it in for repair :(
  3. daveybaby

    daveybaby Well-Known Member

  4. aztekasaur

    aztekasaur New Member

    I have had this problem a few times. It happened when the battery ran down. I charged the phone and it wouldn't boot. Each time, I've removed the battery and it booted fine.
    I would be curious to find out why this happens.
  5. Aztekasaur's suggestion is well worth a try.

    If that does not help you should download Update Service and see if it's possible to reinstall the software in order to get it working again.
    Update service - Learn more - Mobile phones - Support - Sony Ericsson.
    The phone must be powered off during the whole update process so it will hopefully be possible to do this despite not being able to power it on right now.

    Sony Ericsson Answers Team

Share This Page