Xperia Arc Wi-Fi connection problems (may apply to PLAY, neo & pro too)Support


Last Updated: 2012-10-22 21:25:41
  1. jonmorris

    jonmorris Well-Known Member

    I think it's time for a new thread as I'm pretty sure my problem isn't unique.

    I have had an Xperia arc longer than most, and already done the first firmware update. However, I am still having problems.

    Firstly, I connect via Wi-Fi (whatever setting used for sleep, either when screen turned off, except when on charge, or never) and it remains connected - but seems to stop working after fairly minimal amounts of data transfer.

    The problem seems to occur though when there's a lot of data being sent. I can almost perfectly recreate the problem by streaming video with BBC iPlayer or downloading a file.

    What seems to be happening is that I am losing the connection, but the phone doesn't show that. It keeps the Wi-Fi icon on, but isn't connected. I can't easily tell if that's the case (by looking at the router info) but it seems to be easy to confirm by the simple fact that it shows it is still connected even when I go out of range of the router, or power it off.

    I've left the office (so another router, the one at home is D-Link, the one at work is an Apple one) and got on the train, underground, to see that it's still connected.. and when I go above ground and reconnect to the mobile network, I can't send/receive data as it's giving an error related to no Internet via Wi-Fi. Well, duh, there's no Wi-Fi!

    The only solution now is to turn off Wi-Fi and use 3G exclusively. Leaving Wi-Fi on also seems to destroy the battery (from 88% to 17% overnight having done nothing). I'm seriously tempted to return to my Motorola DEFY, even though I'll lose the great camera.

    Is it just me (a hardware issue) or is anyone else having problems? I really don't think it's down to the router you're connecting to, this is the phone. I have over 15 devices I regularly connect at home/work and they all work fine.

    Advertisement
  2. Mozzer x10

    Mozzer x10 Active Member

    I tell you what i have noticed, sort of related. Is sometimes the connection symbols do not relate to the phones current status. ive seen it on Calls, EG Full bars displayed on phone yet when its called goes straight to answer phone indication no signal? and 3G. "h" sign displayed but cannot get on a web page?

    bit odd.
  3. jonmorris

    jonmorris Well-Known Member

    I was wondering if some things were becoming 'stuck' too.
  4. weymouthstan

    weymouthstan Guest

    Same problem on my Neo - WiFi drops connection but icon stays lit.
    I've tried switching my router to 'G' only, and using three different security types.
    I have a Netgear DG384G that works fine with my other wireless gear.

    UPDATE:

    It was my router. Using a Netgear DGN1000 now and connection is solid!

    WS.
  5. gabeyong

    gabeyong Well-Known Member

    does not bother me.

    both TV Shows Stream v3.2.3 & BBC iPlayer works fine

    i am using DLink DIR-655 (@ home - fiber optic), DLink-Dir-615 (@ office - fiber optic), Apple Airport Extreme N (@ dad's BT) all working fine.

    faulty handset?
  6. tabharti

    tabharti New Member

    I have been using arc since last 1 month and have not faced any such problem so far.

    Replied using my Sony Ericsson Xperia Arc
  7. judesons

    judesons New Member

    I had the same problem. Guys try installing 'Blade Wifi Fix', 'REGPON wifi KeepAlive' and 'Wi-Fi Keep Alive' from Android Market and then see the performance. Try out also Wefi Connect.
  8. gstan80

    gstan80 New Member

    Hey guys! same wi fi problem on xperia arc and found lots of buyers with this frustrating issue. this is something they knew even before launching the phone. normally the new phone are tested thousands of times before releasing day and what makes me mad is that they keep not responding to this. if you carefully search on google you will find a lot of people having the problem wit wi fi of sony ericsson xperia arc even if they replace it. they technical support said to me that they never heard of such problem and they recommend an update. so thay do not know even it is all over the internet. layers!! try everithing though so the last option will be to ask for a refund and look for better options. i also have an lg optimus 2x wich is by the way like a ferrary compared to arc even if often is not responding on media players or camera. please let me know if you have and positive reactions. have a good one guys
  9. gstan80

    gstan80 New Member

    I do consider this very fustrating because is like a laptop that you have no wifi at. That is why we buy smart phones, to enjoy internet browsing and sharing, office applications and so on.. xperia arc wifi problem is a very bad one for Sonny Ericsson.
  10. murrayalex

    murrayalex Active Member

    This has happened to me a lot in the last few weeks, not only with the Xperia Arc but also an HTC Desire S and the Nexus S. Initially, on first set up the wifi on the device (I use an Apple Airport base station) will work for about an hour and then disconnect. The next time it will work for 2 minutes only.
    An even bigger problem for me is that each Android device has basically killed the whole home wifi network so that my laptop and other devices cannot then connect and the modem and Airport have to be restarted.
    Frankly, it's rather pathetic in 2011 to have this sort of basic issue. When I connect via wifi with my iPhone or Palm Pre (don't laugh) it works flawlessly.
  11. nyvang101

    nyvang101 New Member

    1.Log on to your router/wireless modem.
    2.Find something called DHCP Connections. Read Router/modem manual
    3.select the Android Phone and delete it from the list
    4.click Manualy Create a new static connection
    5.Inset the Phones Ip adress and mac adress found Under advanced settings in the wireless menu on your phone.
    6.Click save ALL DONE.


    i dont know why this works but it do. if you done it right you can surf with full speed and not get disconnected. Shuld work with all Routers/Modems.

    The problem is not the phone but the modem.. i have tested this on serval routers even Wifi Hot spots i have flooting around at home.
  12. nyvang101

    nyvang101 New Member

    Im working on a app that can automaticly log on to the rooter delete your android devices mac and IP adress and "manualy" create a new static connection. so you wont have to do it your self as i belive many people dont even know how to log on to the rooter.

    Ill let you know how it works when im done. "if i remember"
  13. sp1rit

    sp1rit New Member

    I am also having issues with my Neo its dropping wifi, uploading pictures to my pc is impossible as it always says no new pictures. I then check its details and its in unknown location? Also the keyboard goes hyper sensitive when im trying to email or do anything involving the keyboard when on charge.... If you know a fix for these please let me know i have had the phone a week and close to taking it back to get a new one!! :eek:
  14. flanger

    flanger New Member

    I had the same problem on my xperia arc when trying to connect to my university's wpa enterprise protected wifi network.
    I tried the blade wifi fix and all the other apps suggested above with no success, what has seemed to work for me is the following app:

    Advanced Wifi Lock (Free) by Opotech

    (I still have Blade wifi fix installed but i don't think thats making a difference - could be wrong tho)

    Can anyone confirm that its a solution for them too?

    Just thought i'd post it in case anyone else is struggling with the same issue
  15. Hal-droid

    Hal-droid New Member

    I had also the same problem of wi-fi connection.
    In conclusion, As a result of changing encryption scheme of wireless network,
    I have solved the problem.

    When encryption scheme was WPA1/WPA2 mixed mode, wi-fi connection error occurred frequently. But I have never faced wi-fi connection error since I changed to WPA[FONT=MS Pゴシック]([/FONT]TKIP[FONT=MS Pゴシック])[/FONT].
  16. MamTor

    MamTor Member

    Similar 'fix' in my case. Out the box, and with update to 2.3.3, my 3 day old Arc couldn't connect to WEP encrypted Wifi networks.

    I just needed to change my Wifi's access point encryption method from WEP to WPA/WPA2 PSK and my Arc connected fine.

    I don't mind as in theory, WPA/WPA2 PSK is more secure than WEP, but it's still rediculous that a top of the range, brand new phone won't connect to WEP networks...:eek:
  17. ctinro

    ctinro New Member

    Maybe some of you had the same problem but found a different solution. I loose a half day trying to connect to my Belkin, which does not broadcast the SSID. Now everything is fine. The Arc does not accept the character `#` (sharp) in the password. Maybe there are others more.
  18. xperia7

    xperia7 Member

    I have never had any of the issues people mentioned here. Wifi is always reliable, doesn't seem to affect battery life (not enough for me to tell, anyways), and when there is no wifi network to connect to it uses 3g.

    Canada/Rogers, 2.3.3, bought it on launch date.
  19. marbii

    marbii New Member

    Is there going to be any fix for this problem?
  20. MariaE71

    MariaE71 New Member

    After disabling everything with dynamic choices regarding WiFi in my router it seem like I have managed to get the WiFi reasonably stable. The most significant stability improvement occurred when I changed the WiFi channel from "Auto Channel Scan" to a static selection that no other router in my neighbourhood uses (channel 4 in my case).

    Other things changed, that _might_ contribute to my increased stability.

    * Changed from "WPA/WPA2" to "WPA2 Only"
    * Changed "802.11 Mode" from "802.11n, 802.11g and 802.11b" to "Mixed 802.11g and 802.11b"

    Phone: SE Xperia Arc
    Router: D-Link DIR-855.

    Might help some... Perhaps...
  21. volksgti

    volksgti New Member

    It works good for me with a linsys router and Blade Wifi Fix.
  22. Glengimen

    Glengimen New Member

    I previsouly had a SE Xperia X10 and the wifi worked flawlessly everywhere I went. Now I have an Xperia Arc and the wifi is useless. I have tried all the fixes mentioned above and none seem to work, also I have the same problem at 4 different locations so i find it had to believe that my router at home could be the problem.

    Any other ideas before I sell this useless POS????
  23. jonesy99

    jonesy99 New Member

    Very frustrating does not begin to describe it!!! Have tried all the suggestions in this link and none work consistently, the only thing that does work is selecting a new wireless channel on the router (BT HomeHub), it then recognises the wifi connection and remembers the WEP key too, but then forgets it when the device goes to sleep. There are a number of wireless devices attached to the hub and none of them have these issues, HTC, iPhones etc. Needless to say, I won't be getting another SE. :confused:
  24. hwcheng

    hwcheng Member

    I have a Win 7 NB (HP), a Win XP NB (Sony), an MBP, an iPad, a Moto Milestone, PS3, PSP, NDS 3D at home. All of the above can connect to internet world at the same time without any problem. But my Sony/SE members (an Arc, a Neo, and a Tablet S) can only join sometimes and then stop. Interesting enough, they encounter no Wifi problems outside home. So I think is that a router problem? Then I bought a new router (from Buffalo -> TP-Link), and no change.

    All suggestions above work for a while and the problem returns. (i.e., Wifi connection shows good on my Sony/SE members status bar, but it cannot connect to the outside internet world; yet connection to the router's Web server is fine for changes to make all times.)

    Another interesting thing to find is that my Sony/SE members work fine in the morning, and not in any evening (haunted...?) This specific pattern suggested me to find what changed between mornings/evenings. I used Wifi-Analyzer kind of thing to scan the environment, and of course, to find out that far more AP points working in evenings. So, is it an interfering problem? Thus, I tried changing channel to use, and still the above problem is there.

    In one morning, I have both my Neo and Tablet S connected to my router, my Tablet S started to show its reluctance to go to the outside world. Ah..., THAT might be the problem, interference of MY own stuff! So, I switch on/off my Wifi family members, and now at last, I found my Sony/SE members are working only when the "Lord of the Rings" does not reign. This "Lord of the Rings" is my MBP! Every time when it is switched on, all Sony/SE members have to remain silent!

    Do you have similar experience? Is there any way for me to have this resolved, please? Will DD-WRT help?

    One more remark: my SE members with Android 2.3.2 worked without any problem before. Upgrade to 2.3.3, wifi connection problem started to surface, and to 2.3.4 problem persists.
  25. gpgon

    gpgon New Member

    hi I had an x10 that got stolen. wifi worked fine. it was replaced with xplay. wfi fine. upped to 2.3.4, problem. read it might be time/date conflict issue. then read my router's frimware had time/date inconsistency issues (mine insisted it was thur feb 19 2012, which 2/19/12 is a sunday, also real date was thur JAN 19 2012.

    too long didn't read: try updating your router's firmware. worked for me

Share This Page