1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Xperia E Wifi problemsSupport


  1. mattjamesbean

    mattjamesbean New Member

    My son has a Sony Xperia E and it will not connect to our home WiFi (Vodafone). It finds it but will not connect. It will connect to my phones WiFi hotspot no problem (Xperia Z) the phone is running on jellybean 4.1.1

    Advertisement
    :
  2. scary alien

    scary alien not really so scary Moderator

    Welcome to the AndroidForums, Matt!

    I've moved your thread to the Sony Xperia E area for you in hopes that someone here with your device might be familiar with your issue.

    I've sure you've tried all the usual tricks with connecting to wi-fi (forget network, checking security protocol, double-checking password, etc.).

    Best of luck!

    :)
  3. sadi85

    sadi85 New Member

    I've been using an Xperia E for the last 2 weeks. I changed my SIM today (the phone is unlocked), but my phone couldn't connect to the network, so I reset the phone. But after that it can't connect to the home wifi network (although every other device in the home is working on that wifi network). The phone shows the home wifi network, saves it, but can't connect. I've tried resetting a few times. But the same keeps happening again. Can anyone please help? Should I look for help in related Sony Xperia sub forums?
  4. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Do either of you get an error message when trying to connect?
    scary alien likes this.
  5. acuppen92

    acuppen92 New Member

    I have the same problem as stated above. The phone connects to any network, at work or at family's for example, except the one at home. When trying to connect to the wifi network at home, the phone says it is connecting and this changes to saved and protected by WPA/WPA2 after a while. Nothing happens afterwards so no error message shows up. I have absolutely no clue how to solve this problem. Any help is greatly appreciated.
  6. rog_d

    rog_d New Member

    I too have the same problem. I have a Netgear router with WPA (as supplied by Sky) and all my other Wifi units, including my HTC mobile can connect to it without any problems. Is Sony looking at this as it seems to be A FEATURE? :mad: No messages come back from the unsuccessful 'connect', it just says 'saved'. I do notice on the router maintenance id that the Xperia E does find it (MAC address is filled in) but the IP address and unit descriptor information are various symbols and not readable characters. It seems to me that the Xperia Wifi software has a bug in it.:confused:
  7. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    For both rog_d and acuppen92, please go to the website for the routers manufacturer and attempt to update the firmware of the router. I had a similar problem with a netgear router some time ago and a firmware update to it resolved the issue.
    rog_d and scary alien like this.
  8. rog_d

    rog_d New Member

    Thanks for the information, however, after checking with Sky, the router is at the latest version of Netgear firmware. So where do we go next please?
  9. rog_d

    rog_d New Member

    I've just been on a chat line with Sony about this and they pointed me to http://192.168.0.1/setup.cgi?next_file=wireless_settings-wpa.html where you can check whether the router is a match for the mobile. Although the mobile says it can connect to WPA secured routers, the encryption support on the mobile is only WEP. The Netgear router I have has the security set as WPA-PSK (Wi-Fi Protected Access Pre-Shared Key). The router does have an option of WEP as a radio button but I cannot set it. So, unless anyone can tell me otherwise, this mobile will not connect to it. Any further help would be appreciated.
  10. rog_d

    rog_d New Member

    I've even tried Wifi Hotspotting onto my HTC Desire C mobile and the connection keeps timing-out. What a USELESS mobile this Xperia E is. I wouldn't recommend anyone buying it - it is only good for making calls :-(
  11. Fishyweb

    Fishyweb Well-Known Member

    Is this really true? The Xperia E really cannot connect to a router with WPA-PSK encryption?

    I was thinking of getting one of these for my wife but, if this is true, I'll think again, maybe a Desire C.
  12. Spiderine

    Spiderine Member

    Has anyone managed to figure out the Xperia E wifi problems, it seems to work with most other wifi spots, i.e. providers such as virgin etc... etc...

    However it's failing to connect to my sky wifi, i have the netgear router and it's running the latest firmware.

    I dont know what I should do?

    If this phone cannot connect to wifi, it's pretty much useless to me.

    Should I go exchange it for a samsung galaxy mini 2?
  13. luce0103

    luce0103 New Member

    I've had the same problem. When you turn on your phone 1st time the wizard opens and it offers you to download 'internet configuration and setup' or sth like that. I Ignored that and couldnt connect. Then I installed that and now i can connect. Oh and also make sure you have right wi-fi pass. Good luck :):thumbup:
    scary alien likes this.
  14. forvenk

    forvenk New Member

    Hi All, I have Xpeira E dual and I had the same problem. The wireless connection will show as connected, but when I browse, the pages wont come up. My router is Netgear DG834Gv5. When I changed the wireless security to WEP the phone started working fine.
    scary alien likes this.
  15. Fishyweb

    Fishyweb Well-Known Member

    My wife's (unlocked) Xperia E has no trouble connecting to my home router, secured with WPA. The router is a Thomson one, supplied by Plusnet.
    scary alien likes this.
Loading...

Share This Page