xperia pro can't use t-mobile 3gSupport


  1. wynnsayz

    wynnsayz New Member

    I recently bought a xperia Pro for my sister and it's the unlocked US version. the problem is that that phone can't use 3g data from t-mobile. My sister's previous xperia phone was unlocked as well and it can use t-mobile 3g. Just now I called and t-mobile said any unlocked phone can't use t-mobile data. Any ways I can get around that?

    Advertisement
    :
  2. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    I'm sorry for being the one giving you this info but the Xperia™ Pro sold in the US is not compatible with T-Mobile's 3G frequencies. It actually uses a different one that the one they use, that being said you should be able to get 2G but sadly not 3G.
    wynnsayz likes this.
  3. wynnsayz

    wynnsayz New Member

    Ya I later learned that T-mobile requires both 1700 and 2100 in order to use 3g. Xperia pro only has 2100. T-mobile (or ATT) is truly making this hard... unlimited data but can't use oversea phone vs limited data with wide selection of phones.

    sigh I hate them
  4. bethany66

    bethany66 Member

    So you say: "Xperia™ Pro sold in the US is not compatible with T-Mobile's 3G frequencies." Is that also true for AT&T frequencies? I bought an unlocked one and have not yet been able to get the data working. The phone works, and the data works via WiFi, but not via the cellular network.
  5. rui-no-onna

    rui-no-onna Well-Known Member

    bethany66 likes this.
  6. bethany66

    bethany66 Member

    Rui-no-onna, you are my hero! After multiple contacts with both AT&T and Sony, neither had been able to get the data working on my Xperia Pro. I was truly planning on packaging up the phone tonight to ship it back. You have done me a great service, and I thank you heartily!
  7. bethany66

    bethany66 Member

    I am hoping that Rui-no-onna or someone else can assist me again. While the settings Rui-no-onna provided did indeed give me data/internet access, I have not yet been able to get MMS to function. I have worked with both AT&t and Sony, and they just keep sending me back and forth between them, each saying the other needs to provide the settings.

    I have my settings as you provided and that doesn't work. I changed the Port to 80 as someone suggested and that doesn't work either. My data/Internet works fine, as does SMS. It is just MMS that doesn't work.

    Can anyone help?
  8. rui-no-onna

    rui-no-onna Well-Known Member

    Try the following. They're from my mom's LG Thrive (AT&T branded LG Optimus One).

    Code (Text):
    1. Name: <anything you want>
    2. APN: wap.cingular
    3. Proxy: wireless.cingular.com
    4. Port: 80
    5. Username: <Not set>
    6. Password: <Not set>
    7. Server: <Not set>
    8. MMSC: http://mmsc.cingular.com
    9. MMS proxy: wireless.cingular.com
    10. MMS port: 80
    11. MCC: 310
    12. MNC: 410
    13. Authentication type: None
    14. APN type: <Not set>
  9. mr samster

    mr samster New Member

    I know that it says for cingular, but would i still be able to use it for T-Mobile also?
  10. KDash

    KDash New Member

    I want to buy one to use on a no contract T-mobile. Loving the new SE Xperias!. Just got my son an Xperia Play or his 12th birthday. It's pretty sweet. I gotta have a querty keyboard and I'm crushing on the red Pro! Please tell me I can get it to work in KC MO! I've gotta have internet cuz I think I use it for that more than anything while I'm at my son's sports practices etc...

    HELP!!!!

    Many thanks in advance!!!!

    :confused:
Loading...

Share This Page