Xperia X10 will not connect to PC via USB (unrecognised device)Support


  1. justinbarrow

    justinbarrow Active Member

    I have had my X10 for just 2 months and ever since I have had it the phone will not connect to my PC using the usb cable, I have downloaded the latest Sony software such as the Update program and also PC Companion.

    When I connect the phone to my PC running windows 7 it shows as installing the drivers but then says error and tells me "unrecognised device" I have this error showing up in device manager.

    However when I try this on my freinds PC which is also running windows 7 and it connects fine without any problems I have since tried it on my wifes Laptop running Windows XP Home and it says the same "unrecognised device" this is the same with the other PC we have.

    I even took the phone to a computer shop where they tried it on 3 of their machines and they could not get it to work again "unrecognised device" being the error.

    It has become a real pain and I have now had to download an app called "My Phone Explorer" onto my phone and also install this onto my PC to enable me to transfer large files from my phone but via my wireless router/network.

    I feel that it should just work as I have never had issues with phones like this before they have just been plug n play.

    I have been onto Sony and they say they will look at the phone but will charge me if it works which knowing my luck it will, as it works on my friends pc without a problem so if it works ok on theirs then there cant be anything wrong with the phone.

    Sony just tell me that the drivers are all built into the software program that you download and say my friend must have something different on their machine to make the phone work. Its so frustrating as it only seems to like 1 PC out of several.

    If anyone can help with this or has a solution it would be greatly appreciated as I feel if I ever sold my phone then the new keeper would be unhappy as part of having phones like this with lots of memory you would expect them to connect to a PC without all these issues.

    I have heard Sony are going to be bringing out new software soon which may cure this issue, does anyone know when to expect this new software.

    Finally I have unmounted the SD card in my phone but still get the "unrecognised device" error when connection via USB.

    Thanks everyone in advance :)

    Advertisement
    :
  2. justinbarrow

    justinbarrow Active Member

    Forgot to mention, Thanks to my friends PC I have managed to get Android Gingerbread 2.3.3 onto the phone so it is using the latest software and the phone has never been rooted.

    Thanks again.
  3. beau420

    beau420 Well-Known Member

    So, your phone doesn't work on your windows 7 computer or xp computer or multiple computers in a store, but it works on your buddies computer?

    Are you always using the same USB cable?

    Always try plugging it in to different USB ports....make sure you aren't using a HUB or anything. If you are only trying to use the USB ports on the front of a computer, try the back.

    I would suggest using a different USB cable.

    Does the phone still charge?
    justinbarrow likes this.
  4. justinbarrow

    justinbarrow Active Member

    I am using the same USB cable each time, would this make a difference? I have tried the USB ports on the back of my pc and these are the same still get the unrecognised error.

    When connected to a PC the top LED is orange in colour and the battery appears not to be charging.

    I will try with another cable and get back to you - thanks.
  5. justinbarrow

    justinbarrow Active Member

    Thank you! it was a faulty USB cable i bought a new one and straight away it connects to all computers I was told some of the data pins may have been faulty but the charging pins were fine this explains why it charged from the mains but would not work via USB.

    The lead was brand new with the phone 2 months ago and I have always had this issue since day 1, it must of been a faulty lead from the factory as I have always been very careful plugging it in and out of the phone after hearing of lots of issues with this phones charging port.

    Thanks again, just goes to show what a difference these forums and a new cable can make. I am also glad I didnt send it back to sony as I may have been charged as they would of just wanted me to send the handset back without any cables and used their own and found nothing wrong.

    Heres an interactive pint on me lol, Thanks again.
  6. beau420

    beau420 Well-Known Member

    Sweet...glad it worked out....nice it was just the cable, but at the same time, kind of sucks you had to get a new one.
  7. drsaad

    drsaad New Member

    hey , i am having the same problem never get into usb mode tried many different cables ports, only thing i didnt try is ORIGINAL xperia cable, is this true XPERIA x10 works with only xperia cable and not other cables....?are there different specifications for the cable?
    secondly sme one told me there are usb plug and play driver inside your phone that lets you manage usb is this true, i am new to android doesnt reply know much....
    kindly help i have tried all the procedures given on different sites , even different computers and different cables, pc companion, SEUS etc etc
    i really driving me hell crazy
  8. sinta rosa

    sinta rosa New Member

    hello good morning!! i have the same problem.. help.. im trying to upgrade my xperia x10. my laptop is not recognizing the usb cord/cable im using. My Dad said that he was able to use it just fine before he shipped it (the cp and laptop) here to the philippines. ive tried different cords already.
Loading...

Share This Page