Yahoo E-Mail using E-Mail app and free Yahoo account--Works!


Last Updated:

  1. jklong03

    jklong03 Member This Topic's Starter

    Joined:
    Mar 23, 2009
    Messages:
    10
    Likes Received:
    1
    I remembered from my G1 days a way to sync the E-Mail app up to Yahoo's free (not PoP3) servers so I gave it try on my new BH2 and it works just fine:

    Here are the steps:

    1. Enter Yahoo ID and Password (hint, just use your "username", not the whole joeblow@yahoo.com
    2. Select Manual Setup
    3. Setup IMAP
    4. Incoming server is imap.mail.yahoo.com
    5. Port is 143
    6. Security Type is "TLS (if available)"
    7. Leave IMAP path prefix blank
    8. Hit next
    9. SMTP Server is smtp.mobile.mail.yahoo.com
    10. Port is 25
    11. Security is again TLS (if available)
    12. Check Require sign-in
    13. Verify username and password
    14. enjoy:)

    To Sync up, you CANNOT be on WiFi (dunno why, maybe Yahoo has a deal with T-Mobile?).
    One other note: if after rechecking all your settings and it still says "invalid username/password" try going onto your Yahoo Account and change your "Location" to ASIA ! Weird I know, but for some reason, some people can't get this to work with US-English as their Yahoo Locale (not talking about your phone's settings here, all on Yahoo site end!).
     

    Advertisement
    Euro101 likes this.
  2. jklong03

    jklong03 Member This Topic's Starter

    Joined:
    Mar 23, 2009
    Messages:
    10
    Likes Received:
    1
    I see this got 88 views so far, but no replies?? No one is interested in trying this? Or did someone try it and it not work?

    I would like to hear feedback if anyone has tried this.
     
  3. chadmd23

    chadmd23 Well-Known Member

    Joined:
    Dec 17, 2009
    Messages:
    530
    Likes Received:
    57
    I've been using it since I got the phone. Yahoo IMAP is for iphone use only, which is why WiFi doesn't work. You can't find any mention of it, even from tech support, on the yahoo website. I only wish they would upgrade the server so I can use IMAP IDLE.
     
  4. Euro101

    Euro101 Active Member

    Joined:
    Feb 15, 2010
    Messages:
    31
    Likes Received:
    0
    Just did this works like a charm thanks!
     
  5. thenestor

    thenestor Well-Known Member

    Joined:
    Dec 27, 2009
    Messages:
    1,038
    Likes Received:
    316
    I tried it just a few minutes ago with new instructions, and it worked for me. Choose IMAP as the protocol, not POP3, and then try to use these settings:

    Incoming settings
    Email address: yourname@yahoo.com
    Username: yourname@yahoo.com
    Password: ******
    IMAP server: android.imap.mail.yahoo.com
    Security type: SSL
    Server port: 993

    Click "Next" and it will bring you to the next page of settings:

    Outgoing server settings
    [X] Login required
    Username: yourname@yahoo.com
    Password: ******
    SMTP server: android.smtp.mail.yahoo.com
    Security type: SSL
    Server port: 465

    Hope this helps!
     
    halom and rajbir15380 like this.

Share This Page

Loading...