Yahoo email in HTC


  1. Fiona0007

    Fiona0007 Member

    Hi
    I am a newbie in this forum. I recently got a HTC magic, and was trying to get my yahoo mail into email application without success. It kept saying i typed in the wrong ID or password. It accepted hotmail and google mail though. Anyone managed to get yahoo mail into Email application? Please tell me how you did.

    Advertisement
    :
  2. leec983

    leec983 New Member

    Hi,

    I had the same problem, but it seemed to have something to do with the settings for my Yahoo account which I had for years. Despite looking into all the settings I couldnt sort it, so I eventually created a new account, and forwarded all my emails from the original account to the new one. The new one set up no problem. Hope this helps a little.
  3. mjschmidt

    mjschmidt Well-Known Member

    Yes, I have my Yahoo! Mail account set up on my HTC Magic.

    Incoming settings
    Protocol = POP
    Username = your full yahoo email address
    PW: Your password
    POP Server: pop.mail.yahoo.com
    Security Type = None

    Outgoing settings
    Username = same as above
    PW = same
    SMTP server = smtp.mail.yahoo.com
    Security type = None
    Server port = 587

    NOTE: In order to get POP access to your Yahoo email in the Mail app on your phone, you must either be paying for their premium service, or you have to agree to receive newsletters from Yahoo `partners`to get it for free.
  4. Fiona0007

    Fiona0007 Member

    Hi leec983, thanks for suggestion. Is your new email yahoo? I opened another yahoo mail account and tried set up in HTC email application to no avail. It was not registering at all. Did you need to tweak the set up of your new yahoo mail?
  5. Lefthand

    Lefthand Well-Known Member

    Got my G2 last week, Set up Yahoo and worked fine until yesterday, the only annoying thing it wasn't filtering spam. But since yesterday nothing, it just.. stopped. Can still access it by signing in on the web based one though. oh well, might as well start using Gmail as my main account, I guess.
  6. Fiona0007

    Fiona0007 Member

    Thanks for your input. I still have trouble setting this up with my HTC magic. Is this because we are using different handsets? or live in different countries (i am in UK)? I don't know, but I still cannot have yahoo mail in android email. I can read mails from yahoo web page though. Did you just add new account in android Email app? Could you please tell me in steps how to get this done? Thanks.
  7. Lefthand

    Lefthand Well-Known Member

    Im in the Uk as well , I have a Hero (T-Mobile call it a G2). as I said I also cannot get Yahoo mail straight to the phone through the Mail widget, (although I used to be able to) and like you I now check my Y mail on the web page. This seems to be a common problem, it seem to have everything to do with Yahoo and not the networks or HTC. Having to check mail on the web page ain't necessarily a bad thing though, at least you have access to all your folders etc.
    However, there is a way around it if you really need to get your mail through the mail widget. First of all set your Gmail account to fetch your Y mail. You can do this on your Gmail page, go to settings - Accounts and Import- Import mail and contacts. You can even set it to send mail from your Y account. Then on your phone (and here I'm guessing as I don't know how a Touch works!) tap on the mail widget, make sure you're on the first screen, the one that lists all the emails received: tap "more" and switch to Gmail as your default mail service. Bear in mind though that it takes a while for Gmail to fetch Y mail... so you won't get it as it arrives in your Y inbox. Oh, and you still won't get a notification!
    As I said in my previous post, might as well switch to Gmail as your primary email address...
    Hope it helps!;)
  8. Fiona0007

    Fiona0007 Member

    Hi Lefthand,
    Many thanks for your reply. I got the impression Y mail just isn't compatible with HTC email widget somehow. I am happy with Y mail on the Yahoo browser, and it's too much hassle mixing two email accounts like Y and G. I will leave them alone for now. Don't mind not having notifications. Many thanks.
  9. trick202

    trick202 Well-Known Member

    I've been getting my ymail fine on my hero on orange UK.

    I have mail plus though.

    Have you checked your pop access is checked in settings (on ymail)?
  10. travon802

    travon802 Member

    I am using the free yahoo mail just fine on the MyTouch with the default mail app.

    I suggest using the IMAP protocol for this. Here are my settings:

    Incoming
    Protocol: IMAP
    IMAP Server: imap.mail.yahoo.com
    Security: None
    Server port: 143

    Outgoing
    Check Login required
    SMTP Server: smtp.mobile.mail.yahoo.com
    Server Port: 25


    With these settings, I can delete email on my phone and it deletes immediately (w/o syncing) on the mail server and messages are marked read after synching.
  11. trick202

    trick202 Well-Known Member

    I'm guessing you're not on uk yahoo mail?
  12. travon802

    travon802 Member

    That's correct.. I'm in the US. I just didn't see IMAP offered as a suggestion.
  13. Fiona0007

    Fiona0007 Member

    Thanks Travon and Trick.
    I do not have Y mail plus. I am currently reading mails via Y web browser only.
    Travon, I have tried entering all you said, but it didn't work.
    Thank you for your advice all the same.
  14. trick202

    trick202 Well-Known Member

    try setting your location to the US or asia, rather than UK.

    Some countries allow pop free as standard, other places make you buy plus.
  15. Lefthand

    Lefthand Well-Known Member

    Hi Fiona I've sorted it too by changing my Yahoo account location to Yahoo Asia.
    Here's how you do it. Nothing will change in the appearance or language of your account, I promise, but you WILL get your Y Mail delivered to your phone, notifications and all!

    Access your Yahoo account on your PC.

    In the top right hand corner, click "Options" then "Mail Options" from the drop-down menu.

    From the left hand pane click "Accounts" then click on the "Add or edit an account" link.

    You're now in "Mail Accounts". In the left hand pane click "Account information". You may be asked to sign in again.

    You're now in "Account Information": scroll down to "Account Settings" and click "Set language, site and time zone".

    In the next page select "Yahoo Asia" from the NEW SETTING drop down menu, and GMT UK in the TIME ZONE.

    Click the "Finished" button (very important!)

    That's it, it may take a little while to start with but eventually you'll get all your mail delivered to your phone as it comes in.

    Good luck!
  16. SamXp

    SamXp Well-Known Member

    Dude, this works. Thanks!
    I wonder why you need to set the time zone to UK, though. Strange.
  17. trick202

    trick202 Well-Known Member

    For message delivery/sending detail?
  18. Fiona0007

    Fiona0007 Member

    Hi Lefthand
    Thanks. Looks like it did work for some people.
    I just tried. My account was changed to y asia and I tried again on HTC email. It still won't register me! -unable to connect server! So why is that? I tried manual setup with both pop and imap, both yaoo.com, pop.mail.yahoo.com as well as imap.mail.yahoo.com. Something isn't right with me.
  19. Lefthand

    Lefthand Well-Known Member

    You can set the time zone to your own region, the important thing is to set the server to Asia.
  20. Lefthand

    Lefthand Well-Known Member

    Fiona try deleting your Y account on your phone, (only on your phone, leave the actual Y account as it is, with the server set to Asia. then re-register from scratch using the phone's default settings.
    I'm also beginning to wonder whether it may have something to do with the phone itself. Or perhaps the network? I'm on T-Mob. Have you been in touch with HTC themselves about this? Their CS is quite helpful. Go to HTC - Support and click Customer service. Worth a shot!
  21. djtroy30

    djtroy30 Member

    For my problem with the yahoo email, all I did was update profile and poof...email was working again. Lets see how long.
  22. SamXp

    SamXp Well-Known Member

    Hmm. Premature celebration. It stopped working. It just says "login failed" but I'm still getting notifications of new email.
  23. oggg

    oggg Member

    same problem here. Using HTC Hero from Sprint and yahoo! plus account (US). The emails are showing up normally. However, when I try to refresh I get the message "Login failed". Real weird, how can the emails show up when the phone automatically syncs and not when I try to refresh?
  24. DMAA

    DMAA New Member

    No need for yahoo mail plus.
    If you go to 'options' in your yahoo email account you can select 'mail for mobile' from the menu on the left hand side. Yahoo will provide you with imap login setting for your phone. Though you will need to enter your mobile number, service provider and phone model.
  25. SamXp

    SamXp Well-Known Member

    All it did for me on the "mail for mobile" link is provide a place for your phone number. It sends a text with a link and opens a mobile yahoo interface in the browser. No imap settings.
    I'm also using Yahoo Plus.
Loading...

Share This Page