Your device isn't compatible with this version (Galaxy Prevail)

Last Updated:

  1. GalaxyPrevail2

    GalaxyPrevail2 New Member

    I have a galaxy prevail (Network: Boost mobile, Android version: 2.3.6, Baseband version: S:M820.07 x.FF19, Kernel version:, Hardware version: M820.07)
    (I just bought it online here:
    When I go to Google Play and try to install some apps like Subway Surfers, Temple Run,... it says "your device isn't compatible with this version"
    What does this mean?
    What I need to do with my device so that I can install those apps?

  2. chanchan05

    chanchan05 The Doctor Guide

    Your phone isn't good enough to handle those games. It only has an 800Mhz CPU and a rather outdated (Open GL 1.1) 3D engine. In contrast, my Galaxy S has a 1Ghz CPU with a decent graphics chip (Open GL 2.0 capable) and its a bit slow on those games.
    mikedt likes this.
  3. SulkyAndroid17

    SulkyAndroid17 Well-Known Member

    To answer your first question:
    I don't know anything about those games but they could require an api above what gingerbread offers. Or the Prevail may not support the game for hardware or other software limitations.

    To answer your second question:
    All you can do is root, rom, and overclock. A custom rom is waaaaay better than that stock crap Boost put on it, but this really doesn't mean your games would work. Or get a better phone. The prevail came out in early 2011 and is two android versions behind. Had you bought from Boost, you could have saved 25$ or spent 30$ more than what you did and got a better phone.
    mikedt likes this.

Share This Page