Youtube AppSupport


Last Updated:

  1. Bentamms

    Bentamms Guest

    I have noticed that the youtube app is terrible on the Nexus 10. I have tried to watch a few videos and I will get a few seconds of video, then loading, then a few seconds, then more loading. At first I thought the problem was with my wifi, but after resetting the router a few times and nothing changing I tried my phone. My phone played the videos just fine over the same connection. So I was wondering if there is something wrong with the app, or if there is some kind of setting or something that I have to switch around to get them to play correctly? The videos also take forever to watch in the browser or through any other video players. I dont watch many videos from youtube, so for me this isnt a big problem at all, but still is annoying when I do try and watch any.

    Advertisement
  2. Ekim Gram

    Ekim Gram Well-Known Member

    YouTube on Android sucks (and has always sucked), it's not just the Nexus 10.
  3. Bentamms

    Bentamms Guest

    Its never been great, but its always been useable. The app on the nexus 10 isnt even able to play a short clip.
  4. sikclown

    sikclown Well-Known Member

    Huh, I have no problems with YouTube on my Nexus 10 or any other Android device.
  5. ren857

    ren857 Well-Known Member

    I don't have a nexus 10, but I do have a Galaxy Note II, and I agree with the OP.

    What's funny is that the ad that plays before the video plays perfect - no stuttering and no"circle of doom."
  6. William T Riker

    William T Riker Well-Known Member

    Me neither. Youtube app works just fine on my N10, and I leech off one of my neighbors open wifi :confused:

    Maybe try deleting the apps cache/data or try a different access point
  7. Chrizzl3

    Chrizzl3 Well-Known Member

    YT works very well for me on phone and N10. Make sure you've updated to the latest version. Its a lot better than before!
  8. short space

    short space Member

    Anything that we can try to reduce the problem?
    I have it too.
    Is there a way to download the video before watching it?
  9. BynoUK

    BynoUK Well-Known Member

    Works just fine on my N10 and GS3, never had a problem with the app on previous android devices either.
  10. tjreishus

    tjreishus Well-Known Member

    I just tried it out. Randomly selected many HD videos. The videos fully loaded in seconds. There was no pausing on mine. The longest video was 2 minutes 30 seconds in HD and it was done loading the whole video in about 5 seconds.

    Sounds like you might have a connection issue.
  11. short space

    short space Member

    For we Android tech newbies:
    1. How do we determine we have latest Youtube app? If not how do we get it?
    I am assuming that the Youtube app [discussed] is invoked by clicking the Youtube icon that came with my N10.Correct?
    2.What cache do we clear to possibly improve Youtube performance & how do we do that?
    3. Are there any alternative Android Youtube apps that might yield better performance?
  12. siggy1964

    siggy1964 Well-Known Member

    I haven't had any problems either.
  13. tjreishus

    tjreishus Well-Known Member

    I feel bad for those of you having problems with youtube. I personally keep most of my personal videos on youtube so I use it a lot to show people. I would be really frustrated if I were in your shoes. I have 30mbps internet with a nice router at home so I thought I would try my test again tethered to my GS3 on 4G. I still found videos were starting up almost instantly and the video loaded about 5 times faster than it was playing. I still didn't have any performance problems. I only selected HD videos to make sure they were high data videos. I wish I could offer some more advice or help as to why this happens to several of you, but something is obviously wrong. I post this just to let you know the N10 is capable of it, but now your left with the tedious work of figuring out why yours is not.

    Best of luck
  14. schulzjt

    schulzjt Member

    I found this on another Forum and it seemed to help my problem which is the same as yours. Under wifi settings, uncheck the "Wifi optimization" box. No more buffering. Hope this helps.

Share This Page