Youtube Mobile not working....Support

Last Updated:

  1. Apache Thunder

    Apache Thunder Well-Known Member

    Any one else having issues getting the Youtube app to work? The mobile version of the site also does not work. It says "Sorry, this video cannot be played" and the Youtube mobile app spits out a "Unable to connect to server. Touch to retry" error. The odd thing is, the youtube app works if I turn on Wifi, but when running off the 3G network only, it doesn't work.

    All my other apps connect to the internet just fine. SpeedTest works, Market works, and Facebook works. Just not Youtube.

    The full version of Youtube does work and is the only version of youtube I can get to work. I have Adobe Flash 10.3 paired with Dolphin HD as my web browser.

    My phone is rooted and has the "HalfAssRom" with Kouma Kernel 2.0 on it.

    Any suggestions on what's going wrong? I've tried clearing cache/data for the youtube app and tried uninstalling/reinstalling it...doesn't work. :(

  2. wetbiker7

    wetbiker7 Well-Known Member Contributor

    As far as the apps go , try using the YouTube app from the CTMod 2.3 removed apps zip or find another one on the net and use the to install it in CWM .

    If it's not playing on Dolphin , it sounds like your Flash is not working . Have you tried FlashPlayer 10.2 ? That's what I'm using and it works fine . I just tested it again .
  3. Apache Thunder

    Apache Thunder Well-Known Member

    Flash is working fine for me otherwise I would not be able to play videos on the desktop version of Youtube which play fine. (though laggy on anything past 240p setting). I have used other sites that require flash and they have worked fine.

    I'll try the alternate versions of youtube you mentioned and will see if I can get anywhere with them.
  4. OuterHeaven

    OuterHeaven Member

    I had the same thing happen, and it was because of proxy settings. I read that changing the proxy settings to <not set> would be better than When I did that the browser still worked fine, but the YouTube app stopped working. I changed the proxy addresses back to and the proxy ports to 0, and YouTube worked again.
    cyberapps likes this.
  5. Apache Thunder

    Apache Thunder Well-Known Member

    lol spot on. I was about to post saying that the proxy settings in my DATA hidden menu were set to "<Not Set>" and after changing them to and 0 respectively, my Youtube app started working again. Streaming video in WeatherBug wasn't working either, so that was what prompted me to check the proxy settings.

    Its working now. So for any of those doing the proxy tweak for better 3G speeds, be sure to set them to 0 and since simply clearing them out so they read as "Not Set" will cause problems with apps that stream video like Youtube.
  6. cyberapps

    cyberapps Well-Known Member

  7. Apache Thunder

    Apache Thunder Well-Known Member

    Uhm you failed to read the post correctly. As I said in the original post, the youtube app worked fine on Wifi, but did not work when using the cell towers only. But I have since fixed the issue now if you read my last post. ;)
  8. wetbiker7

    wetbiker7 Well-Known Member Contributor

    LOL . yep ..... ya gotta set those proxies . :D
  9. sjamie

    sjamie Well-Known Member

    Did you get the Youtube mobile site working again too? For me, the Youtube app works well but I get the "Sorry, this video cannot be played" error when I try to play a video from the website. Clicking a video on the site "should" launch the YouTube app.
  10. wetbiker7

    wetbiker7 Well-Known Member Contributor

    Didn't for me. It would play directly from the site using Dolphin. :D
  11. Maui Droid

    Maui Droid New Member

    I'm having a similar issue. Youtube app works fine, but if I click a Youtube link in Facebook, it takes me to Youtube, but when I click play I get "Sorry, This video cannot be played".
    I've tried everything I can think of. Using android browser, Dophin browser, HD off, logged in, not logged in, etc.

    I tried setting my proxy address to and the port to 0, but it says port address is not valid.
    Any suggestions?

    There's also a space for proxy exceptions. Should there be any info in there?
  12. w31rd0

    w31rd0 New Member

    Sorry....hey guys I don't know anything about script and codes. After days of frustration, I tried something weird and it worked on my xperia neo v. The problem started when i updated to ICS 4.0.4. What i did was i went to SETTINGS>WIRELESS & NETWORKS>MORE>MOBILE NETWORKS>ACCESS POINT NAMES>select the one which is already active>go down to BEARER> change it to eHRPD. That's it. It works for me. BTW I'm from INDIA and I have a mobile 3G connection. Hope this helps!
  13. sjamie

    sjamie Well-Known Member

    For me, it seems to be browser specific. Opera Mobile opens the YouTube app from the YouTube site and plays videos correctly. The Maxathon browser properly plays videos from YouTube's site in its own viewer (portrait mode only). The stock Android browser, Dolphin HD, Ninesky, Skyfire and others give me the "Sorry, I can't play this video" error.

    As a result, I've made Opera Mobile my new default browser.
  14. Maui Droid

    Maui Droid New Member

    Mahalo sjamie, it works! Opera Mobile is now my default browser!
  15. sjamie

    sjamie Well-Known Member

    I'm glad I could help you!
  16. kurkosdr

    kurkosdr Member

    Same problem here. Funny thing? If I log out, everything works fine. Of course that way the youtube start page containing videos from my subscriptions gets replaced with random junk. I tried logging in to an old account of mine, same problem, I have to log out in order to not get the message

    BTW I hate how Google brushes of customers with generic error messages like "Couldn't do X". Well, I know you can't, otherwise I would see you doing it. But could you bother telling me why?

    It's applies to both Google and Android. Just try and post a comment containing a link in youtube, and you 'll get an ultra-generic "error occured", instead of something like "No urls allowed".
  17. Jiminycricket9

    Jiminycricket9 New Member

    I fixed it..go to "manage applications" scroll down to YouTube click it then "uninstall updates "Smacked easy peasy.done
    and you're welcome ;)
  18. Jiminycricket9

    Jiminycricket9 New Member

    I fixed it..go to "manage applications" scroll down to YouTube click it then "uninstall updates "easy peasy.done
    and you're welcome ;)
    union3476 likes this.

Share This Page