YouTube videos won't load on dataSupport


Last Updated: 2015-01-12 04:23:06
  1. pienewb

    pienewb Member

    I'm having trouble with YouTube, whenever I try to load a video, it just sits there with the loading circle and does nothing else. It will load when I'm on wifi but not when I'm using my data. I've tried using 4g and 3g, no luck. I've also used the app and the mobile site, neither work. I've uninstalled the app back to stock, deleted all cache and everything. I don't understand what's wrong with it. Thanks for your help.

    Advertisement
  2. wyelkins

    wyelkins Well-Known Member

    It sounds like you are in an area with very slow 3g. Try it very late at night. Speeds are usually faster then

    Try at other places in your area. Run speedtest.com app in different places and compare your download speeds
  3. pienewb

    pienewb Member

    It's not my speeds I know for sure, my 4g lte runs at 14mbs and my dad has boost also and his YouTube is working fine on 4g
  4. wyelkins

    wyelkins Well-Known Member

    Maybe you are short on free memory. Not sure why it works fine on WIFI though.
  5. pienewb

    pienewb Member

    does anybody else have any ideas?
  6. winnythechu

    winnythechu New Member

    Go to settings...data usage.... push the button with 3 vertical dots... make sure restrict background data is not selected.
    Unforgiven likes this.
  7. frosthax1

    frosthax1 Well-Known Member

    you sure your not just being throttled? if your being throttled youtube prolly wont work as well as most videos on data.you prolly also noticed your downloading on google play takes forever per download.if your on sprint boost virgin mobile and straight talk there is such a thing as throttling and you have a high speed limit and once you meet your limit its slow as a snail.my pandora wont even work ever since i was throttled.im doing the data throttle hack now though but if your already throttled it wont show until they turn the throttle off each pay month

Share This Page