1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Z4Root not working with new Rogers Captivate (w/ 2.2 update)


  1. theadderblack

    theadderblack Active Member

    Well, just got me a lovely new Captivate from Rogers, got the Froyo 2.2 update and wanted to root it. Trouble is, the z4root program simply stops and returns me to the home screen having doen nothing. Well, not exactly "nothing" - it seems a helluva lot laggier now until I reboot the phone.

    I have stopped all apps running in the background before launching z4root too.

    Any help would be greatly appreciated!

    Cheers

    Adder

    Advertisement
  2. mnemonicj

    mnemonicj Well-Known Member

    I had a similar thing happen when I ran z4root on my wife's 2.1 Stock Captivate. I rebooted the phone and then ran it again and it was successful. Did you look to see if it Superuser app was on your phone, but maybe not functional?
  3. theadderblack

    theadderblack Active Member

    No SuperUser app visible. Tried multiple times too. Cant seem to figure it out. Maybe I should re-download and install z4root?
  4. theadderblack

    theadderblack Active Member

    Would I look somewhere specific for superuser or just on the applications page? Still isnt taking for so,e reason
  5. Rootmepls

    Rootmepls Well-Known Member

    Did you try SuperOneClick yet? Might give that a whirl. Not as easy as z4root but still pretty easy. Just install the correct 64-bit or 32-bit drivers for your phone. Drivers on this page.
  6. theadderblack

    theadderblack Active Member

    Worked like a charm! Thanks! Somehow though, Titanium Backup isnt installing cuz the root check failed and its looking for something called BusyBox...I know that phones rooted now as i've checked the tethering and all is good...
  7. Rootmepls

    Rootmepls Well-Known Member

    I know that all the issues I had when first rooting my phone were caused by bad drivers from the Samsung site. SuperOneClick will install BusyBox in the rooting process if you need it.
  8. brucelebel

    brucelebel New Member

    :(Can't root my DROIDX anymore...since updating and there is no turning back now. Hope someone comes up with a workaround soon. Life has become boring.:mad:

Share This Page