1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

Solved Zeki Tablet stuck on loading screen.


  1. I purchased a Zeki Android 8" tablet a few days ago. It worked fine for not even a week and died completely over night. Now when I turn it on it wont go anywhere passed the "Android" logo during the loading screen.

    Advertisement
  2. Loonatick

    Loonatick New Member

    Hi i just encountered the same problem with the zeki 8" TBDG874B.
    what i did to get it of the flashy Android logo was hold down the volume button on the minus (-) side and get a small pin or needle to tap the reset. while holding the volume it will reset, then tap the power button still holding volume it will bring up a list. do a factory reset you lose all data but thats what i had to do. i tryed deleting the caches but didnt work. after the deletion select restart and the logo will again appear, just wait and it should come back to like when you first turned on and your golden, hopefuly. just dont do what you did b4 if anything. what i was doing was downloading a large file and was attemting to add an additional user at the same time
    . sorry for bad grammer btw. hope this helps you or anyone else :)
  3. 1Tinkerbell

    1Tinkerbell New Member

    My Tablet is a zeki 8" and when I power on it goes to android and stays there. I did do the system restore and did the minus (-) and power thing and it still does it. What should I do to get this back up and running. Sometime it will go to the time and lock screen and I swipe to unlock and all I get is a black screen. So Im thinking that everything is lost on my tablet. How do I get it all back.

    Help Please:(
  4. darkcyber

    darkcyber Well-Known Member

    If you do a "factory reset" that completely wipes your Android device...yes...all data on that is lost and the device is put back to stock, just like it came out of the box new. You will have to set it back up again, just like you did the first time you got it.
  5. Chewie

    Chewie New Member

    How long did it take your tablet to reset? Mine is taking an inordinately long time. Also, what does it do when it's done? Does it shut off, or go to the home screen?
  6. Chewie

    Chewie New Member

    One more question. When I try to reset my tablet, it says "No Command". What does that mean, and how do I fix it?

Share This Page