ZTE Merit possible cause for phantom restarts (log inside)Support


  1. nickdalzell

    nickdalzell Well-Known Member Contributor

    like i mentioned before in another thread or two, if i put my ZTE Merit (Avail) into airplane mode it never has this problem, narrowing it down to the cellular radio being a possible culprit. While i am not sure if this applies to all the issues surrounding the ZTE rebooting itself issue, it did shed some light on mine--apparently something involving the cellular radio crashes and causes a kernel panic, and it's NOT due to any app, but mainly a core service being unstable for whatever reason. here's a copy of the log:


    SMSM: modem SMSM state changed to SMSM_RESET
    probable err_fatal on the modem. calling sub system restart
    restart sequence requested for modem restart_level=3
    sub-sys restart: subsystem_restart()
    subsystem_restart: modem did not enable SSR, reset SOC instead.
    [SDM] smem: DIAG 'Q6SW a2_il_per.c01879 p:0,0,0 A2 assertion failed
    Notify: start reset
    Kernel Panic - not syncing: subsystem-restart: Resetting the SoC - modem crashed.

    EDIT: this rebooting issue seems to happen at anywhere from once or twice per hour to once a day. it's pretty random, and in my case, it seems to peak in frequency in fringe areas (one or two bars, white data icons (lost google services))

    Advertisement
    :
    very intrested likes this.
  2. jamespfassett

    jamespfassett Well-Known Member

    Ouch, that really sucks man...

    If I had such a rampant reboot issue, Id be pissed. I hope one of us on here can find a permanent solution for that.

    For some reason, some peoples phone do it, and some do not. Mine doesnt do it at all. And I would notice, because I play with this thing so much its probably going to make me go blind...
  3. nickdalzell

    nickdalzell Well-Known Member Contributor

    It seems to vary, but I did manage to track it down, but haven't yet figured out the cause. Wiping and reflashing doesn't fix it. I usually turn it on airplane mode if not expecting calls, as its at least 50% MP3 player anyway. I hope this discovery helps others as I hear many with ZTE phones have this problem. I think its a PRL update issue, as I changed the settings for network inside the test menu to GSM only vs. the factory setting of GSM auto PRL. whenever the phone tried to do a PRL list update, it kernel panicked and rebooted itself as evidenced by this log.

    I left data on so we will see in a bit if the PRL update caused it.
  4. Hey there nickdalzell! Brand new to the forum, and still a noob to smart phone and android. Anyway, I have the same problem with my ZTE Merit, and it does it about every other day. At this point its not a big deal but I hope it doesn't get worse. My quetion is did you figure out what was causing it to reboot?
  5. nickdalzell

    nickdalzell Well-Known Member Contributor

    no, i have not. however i fooled around in the /system folder enough and hacked a few things in SQlite that must have stopped it because i have not had it since. not even once. i am unable to find out just *what* i did so i am putting together a neat little CM 7 lookalike ROM which has the same benefit and when i am finished it will be in nandroid backup form. all anyone would need to do then is boot into CWM and restore it.

    the phantom boots are also common in most if not all ZTE Avail/Merit Z990G devices, i doubt it's hardware more like unstable software, some setting in the /system that causes a kernel panic and auto reboot when the cellular modem attempts a PRL list update every once in awhile.
  6. Glad to hear your phone is better. I'm new to all this, where can I go to get a good understanding on rom, how to flash it, how to back it up, ect. I can't seem to get anywhere with my merit. I have root but that's all I can get. Every time I try to flash something, my phone sits on the ZTE boot screen for a while and reboots with no results. Or get stuck on that screen for hours and I pull the battery. I'm not sure what I'm doing wrong, or maybe I'm missing something. My goal is to mount a second partition for internal memory. As you know this phone comes with almost nothing inside. Any help would be appreciated. Thanks!
  7. nickdalzell

    nickdalzell Well-Known Member Contributor

    you may have root but do you have ClockworkMod installed? you will need that to install/flash custom ROMs. for any questions i suggest the Merit-All Things Root sub-forum up top. you can ask all the questions you like. some have made ROMs with features like overclocking and themes in backup form ready to flash--all you have to do is put them on the root of the SD card (aka not in a directory such as 'download') and boot into recovery by turning the phone OFF, holding down home, volume UP, and power at the SAME TIME, and it should boot into ClockworkMod if it is already installed. then go to backup/restore and backup your current setup and then go to restore and select the proper folder on your SD Card (nandroids show up under clockworkmod/backup/ as dated folders.)

    if you boot loop (get stuck at the ZTE screen or it dumps you back into recovery) you either installed an incompatible ROM (such as a CyanogenMod build for another device like the ZTE Blade) 2) you didnt' wipe the /data and /cache before you did so, or 3) you don't have clockworkmod and used stock recovery, which won't work
  8. I tried to get cwm. maybe i'm misunderstanding things, but I got rom manager and I couldn't reboot into cwm recovery like it wants you to, so I got rid of it. I'll rummage through the forums and see if I can learn anything.
  9. out of ideas

    out of ideas Well-Known Member

    Get the CWM off these boards. Rom manager doesnt work with us.
  10. well that clears up a bit! I have tried some off the boards. must be doing something wrong because I have failed about half a dozen times today. I'll keep on trying till it works.
  11. out of ideas

    out of ideas Well-Known Member

  12. Sweet! I had just figured it out. I'm understanding it way better now. How do I Thank you for your stats on the left?
  13. out of ideas

    out of ideas Well-Known Member

    The little "thanks" box on the bottom left of the post.
    very intrested likes this.
  14. xer0615

    xer0615 Member

    I had a reboot issue with my ZTE merit. It was an issue with the SIM card. I did not suspect that using the sim card from my older Net10 LG Blackberry Ripoff would cause such an error.. but since replacing it with the SIM card that came with the merit, I have no issues with reboots.
  15. nickdalzell

    nickdalzell Well-Known Member Contributor

    If you root the phone install the free 'phone info' app, load it, go to 'phone information' and scroll down. Select the 'GSM only' choice (GSM (auto PRL) is default). While this forces you into 2G only data mode, the phantom boots cease. I finally traced it to a definite issue regarding the auto PRL list update. Data is slower (use wifi) but battery life is also improved a bit
  16. kenbo11

    kenbo11 Member

    For anyone still dealing with this problem. The Phone Info app that is referred to here is not on the play store anymore. There is a phone info app there but it's not the same one. You can find the right one in my next post.
  17. kenbo11

    kenbo11 Member

Loading...

Share This Page