1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

zte merit wont chargeSupport


  1. jab1079

    jab1079 Member

    I have a ZTE z990g Merit. Last week my phone was hooked up to the car charger and everything was just fine, then it stopped charging. At first I thought it was just hot so I unplugged it and let it cool. Since then it hasnt taken a charge from the car. I've bought 2 new chargers since and one was specifically for my phone. Still nothing. I wasn't to concerned because it still worked with the house charger until tonight. When I plugged it into the house charger it didn't charge. I took the usb cord out of the wall adapter and plugged it into the computer at my moms and it started charging. I don't have a computer at my house so I don't know what to do or why it would stop charging from the outlet or the car. I am using the same usb cord from the wall adapter to charge from the computer so its not the cord. What would cause this?

    Advertisement
    :
  2. jab1079

    jab1079 Member

    I'm wondering if it may be a software issue. Something that has to do with regulating voltage or something. I don't know anything about this stuff so this is strickly me thinking "logically". I mean considering it does take a charge with the same usb cord but only when its plugged into the computer I'll assume that the pins aren't messed up. Also that while it does charge, the battery percentage stops at 62%. The battery icon continues to show that its taking charge but it doesn't go any further. So does anyone think that doing a hard reset back to factory settings may clear it up? Maybe its a glitch or virus of some sort. I'm just tossing ideas around... Any suggestions at all would be greatly greatly appreciated.
  3. AntimonyER

    AntimonyER AF Addict VIP Member

    Hey jab, just a heads up, I moved this post to the ZTE Merit forum for you. Thanks for understanding. :)
  4. kingmt

    kingmt Well-Known Member

    This phone is very picky about its chargers. Walmart had a car charger that cost $7 that seems to work better then the one that came with it. I have tried several but only found two that worked besides the USB from the PC.

    Good luck.
  5. shan12stones

    shan12stones New Member

    mine is acting up right now to
  6. nickdalzell

    nickdalzell Well-Known Member Contributor

    no car chargers will charge my Merit. it needs for some odd reason a high powered charger. even the Kindle Fire charger won't do it very well (charges up but extremely slow) this phone seems to be picky about using the charger supplied with it. car chargers of any kind even those with fancy digital readout will indicate 'charging' in the notification area but the battery still continues to drain, albeit slowly. charging through a laptop USB port slow-charges like the Kindle Fire charger does.

    I've determined that the charger must output 1A 5V at least to slow-charge, and 1.5 or more amps to fast charge like the one supplied with it. most car chargers only put straight 12V at low milliamp rates of 500mA or less. these will maintain current charge but won't charge up. the supplied charger is rated 500mA as well but I doubt the reading is accurate, as no other charger supplying the same volts/amps (such as the Optimus V charger with the same mini-USB port) will accomplish the same feat. Kindle Fire charger is rated 1.0A 5V
Loading...

Share This Page