ZTE U960 ROM Discussion


  1. MichelR

    MichelR New Member

    anyone else have play store issues with solutor Gapp + Root V2 upgrade?
    I can't start it, i've directly the unexpected stop error message.
  2. nothingman76

    nothingman76 Well-Known Member

    I hade the same problem and I fixed by doing a wipe from the recovery (data, cache and dalvik).
    MichelR likes this.
  3. sergmarin

    sergmarin Member

    The same issue happens after flashing of modified kernels (/cache folder mounts read-only), you need to wipe cache and dalvik-cache via clockworkmode recovery.
  4. bullifrank

    bullifrank Active Member

    @weimerd: was the same for me when tried to flash from my Win 7 machine. Did the same with win-XP Netbook and bingo. Try to find a XP machine for flashing. Do not use WIN 7 (or XP running on WIN 7 virtual) as (i think) the driver system and use is different to XP
  5. nothingman76

    nothingman76 Well-Known Member

    I successfully flashed the ROM using the xpmode virtual machine under WIN 7: as suggested by the solutor you need toquickly re-attach the phone to the vm (using the virtual pc gui) when it reboots.
  6. stierlitz

    stierlitz New Member

    the same behaivior on nativ xp system
  7. hellomnp

    hellomnp Well-Known Member

    can it possible that all roms links ,kernels links and all useful links for zteu960 are posted in the top of every new page.
  8. weimerd

    weimerd Member

    So finally I made it and got the update running on a XP machine. Update went fine, also recovery mode works - Many thanks to TheSolutor!

    So finally rom shows 2B06 baseband version.

    Now the sad thing: SIM1 is still not working with my o2 cards. SIM2 no problem. Every other phone has no problem with these sim cards. So still SIM1 is not working properly.

    Tomorrow I will test bluetooth. In versions before bluetooth app was crashing when trying to pair with my car audio system (mercedes c)

    So again waiting for ZTE to get this solved - annoying...
  9. EmilF

    EmilF Well-Known Member

    I don't believe that the baseband is actually updated with the 2B06 ROM updater. In any chase, you cannot trust what is shown in under baseband version under settings - just information from the build.prop, not the actual baseband version...
  10. sergmarin

    sergmarin Member

    btw USSD is working on SIM1 now, i believe that is result of modem's upgrade, not android system.
  11. EmilF

    EmilF Well-Known Member

    How did you get it working? I have the same problem as you had, that the phone just enters charging state when it is connectet to the machine, and does not install the drivers...
  12. weimerd

    weimerd Member

    I just took a real XP machine. Installed the OneClick-Updater. Installed the drivers (see installation folder of oneclick-Updater). Turned off the phone. Plugged in usb port. Phone started into charging mode, some drivers where installed. Afterwards I started the updater tool. I don't remember if I had to start the phone or if the updater tool recognized the phone from charging state. You could try both.

    Good luck my friend :)
    hmvs likes this.
  13. weimerd

    weimerd Member

    Why should ZTE fake an 2B06 update? I would understand this for custom roms but this is an official one. So I think it's a true baseband update. Nevertheless they did not fix everything as you can see at my sim card problems at SIM1.
  14. EmilF

    EmilF Well-Known Member

    Im not saying that they are "faking" it, but only that under settings it does not show the actual baseband version, that is just a simple fact. Also ZTE have not included baseband updates with their earlyer ROM's.

    E.g. if you have B13 baseband, and flash a 2B03 ROM, settings will show 2B03 baseband, not B13 baseband as the phone is actually running.

    That there is not baseband update, is what I understand from this post.
  15. The Solutor

    The Solutor Well-Known Member

    To be clear, the standard android info page shows only what's written on build.prop

    So, if you update just the android section, as we are used to, with the update.zip package, you will see the updated basebands while they aren't.

    The result from *983*154# menu should be more effective.

    Back to the 02B06 I've checked again, there is a 10 MB file that is identical in size with one present on the stand alone SP baseband update but a lot of other files are missing.

    So (I guess) the 02B06 baseband update is meant to update only part of the SP baseband SW, likely because the other sections are untouched by the latest update.
  16. sergmarin

    sergmarin Member

    Today I restored my CWM-backup of previous system (2B03) and USSD on SIM1 stopped working. So i think that solution of that behavior is not in baseband but in the android system...
    Just returned again to the 2B06 :) ...
  17. nothingman76

    nothingman76 Well-Known Member

    I'm not an expert but did you try to play with the settings available dialing this code * 983 * 01 # ?
  18. The Solutor

    The Solutor Well-Known Member

    Yes the fix is in the ROM, when I noticed that the USSD was fixed, was after flashing just the Qualcomm section of the phone.
  19. The Solutor

    The Solutor Well-Known Member

    Looks like the O2 SIMs problem is way different than the Vodafone.it one.

    If I understand correctly the O2 SIMs aren't recognized at all (the vodaone.it disconnected trirself from the net after four seconds) could be even an electrical problem.

    Another quick test could be renaming the STK1.apk (and rebooting the phone), I remember that the N900 was not working with UK and Sweden Three SIMs, and was because an STK problem.

    If the phone was already updated to B10/B12 could be interesting to see if the B08 baseband makes any differences.

    Sometimes a fix for a problem breaks something else.
  20. weimerd

    weimerd Member

    I will play a little with that. btw do you have B08 baseband for me so I can play arround with it? I don't have it here. Best would be a pac-file.
  21. The Solutor

    The Solutor Well-Known Member

    I haven't it

    I found the links for the whole roms b07, b08 and b10 official roms.

    They are on the (ugly for non registered users) 115.com.

    You can download from there (easily but slowly) with jdownloader, or register to 115.com (google for tutorials in English)
  22. KToM73

    KToM73 Member

    Hi Guys,

    Thanks for answers for my "freezing" problem...
    My experiences regarding the mentioned issues:
    1. freezing - can be due to Nilkin silicon case, sometimes phone was really hot (charging + 3G - but 3G connection was not proper due to SW issue)
    2. Since I have updated to 02B06 (Big thanks for The Solutor -here again) no freezing even with Nilkin case
    3. I had serious problems (with B12 and B13 -2B03 maybe?) to connect to 3G, since 02B06 upgrade - no problem :)
    4. When I changed back to B13-(2B03 maybe?) - 3G problem solved also -after 02B06 upgrade

    My question (I am an 1.0 Android user :)
    Could anybody explain me the SW architecture of the phone, SW versions and SW upgrade methods? Different caches...
    ROM, baseband, recovery, image etc - I have some faint idea but it would be really good to understand, I know I use your time, but please :)

    Thanks in advance,

    Tamas
  23. nothingman76

    nothingman76 Well-Known Member

    Can you explain how sms w/o sender's number are managed with 2B06 ?
    It seams to me that I've received an sms w/o sender's number on sim2 using the stock sms client... but unfortunally I've deleted the sms (It was spam :) ) and I'm not 100% sure that it really was without sender's number...
    I don't know how to try to send me an sms without sender's number fo testing...

    Edit: The stock sms client it's different from the one present on previous rom: it show a pop when receiving sms and this popup is not fully localized in english but it contains chinese characters...
  24. bullifrank

    bullifrank Active Member

    Tried this but same result..."white screen" when rebooting
    [​IMG]
  25. ablogik

    ablogik Active Member

    So I have tried to update with 02B06 as explained in this post: http://androidforums.com/4380734-post370.html

    It looks like the update process finished at 83/100 and not 100/100. Got some dialog box in chinese, no clue what that meant. Then, rebooted... but now I am stuck:
    - can't go into recovery anymore (Switch On + VolUp does not work).
    - can't connect to it using adb: device is not listed. Hence, I can't reboot in recovery and either restore a backup, or install the root+gapps update provided.

    The phone looks to work (although I used to have 3g on SIM2, now I always get E). So no root, no gapps, and not sure what's the status of the phone. Need to try some other things and find out how to root and reboot in recovery.

    In the past, I used to get some freeze when switching on WiFi... now no more freeze, but I miss a lot of stuff :(

Share This Page