Go Back   Android Forums > Android Phones > HTC Thunderbolt > Thunderbolt - All Things Root

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old July 19th, 2011, 01:52 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Gender: Male
Posts: 73
 
Device(s): HTC Thunderbolt
Carrier: Verizon Wireless

Thanks: 26
Thanked 7 Times in 6 Posts
Default CM7 and auto-app restore

Does this feature work? I know tesla coil had the option of automatically backing up apps to a google account or something and automatically downloading them when you install a new ROM (or get a new phone). Would this work on my new install of CM7? I see the option, but after about an hour nothing automatically downloaded yet.

Advertisements
Fruban is offline  
Reply With Quote
sponsored links
Old July 19th, 2011, 06:06 AM   #2 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 11,051
 
Device(s):
Carrier: Not Provided

Thanks: 7,916
Thanked 7,248 Times in 4,496 Posts
Default

have you signed in to the market yet? i believe youll need to open the market and acept its terms before anything will auto restore.
__________________
The Delivery Guy
If someone has helped you,please click the THANKS button on that post.
Please post questions so others can benefit from the answers.
donate to my device fund
scotty85 is online now  
Reply With Quote
Old July 19th, 2011, 08:05 AM   #3 (permalink)
Senior Member
 
WormDoes's Avatar
 
Join Date: Aug 2010
Location: Massachusetts
Posts: 3,199
 
Device(s): G2 & Nexus 7
Carrier: Trapped on Verizon

Thanks: 605
Thanked 1,288 Times in 672 Posts
tren8622@gmail.com
Default

CM7 always auto restored my apps. The other AOSP builds do not however. Which sucks because I don't use TiB. Lesson learned. When you did the initial setup, your Google account and such, did you make sure you checked off data backup and restore as an option?
WormDoes is offline  
Reply With Quote
Old July 19th, 2011, 08:40 PM   #4 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Gender: Male
Posts: 73
 
Device(s): HTC Thunderbolt
Carrier: Verizon Wireless

Thanks: 26
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by scotty85 View Post
have you signed in to the market yet? i believe youll need to open the market and acept its terms before anything will auto restore.
Yup, I actually downloaded some apps manually because I couldn't keep waiting.

Quote:
Originally Posted by WormDoes
When you did the initial setup, your Google account and such, did you make sure you checked off data backup and restore as an option?
Under "Privacy" setting, "Back up my data" and " Automatic Restore" both appeared to be checked by default when I visited that setting the first time soon after installing CM7. *shrug*

It's also not auto-retrieving facebook pics to my contacts, though I do appear to have my contacts successfully synced since they're all there. I selected "sync to existing contacts" after being prompted by the set up.

One little thing possibly woth being mentioned was that, because I forgot I had to install gapps with CM7 being AOSP since it's been a while since I've used AOSP, I booted up into CM7 and explored a bit for 5 minutes or so before realizing what I forgot to do. I simply rebooted into clockwork recovery, downloaded the newest gapps for HDPI devices from the CM wiki, and flashed it to the phone. Would booting into CM7 before flashing gapps like that have any effect? For example, I was only able to run the proper google experience setup after flashing gapps, which is why I was confused when I couldnt add a google account prior to flashing gapps.

PS - did they take out the long-press back button app kill function in the newest CM7?
Fruban is offline  
Last edited by Fruban; July 19th, 2011 at 08:48 PM.
Reply With Quote
Old July 19th, 2011, 08:42 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Gender: Male
Posts: 73
 
Device(s): HTC Thunderbolt
Carrier: Verizon Wireless

Thanks: 26
Thanked 7 Times in 6 Posts
Default

Also, I love the avatar, WormDoes. made me LOL when I first read it.

Also, Dexter was one of my favorite cartoons growing up, scotty. Just thought I'd mention that as an afterthought
Fruban is offline  
Reply With Quote
The Following 2 Users Say Thank You to Fruban For This Useful Post:
scotty85 (July 19th, 2011), WormDoes (July 20th, 2011)
Old July 19th, 2011, 10:17 PM   #6 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 11,051
 
Device(s):
Carrier: Not Provided

Thanks: 7,916
Thanked 7,248 Times in 4,496 Posts
Default

no,flashing gapps after the fact shouldnt have anything to do with it. im really not sure what could be going on here. you do have background data and auto-sync turned on in accounts and sync,yes?

heres something you can try if you feel like flip flopping between backups.

-restore a backup that has all the apps you want.
-get titanium backup if you dont have it
-open titanium,go to: menu softkey/more/market doctor. touch ok to run the market doctor. it will go thru all your apps and verify their links to the market. if it finds some that are broken,it has some magic way of finding and fixing them.
-after its done,go to the market. download or update an app. this will cause the market to refresh. afterward,you should see all your apps in the "my apps" section.
-now wipe and go back to your current rom. go to the market. hopefully your apps will be there and be downloading. if they arent downloading,hopefully at least they will be there. im not sure how you might kick-start the market to download,if it isnt doing it. maybe force stop it and then go back in to my apps?

i personally dont care if my apps auto download or not,i can see both sides of the coin why some folks like it and some dont. i just wait for the market to download what its going to(even if that is none ) then run a titanium batch for "missing apps+data" so that tibu restores whatever the market didnt.

but anyway,hopefully the market doctor may work for you.
scotty85 is online now  
Reply With Quote
Old July 19th, 2011, 11:56 PM   #7 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Gender: Male
Posts: 73
 
Device(s): HTC Thunderbolt
Carrier: Verizon Wireless

Thanks: 26
Thanked 7 Times in 6 Posts
Default

My backup ROM, the one i was using before CM7, only uses radio MR1, and now that I have 2, I dont think the market doctor will work. Actually scratch that. Should work with wifi right? If not, couldn't I just do a manual backup with titanium backup? I think I've done that once, as a test, but before I had all the apps I want now and had before installing the new ROM. the FB sync issue is bugging me though. Too bad I can't post in the CM7 developer page about these things though. If it is indeed a ROM issue.
Fruban is offline  
Reply With Quote
Old July 20th, 2011, 12:19 AM   #8 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Gender: Male
Posts: 73
 
Device(s): HTC Thunderbolt
Carrier: Verizon Wireless

Thanks: 26
Thanked 7 Times in 6 Posts
Default

New thought. Maybe the phone's google app backup already thinks I have the apps installed because they're on the SD card, but since they weren't formally installed, the OS doesn't recognize that they're there? Who knows.

Edit: And to throw out some more possibilities, do you know if CM7 1.2 has been optimized at all for the official MR2? Because if it's still based on the leaked one, maybe there are some subtle issues with the ROM and my official MR2 radio, since I'm not using the leaked one.

Edit2: And could there also be some discrepency because of switching from a froyo based ROM to the AOSP (which is based on GB aosp or something? Or is it still froyo based?)
Fruban is offline  
Last edited by Fruban; July 20th, 2011 at 03:31 AM.
Reply With Quote
Old July 20th, 2011, 06:51 AM   #9 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 11,051
 
Device(s):
Carrier: Not Provided

Thanks: 7,916
Thanked 7,248 Times in 4,496 Posts
Default

heres prolly what id do:
restore mr1 cm7. make a backup of all your apps with titanium,just in case. turn on wifi and see if it works... then see if market doctor will run. once youve gotten everything to show up in "my apps",verify the md5 of your cm7 download. go to recovery and do a full wipe of data/cache/dalvik and do a fresh install of mr2 cm7. hopefully your sync issues will resolve
scotty85 is online now  
Reply With Quote
The Following User Says Thank You to scotty85 For This Useful Post:
Fruban (July 20th, 2011)
Old July 20th, 2011, 09:11 PM   #10 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Gender: Male
Posts: 73
 
Device(s): HTC Thunderbolt
Carrier: Verizon Wireless

Thanks: 26
Thanked 7 Times in 6 Posts
Default

I dunno why I have such a hard time with CM7 lol. I want to like it. I DO like it. But I just want it to like me back!

Anyway, the only backup I had was tesla 1.7, for MR1. wifi worked, but I had no signal. Still, I couldn't do the market doctor thing because I dont have the donation version (yeah I'm too poor right now, fresh out of college and looking for a job) so I ended up just manually backing stuff up with Titanium Backup. That's fine, just a minor hassle. Still much better than the days of my LG without an auto backup option at the time or so I thought hehe. Anyway, I installed RC3 of tesla coil GB for MR 2 and 2.5 only because tesla was a good rom for me before with MR1. What I'll do is set that up the way I like it to have a solid working backup with everything just the way I like and I'm familiar with, and bounce between that and CM7 1.2 for MR2 radios.

Also, I think there may have been some whacky issues with my google accounts that may have been affecting android, both on the CM7 1.2 ROM and Tesla Coil RC3 since I couldnt sync contacts and fb pics correctly on either one. On my main gmail account, with all 200 of my contacts, I had a few different "groups" of people, one of which was like 800 something. somehow, it made duplicates, triplicates, and quadruplicates (wow those are real words? lol) of contacts. I think it had something to do with the switch to using sense backup tools coming form the LG ally since some of them had notes indicating HTC in the string of... stuff. Anyway, it was a giant mess.

Luckily, I discovered an auto-merge feature with the contacts which cut down the big number to 333 I think, and I got rid of extra groups and basically just streamlined the whole thing on the account's end. When I set up my accounts this time, I just did one at a time and let it complete the main gmail one first, just basic contacts, before adding my second gmail account and finally the HTC sense version of FB. I'm not sure if there is a reliability difference between AOSP FB account syncing/app vs the sense one, but this one worked, after a while.

My second google account, I discovered, didnt have any worthwhile contacts stored on it, so I just didnt bother syncing anything from it but the mail itself.

In the dialier people settings, I went to People and View and set it so I only show people with numbers. Dunno if that helped, but my logic was that I was trying to cut down on the sheer volume I was trying to sync.

Anyway, something I did here seemed to work, but the app syncing never did. Luckily I just used Titanium Backup. *Whew!*


Edit: *Wall of text hits YOU for 9823 damage*
*You are dead*
Fruban is offline  
Reply With Quote
sponsored links
Reply


Go Back   Android Forums > Android Phones > HTC Thunderbolt > Thunderbolt - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:55 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.