Go Back   Android Forums > Android Phones > Samsung Transfix > Transfix - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old November 22nd, 2011, 02:05 AM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Dec 2010
Posts: 221
 
Device(s): Samsung Galaxy S2 Epic 4G Touch EL29 Rooted Stock
Carrier: Not Provided

Thanks: 28
Thanked 32 Times in 22 Posts
garyschoelkopf@gmail.com
Thumbs up How To Root SCH-730 2.3.4

i did some research and found the right stuff to root this phone
i do not take credit for this at all only for bringing it here to the forums for us here

1. Download the file below
2. extract to desktop
3. run the file that says "run" let it boot
(u may not have installed superuser during the rooting process so i recomend doing so manually by placing it on the root of the sd card and installing it from there)
4. download "Terminal Emulator" from the market
open
type "su" it will ask u to allow it
then type "reboot"


if ur phone reboots then u have root acess
Attached Files
File Type: zip Transfix-root.zip (427.7 KB, 2045 views)

Lilg37 is offline  
Reply With Quote
The Following 5 Users Say Thank You to Lilg37 For This Useful Post:
El Presidente (November 22nd, 2011), ladylora (December 13th, 2011), MrMaynard (November 29th, 2011), sezni (November 22nd, 2011), VooDooChylde (April 22nd, 2012)
sponsored links
Old November 22nd, 2011, 07:37 PM   #2 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

i successful,thank you very much
sezni is offline  
Reply With Quote
Old November 26th, 2011, 11:22 PM   #3 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Didnt work for me

I tried the steps above and when i type su it says permission denied, I dont know what iam doing wrong. Any suggestions would be appreciated
toyotahilux is offline  
Reply With Quote
Old November 27th, 2011, 03:06 PM   #4 (permalink)
Member
Thread Author (OP)
 
Join Date: Dec 2010
Posts: 221
 
Device(s): Samsung Galaxy S2 Epic 4G Touch EL29 Rooted Stock
Carrier: Not Provided

Thanks: 28
Thanked 32 Times in 22 Posts
garyschoelkopf@gmail.com
Default

Did u install superuser.apk from the zip folder befor u tried it?
Lilg37 is offline  
Reply With Quote
Old November 29th, 2011, 05:20 PM   #5 (permalink)
New Member
 
Join Date: Nov 2011
Location: Kansas City, Missouri
Posts: 1
 
Device(s): Samsung Transfix and 64gig iPod touch 4G
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've downloaded the file for rooting the transfix. How do I get it to the desktop?
matthewbeach41 is offline  
Reply With Quote
Old November 29th, 2011, 10:13 PM   #6 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 26,571
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,016
Thanked 15,808 Times in 8,481 Posts
Default

You should just be able to select the desktop as the download location on your PC?

You'll then need a program like Winrar or Winzip to extract the files to your desktop.
__________________
Site Rules & Guidelines / Staff List / Ask the Staff
Want to bring naughty posts to our attention? Use:
Be respectful to each other - That's what we're all about.
El Presidente is offline  
Reply With Quote
The Following User Says Thank You to El Presidente For This Useful Post:
Lilg37 (December 2nd, 2011)
Old December 10th, 2011, 01:33 AM   #7 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

So, just got my Transfix, grabbed this rootkit, got my phone hooked up, installed superuser, extracted the kit to my desktop, ran, run.bat...

and nothing.

printout:
error: unknown host service
"[*] Triggering core dump..."
error: device not found
error: device not found
error: device not found
error: device not found
error: device not found
"Rebooting phone. It may buzz a lot and loop on boot. Don't panic."

And does nothing.
Tried it with USB storage both enabled and disabled. Also, compatibility mode for vista and xp did nothing.
no root wat do?


EDIT: You forgot to add the step to enable USB debugging mode through Settings::Applications:evelopment::USB DEbugging.
img, #cubbies-overlay{ -moz-transition-property: margin, box-shadow, z-index; -moz-transition-duration: 0.1s; -webkit-transition-property: margin, box-shadow, z-index; -webkit-transition-duration: 0.1s; } .cubbies-selected{ z-index: 9999; box-shadow: 3px 3px 8px -1px blue !important; cursor: pointer !important; margin: -3px 3px 3px -3px; } .cubbies-selected:active{ box-shadow: 2px 2px 5px -1px darkblue !important; margin: -1px 1px 1px -1px; } #cubbies-overlay{ position: fixed; z-index: 9999; bottom: 30px; left: 30px; box-shadow: 0 2px 3px rgba(0,0,0,0.8); border: none; } #cubbies-overlay:hover{ box-shadow: 0 2px 3px rgb(0,0,0); }
SmilingAhab is offline  
Last edited by SmilingAhab; December 10th, 2011 at 01:37 AM.
Reply With Quote
The Following User Says Thank You to SmilingAhab For This Useful Post:
gatecrasher59 (April 13th, 2012)
Old December 19th, 2011, 05:48 PM   #8 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

im having the same problem, i have super user installed along with terminal emulator. I have debugging on, and have tried running run.bat only to get the same message shown above. Still without root. What do i do now?
sthcom is offline  
Reply With Quote
Old December 28th, 2011, 11:30 AM   #9 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

alight extract the first file that says run then open the file that was extracted then hit the one that says run then it should reboot your phone!
TOP FLIGHT is offline  
Reply With Quote
Old January 13th, 2012, 10:01 AM   #10 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Finally got root awhile ago, any idea when we might see a ROM for this phone?
sthcom is offline  
Reply With Quote
sponsored links
Old January 13th, 2012, 01:00 PM   #11 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine is rebooting and its still sitting here with samsung on the screen and keeps vibrating. I'm starting to worry.
TeslaFreakshow is offline  
Reply With Quote
Old January 23rd, 2012, 04:01 PM   #12 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Question Rooting Transfix

How is it that you run the "run" script from the phone? I've tried running the script from a terminal emulator with no success, and even opened the file in a text editor to see if my programming knowledge might help.

1. Download to Desktop
2. Move to SDCard
3. Install Superuser on root of SDCard
4. Run script how?

Thanks. Any help is greatly appreciated for this noob.

P.S. When I try and open the run.bat file, I receive the following message: "File type bat not recognized"
nixnax is offline  
Last edited by nixnax; January 23rd, 2012 at 09:23 PM. Reason: Post Script
Reply With Quote
Old January 25th, 2012, 05:40 PM   #13 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same...

Quote:
Originally Posted by TeslaFreakshow View Post
Mine is rebooting and its still sitting here with samsung on the screen and keeps vibrating. I'm starting to worry.

Same thing for myself...
nixnax is offline  
Reply With Quote
Old January 30th, 2012, 01:48 PM   #14 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

NIXNAX You aren't using a Windows system are you? .bat is windows specific.
My problems were solved by downloading and installing the Transfix drivers (it took an extremely long time for them to install from my phone, there were about 5 more drivers when debugging is active)
Let it sit for a while and everything install, then run "run.bat" mine worked flawlessly after i waited for everything to install.
All of this needed to be done on windows. i tried Mac, and linux XD
sthcom is offline  
Last edited by sthcom; January 30th, 2012 at 01:53 PM. Reason: Incomplete.
Reply With Quote
Old February 7th, 2012, 07:06 PM   #15 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

doesn't even work for me...
christa18 is offline  
Reply With Quote
Old February 7th, 2012, 07:25 PM   #16 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i even tried it several ways PLEASE HELP. text me other ways if youd like please.. 724 425 6830
christa18 is offline  
Reply With Quote
Old February 13th, 2012, 02:19 AM   #17 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I rooted but ran into some problems. I just took my time and tried a few things and it worked. This is what I did...

Pre-rooting steps.
1. Plug in your Samsung Transfix to your pc. Make sure drivers load.
2. Go to Settings>Applications>Development> and check USB Debugging

1. Download the file above
2. Extract to desktop or in the folder of your choice.
3. Run the file that says "run". It will load a screen and run through the process and reboot your phone. It said on my pc to enjoy my rooted phone.
4. Download "Superuser" from the market. Install and run.
5. Download "Terminal Emulator" from the market
open
type "su" it will ask u to allow it
then type "reboot" if it doesn't reboot, type it again. I had to do it twice for some reason. I think because of the $ and # signs....$ is normal and #is SU.

Should look like this
Code:
$ export PATH=data/local/bin:$path
$_
After you type in SU it should show the # sign. This will let you know if you are rooted and have SU access.

I am a total newb to rooting(my first root) and with little troubleshooting and not the best guide in the world to follow off of I think it went pretty smooth.
Hope this helps.
Delirious84 is offline  
Reply With Quote
Old March 6th, 2012, 10:25 AM   #18 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you!!!
taylor441 is offline  
Reply With Quote
Old March 8th, 2012, 10:25 AM   #19 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 21
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default still no root

titanium backup says its not rooted
reenoip1 is offline  
Reply With Quote
Old March 18th, 2012, 11:30 AM   #20 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

now how do i get free apps and customize my phone the way i want it?


p.s. thanks to everyone, i used a little from each and got it
Menchaca is offline  
Reply With Quote
sponsored links
Old April 9th, 2012, 11:14 AM   #21 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can anyone post a video on yosutube on this process because i dont want to risk screwing up my phone.
Scotty2000 is offline  
Reply With Quote
Old April 15th, 2012, 08:33 PM   #22 (permalink)
New Member
 
seediqbale's Avatar
 
Join Date: Apr 2012
Location: Phoenix, AZ
Gender: Male
Posts: 8
 
Device(s): ZTE Warp Sequent
Carrier: Boost Mobile

Thanks: 3
Thanked 1 Time in 1 Post
Cool it works

tanx a bunch
seediqbale is offline  
Reply With Quote
Old April 22nd, 2012, 01:27 PM   #23 (permalink)
New Member
 
Join Date: Apr 2012
Location: wisconsin
Posts: 1
 
Device(s): samsung transfix SCH-730
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Lilg37 View Post
i did some research and found the right stuff to root this phone
i do not take credit for this at all only for bringing it here to the forums for us here

1. Download the file below
2. extract to desktop
3. run the file that says "run" let it boot
(u may not have installed superuser during the rooting process so i recomend doing so manually by placing it on the root of the sd card and installing it from there)
4. download "Terminal Emulator" from the market
open
type "su" it will ask u to allow it
then type "reboot"


if ur phone reboots then u have root acess
Thanks so much just got the transfix and it was a little different to root but thanks to you I got it done, Thanks!!
VooDooChylde is offline  
Reply With Quote
Old May 7th, 2012, 03:17 AM   #24 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Basically this is pissing me off.. Can someone give me the play by play.. Cause all of this is crazy talk to me.. And I really just want a screen shot app.. I got the zip file on my desktop I got the emulator and I have super user.. Why is this not working?!
ninafbabyy is offline  
Reply With Quote
Old May 7th, 2012, 10:22 AM   #25 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 40
 
Device(s): HTC Evo 4g (x3), Nook Color (rooted)
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by SmilingAhab View Post
error: device not found
This may or may not help, but when I was rooting a different phone and kept running into this problem, it turned out that I had NOT selected the option to mount the phone as a "Disk Drive" in Android Settings on the phone. The option to charge only (as in charge the battery) was selected.

Once I went into Settings > Connect to PC > Default Connection Type _or_ selected the USB option in the notifications tray and changed from Charge to 'Disk Drive', I was able to get past this error.

One other possible source of problems: If you have a "Charge Only" cable that doesn't have the wiring to sync, you'll get the same type of error. Believe it or not, some cheap cables lack the wiring for data sync (mount as Disk Drive) but do charge... I know, I have one. So make sure that you use a USB Cable that is known to have the complete wiring for data...

Hope that helps someone...
OldDogEyes is online now  
Reply With Quote
Old June 4th, 2012, 01:38 PM   #26 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Talking Not able to root my transfix

First, I was wondering if you have to install the software to a pc. Second, I was wondering how do you turn off the charging option only when it's connected to a pc? Mine doesn't have the option under settings to change that unless it's somewhere else. PLEASE HELP! I am so new to this I am totally lost! You can text me tips if that'd be easier to 832 329 7092
lengelke is offline  
Reply With Quote
Old June 15th, 2012, 07:36 PM   #27 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Ziplip

Quote:
Originally Posted by TeslaFreakshow View Post
Mine is rebooting and its still sitting here with samsung on the screen and keeps vibrating. I'm starting to worry.
This is happening to me too, I don't know what's going on.
sweetxo is offline  
Reply With Quote
Old June 18th, 2012, 09:25 AM   #28 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i am mad confused... I did everything but I cant figure out how to install an .apk file from the root of the sd card... Grrrr...

EDIT: I am dumb, i figured it all out... ROOT SUCCESSFUL

Now how do i move all my apps to my sd card?
smoore5527 is offline  
Last edited by smoore5527; June 18th, 2012 at 09:48 AM. Reason: solved!
Reply With Quote
Old June 18th, 2012, 07:12 PM   #29 (permalink)
Member
 
smokinjoe2122's Avatar
 
Join Date: May 2011
Location: Wisconsin
Posts: 100
 
Device(s): Samsung Vitality Spz0's Open Android 2.3.6
Carrier: Not Provided

Thanks: 10
Thanked 7 Times in 4 Posts
jtischer1979
Default

Quote:
Originally Posted by smoore5527 View Post
i am mad confused... I did everything but I cant figure out how to install an .apk file from the root of the sd card... Grrrr...

EDIT: I am dumb, i figured it all out... ROOT SUCCESSFUL

Now how do i move all my apps to my sd card?
You can run DTA2SD, which is a script that allows your apps to run from SD, but you need to partition your sd card correctly, and there's always a decent chance your phone will not boot up after using it. Since we don't have a custom recovery, I'd suggest NOT to do it, unless you feel adventurous.

The way I was able to free up some space is download and run Link2SD. You have to still manually partition your SD card with 2 primary partitions, one Fat32 and the other ext2 (or 3 cannot remember) and run the program.

Good luck
smokinjoe2122 is offline  
Reply With Quote
Old July 9th, 2012, 04:53 AM   #30 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Worked great for me... Was finally able to get rid of that useless Facebook app!
FuzzyLogic1960 is offline  
Reply With Quote
sponsored links
Old July 31st, 2012, 11:32 PM   #31 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Everytime i type in "su" it says not found, H E L P ! :/
-James
JamesSimmons is offline  
Reply With Quote
Old August 4th, 2012, 12:47 AM   #32 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default question

Which. Terminal Emulator. Do i have to install to root my Samsung transfix
Arturo 12 is offline  
Reply With Quote
Old September 9th, 2012, 02:26 PM   #33 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I find that ConnectBot Is the easiest to use.
Curlyfriez is offline  
Reply With Quote
Old December 10th, 2012, 10:52 AM   #34 (permalink)
New Member
 
Join Date: Dec 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello everyone just got a transfix from my gf she upgraded so i got it for free running with out a network so figured i go modding i have success in flashing to honey comb with my viewsonic G-Tablet what a kickass tablet so just a update i ran the the zip file with the phone plugged into to th computer it updated and then through superuser i updated the root!!!! so i am still gonna try running terminal will keep u posted
xKurzx is offline  
Reply With Quote
Old January 4th, 2013, 10:36 PM   #35 (permalink)
New Member
 
Join Date: May 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I keep getting a .htm file. Any help?
AndZak7106 is offline  
Reply With Quote
Old March 3rd, 2013, 04:41 PM   #36 (permalink)
New Member
 
Join Date: Feb 2013
Location: CC TX
Gender: Male
Posts: 8
 
Device(s): Boost Samsung Transform Ultra, Boost HTC Evo Design 4g, Cricket Samsung Transfix
Carrier: Boost, and Cricket

Thanks: 3
Thanked 3 Times in 1 Post
Default

the odin method is so much easier...any way i can use it on the transfix like i did my transform ultra?
CWM files anyone?
bill_is_sailin is offline  
Reply With Quote
Old September 21st, 2013, 09:12 PM   #37 (permalink)
New Member
 
Join Date: Sep 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Multiple fails

I followed all the instructions to the letter, but when I went to download the app, there was no app that just said "Terminal Emulator" as was suggested... I tried MULTIPLE emulators, finally settling on "ConnectBot", but when I attempted to reboot, I kept getting the error "Not Permitted". Not permitted, just like every damned thing else in this crap phone. Okay, so I tried again, uninstalling SuperUser and ConnectBot, using the updated SuperUser on the playstore... Still nothing. What the hell? Are these outdated instructions? Am I doing something wrong? I can't even seem to generate some kind of useful error... just... NOT PERMITTED!
Enigma is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Transfix > Transfix - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:16 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.