Go Back   Android Forums > Android Phones > Motorola Triumph > Triumph - All Things Root

Like Tree28Likes

test: Reply
 
LinkBack Thread Tools
Old October 26th, 2012, 10:12 AM   #1 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Thumbs up [CLOSED][RECOVERY][UPDATE: 11/30/2012] CWM Recovery 6.0.1.9 by b_randon14[CLOSED]

Thread no longer being maintained as I don't have the device. Download links no longer work. Sorry for any inconvenience.

Advertisements
__________________
Donate if you like my work!

Gain 250mb and help me out, sign up for Dropbox here: 250mb Extra Space on Dropbox

find / -user your -name base -exec chown us:us '{}' ';'
b_randon14 is offline  
Last edited by b_randon14; December 31st, 2013 at 10:39 PM. Reason: Closed.
Reply With Quote
The Following 16 Users Say Thank You to b_randon14 For This Useful Post:
askdjhf (August 19th, 2013), bluetec (October 26th, 2012), BSydz (October 28th, 2012), calitrippin (October 26th, 2012), Chairshot215 (October 28th, 2012), Cyta (October 30th, 2012), djboi2011 (October 26th, 2012), g60madman (October 26th, 2012), Inc0gnit0 (October 27th, 2012), inub (October 28th, 2012), Izzard (October 26th, 2012), jimg3081 (October 26th, 2012), mattbodin (November 3rd, 2012), MikeRL (October 26th, 2012), sqwerl (February 26th, 2013), thangfish (October 26th, 2012)
sponsored links
Old October 26th, 2012, 11:40 AM   #2 (permalink)
Member
 
Join Date: Apr 2012
Gender: Male
Posts: 450
 
Device(s): LG Nexus 4, Asus Nexus 7, Motorola Triumph, & LG Optimus V - All Hacked & Running CyanogenMod!
Carrier: T-Mobile USA

Thanks: 226
Thanked 194 Times in 129 Posts
Default

Can you make one with the regular light blue theme? I find this recovery to be awesome, but it's a bit odd for me to see it in yellow green. If it's a pain to do that, don't do it.
Bob Blaylock likes this.
__________________
Be a pal and sign up for Dropbox with this URL (if you haven't already got an account) It will assist me and you by giving us both an extra 500MB space. Useful for all the uploads I share with you guys.
MikeRL is offline  
Reply With Quote
Old October 26th, 2012, 11:52 AM   #3 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Yeah I can make a couple different themes ones if you all would like that!
b_randon14 is offline  
Reply With Quote
The Following 3 Users Say Thank You to b_randon14 For This Useful Post:
Inc0gnit0 (October 27th, 2012), inub (October 28th, 2012), MikeRL (October 26th, 2012)
Old October 26th, 2012, 12:20 PM   #4 (permalink)
Member
 
Join Date: Mar 2012
Posts: 185
 
Device(s): Triumph
Carrier: Not Provided

Thanks: 85
Thanked 56 Times in 41 Posts
Default

Seeing that our phone is not abandoned by community, seeing this little updates like CWM, or themes on forgotten Stock, or Sharp Roms, not to mentioned bigger things like CM9 and Kernel updates make me believe that I will use Triumph for the next 10 years.
Thank you guys for the hard work.

Flashed it right away and re-flashed CM9 update 2. No issues so far.
g60madman likes this.
Izzard is offline  
Reply With Quote
The Following User Says Thank You to Izzard For This Useful Post:
g60madman (October 26th, 2012)
Old October 26th, 2012, 12:32 PM   #5 (permalink)
Member
 
Join Date: Jan 2012
Posts: 151
 
Device(s): Motorola Triumph,LG Optimus V
Carrier: Not Provided

Thanks: 21
Thanked 39 Times in 35 Posts
Default

Quote:
Originally Posted by b_randon14 View Post
Yeah I can make a couple different themes ones if you all would like that!
Cyan would be sweet...i think its the reason i like cm so much
jamesd1085 is offline  
Reply With Quote
Old October 26th, 2012, 12:44 PM   #6 (permalink)
ROM Developer
 
dsmryder's Avatar
 
Join Date: May 2011
Location: NE Florida
Posts: 2,295
 
Device(s): Samsung Epic Touch 4G running whatever I throw at it
Carrier: Ting for now

Thanks: 371
Thanked 487 Times in 338 Posts
Default

Maybe a version with power as the select button? For those who have dead capacitive buttons. You know, because I know you have sooooo much time.
dsmryder is offline  
Last edited by dsmryder; October 29th, 2012 at 12:56 PM. Reason: I use swype to type.
Reply With Quote
Old October 26th, 2012, 01:17 PM   #7 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Lol yeah ill make a power button select version as well! When I get the time of course lol!! :P
inub likes this.
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
inub (October 28th, 2012)
Old October 26th, 2012, 01:18 PM   #8 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

And I'm thinking stock looking, maybe cyan, red, maybe even one for the girls, and then a sweet mtdev themed version!!
g60madman and inub like this.
b_randon14 is offline  
Reply With Quote
The Following 2 Users Say Thank You to b_randon14 For This Useful Post:
g60madman (October 26th, 2012), inub (October 28th, 2012)
Old October 26th, 2012, 02:24 PM   #9 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 37
 
Device(s): Nexus 4 Galaxy Nexus EVO V 4G Viewsonic GTab
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 5 Posts
Default

Awesome. Did you leave the option to select backup type? DUP is the default and I do not want to use this incremental backup type. Hopefully once TAR is chosen the first time, CWM will write a small file to remember this selection. At least this is the way 6.0.1.5 works on my GNex. Most users will want to toggle the backup type to TAR the first time they use it. Thanks again! B_randon
bluetec is offline  
Reply With Quote
Old October 26th, 2012, 05:53 PM   #10 (permalink)
Member
 
Join Date: Jan 2012
Posts: 151
 
Device(s): Motorola Triumph,LG Optimus V
Carrier: Not Provided

Thanks: 21
Thanked 39 Times in 35 Posts
Default

Quote:
Originally Posted by b_randon14 View Post
And I'm thinking stock looking, maybe cyan, red, maybe even one for the girls, and then a sweet mtdev themed version!!
The MTDEV theme is a must...lol...they have 180'd the triumph in a matter of a few months...we all have a reason to love our triumphs now...full op ics is only steps away!
jamesd1085 is offline  
Reply With Quote
sponsored links
Old October 26th, 2012, 06:06 PM   #11 (permalink)
ROM Developer
 
g60madman's Avatar
 
Join Date: Oct 2011
Location: New Mexico, USA
Gender: Male
Posts: 1,816
 
Device(s): I have worked on: Galaxy Nexus, HTC Evo V 4g, Motorola Triumph, Samsung S3, S4 and Victory
Carrier: Verizon

Thanks: 844
Thanked 2,810 Times in 772 Posts
Default

Quote:
Originally Posted by jamesd1085 View Post
The MTDEV theme is a must...lol...they have 180'd the triumph in a matter of a few months...we all have a reason to love our triumphs now...full op ics is only steps away!
Don't forget b_randon is part of Team MTDEV He is just the quite developer in the back of the room mixing up the wicked kernel potions
g60madman is offline  
Reply With Quote
Old October 26th, 2012, 06:31 PM   #12 (permalink)
Member
 
Join Date: Jan 2012
Posts: 151
 
Device(s): Motorola Triumph,LG Optimus V
Carrier: Not Provided

Thanks: 21
Thanked 39 Times in 35 Posts
Default

I know hes part of mtdev...im hopin that you guys figure this kernel out...and that it will make the triumph so nice he wont wanna jump to straight talk...we know you have been busy lately b-randon but you and all of mtdev have been crucial to the distance made in fixing the triumph
jamesd1085 is offline  
Reply With Quote
Old October 26th, 2012, 06:56 PM   #13 (permalink)
Senior Member
 
thangfish's Avatar
 
Join Date: Sep 2011
Posts: 1,311
 
Device(s): Triumph - CM7.2.0 mostly
Carrier: Not Provided

Thanks: 331
Thanked 352 Times in 265 Posts
Default

I restored a backup of Froyo Ics to use hdmi and while I was at it I installed this recovery.

When I finished, I restored Cm7 from backup and bootlooped. Tried multiple times.

Went back to cwm 504 and restored same back-up successfully.

Don't know what's up. Any ideas?

Colors?
I don't care at all, but the lime green selection w/ white letters is impossible to read... At least to me.

Thanks for all the work on this, b!
Bob Blaylock likes this.
thangfish is offline  
Reply With Quote
Old October 26th, 2012, 11:00 PM   #14 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Quote:
Originally Posted by bluetec View Post
Awesome. Did you leave the option to select backup type? DUP is the default and I do not want to use this incremental backup type. Hopefully once TAR is chosen the first time, CWM will write a small file to remember this selection. At least this is the way 6.0.1.5 works on my GNex. Most users will want to toggle the backup type to TAR the first time they use it. Thanks again! B_randon
Yeah that option is there and once you choose it, it sticks! It saves a file in the clockworkmod directory!
b_randon14 is offline  
Reply With Quote
Old October 26th, 2012, 11:02 PM   #15 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Quote:
Originally Posted by thangfish View Post
I restored a backup of Froyo Ics to use hdmi and while I was at it I installed this recovery.

When I finished, I restored Cm7 from backup and bootlooped. Tried multiple times.

Went back to cwm 504 and restored same back-up successfully.

Don't know what's up. Any ideas?

Colors?
I don't care at all, but the lime green selection w/ white letters is impossible to read... At least to me.

Thanks for all the work on this, b!
Hmm that is odd. I have restored cm7 quite a few times testing things out. I'm hoping we wont run into issues with backups made with older recoveries.

And yeah I can understand that. I'm just partial to line green if you guys didn't catch on yet lol!
b_randon14 is offline  
Reply With Quote
Old October 28th, 2012, 07:51 AM   #16 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Okay so I have added a ICS Blue and Red themed, the ICS Blue looks close to stock colors with a little tweaking, very easy on the eye, and the Red one is well a red themed one lol!

I also added a power select version as well. It is ICS Blue, but I mapped it so that the power button selects items. Right now I am looking into finding out how to enable to where it always shows the back menu item. I believe its by defining has no select button in the BoardConfig, but i'm not for sure. If anyone knows for sure let me know!

Hope everyone enjoys these new colors!
calitrippin and inub like this.
b_randon14 is offline  
Reply With Quote
The Following 5 Users Say Thank You to b_randon14 For This Useful Post:
calitrippin (October 28th, 2012), Inc0gnit0 (October 28th, 2012), inub (October 28th, 2012), rebel69ization (October 28th, 2012), thangfish (October 28th, 2012)
Old October 28th, 2012, 11:14 AM   #17 (permalink)
ROM Developer
 
Chairshot215's Avatar
 
Join Date: Aug 2011
Location: Illadelvall Pennsy
Posts: 725
 
Device(s): Starship_Triumph_Class_WX435 Evo V 4G (Angry Bean AOSP 4.2.2 / Starship Evo_V Class_Beta) Kindle F
Carrier: Not Provided

Thanks: 286
Thanked 535 Times in 204 Posts
All the time
Default

This is awesome, so happy adb will work. I am in the middle of re-setting up my environment when I deleted the document I saved things like the adb udev rules for triumph and this just popped up when I tried to Google them.

Still seem to not be able to find the udev rules if anyone has them handy,lol.
Chairshot215 is offline  
Reply With Quote
Old October 28th, 2012, 12:20 PM   #18 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Quote:
Originally Posted by Chairshot215 View Post
This is awesome, so happy adb will work. I am in the middle of re-setting up my environment when I deleted the document I saved things like the adb udev rules for triumph and this just popped up when I tried to Google them.

Still seem to not be able to find the udev rules if anyone has them handy,lol.
What I do is Google udev android or something and there is a cm7 wiki page talking about how to make your udev file. And to get our vendor ids and stuff just hook your phone up and have advanced debugging on and type lsusb in the terminal on your desktop. It will list all USB devices and ours will be foxconn. Do the sane for recovery cause the ids are different.

Remember to restart udev again and unplug and plug the phone back in. Also if you want when I get back on my Linux box ill copy my udev rules and post them for easy access!!
Chairshot215 likes this.
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
Chairshot215 (October 28th, 2012)
Old October 28th, 2012, 01:29 PM   #19 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 78
 
Device(s): Motorola Triumph with U9000 ROM
Carrier: Not Provided

Thanks: 99
Thanked 29 Times in 24 Posts
Default

Thanks for the color options b_randon. I'm using the blue variation now but you might want to think about making the highlighted text on the lime green version black instead of white so it's easier to read :-)
Inc0gnit0 is offline  
Reply With Quote
The Following User Says Thank You to Inc0gnit0 For This Useful Post:
b_randon14 (October 28th, 2012)
Old October 28th, 2012, 03:20 PM   #20 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 78
 
Device(s): Motorola Triumph with U9000 ROM
Carrier: Not Provided

Thanks: 99
Thanked 29 Times in 24 Posts
Default

Has anyone tried restoring a Froyo ROM to see if it will restore properly? I did two backup's, one with dup and one with tar, and I see the tar files are named correctly (ext3) as opposed to CWM 5.5.0.4 which gives them an ext4 extension. I found out the hard way that CWM 5.5.0.4 does not seem to restore Froyo backups properly, even when you rename the backups to ext3 and change the extensions in the md5 hash file.

I really do not want to have to install from scratch again while testing other ROM's.
Inc0gnit0 is offline  
Reply With Quote
sponsored links
Old October 28th, 2012, 03:36 PM   #21 (permalink)
Member
 
Bob Blaylock's Avatar
 
Join Date: Apr 2012
Location: 38° 28′ North, 121° 26′ West
Gender: Male
Posts: 123
 
Device(s): Motorola Triumph
Carrier: Virgin Mobile

Thanks: 18
Thanked 35 Times in 28 Posts
Default

Quote:
Originally Posted by b_randon14 View Post
And yeah I can understand that. I'm just partial to line green if you guys didn't catch on yet lol!
Quote:
Originally Posted by b_randon14 View Post
Okay so I have added a ICS Blue and Red themed, the ICS Blue looks close to stock colors with a little tweaking, very easy on the eye, and the Red one is well a red themed one lol!
I'd like to express the opinion that the “ICS Blue” ought to be the default. “Easy on the eyes” is important, especially on a small screen, and especially for a cranky old man like me whose eyes aren't what they were when they were younger. (Though I think that even when my eyes were at their prime, I still would have found your “Lime green” scheme to be harsh and uncomfortable.)
Bob Blaylock is offline  
Reply With Quote
Old October 28th, 2012, 03:57 PM   #22 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Yeah as long as the file names are right. See when restoring, cwm parses the ext3 or ext4 or whatever out of the filename in order to determine what to format the partition as. And on the old 5.5 recovery, the recovery.fstab defined system data and cache all as ext4 so even when backing up a stock rom in the recovery those partitions were mounted as ext4.

But I fixed that issue in this cwm build. I set system data and cache as auto so it mounts it as whatever the partition is formatted as. So on a stock rom it formats it all to ext3 and on cm it formats system to ext4 and the rest stay ext3 but get mounted as ext4 by cm7 when the rom loads.

In the old 5.0.2 recoveries, you could specify two filesystems in recovery.fstab and so we had ext4 and ext3 listed which is why we never had that problem before!!

Long story short, yes restoring a stock, or even sharp or x6 variant rom, will work with this cwm recovery.
jamesd1085 and Inc0gnit0 like this.
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
Inc0gnit0 (October 28th, 2012)
Old October 28th, 2012, 05:01 PM   #23 (permalink)
Member
 
Join Date: Jan 2012
Posts: 151
 
Device(s): Motorola Triumph,LG Optimus V
Carrier: Not Provided

Thanks: 21
Thanked 39 Times in 35 Posts
Default

It works very nice for cm9...finished restoring so quickly I thought for sure it didn't restore...but it booted and all was as I left it...only problem is I keep booting into recovery to find a near colorless recovery screen that I can't read...it has buggy lines running through it and just isn't right...about 1 in 10 boots into recovery it comes up with full color and looks great...I have used both the red and the ics blue neither working correctly...I used flash able files...could there be a problem with the flash able files...I flashed twrp and it works perfectly...any ideas
jamesd1085 is offline  
Reply With Quote
Old October 28th, 2012, 06:05 PM   #24 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 78
 
Device(s): Motorola Triumph with U9000 ROM
Carrier: Not Provided

Thanks: 99
Thanked 29 Times in 24 Posts
Default

Thanks for the explanation b_randon.
Inc0gnit0 is offline  
Reply With Quote
Old October 28th, 2012, 08:07 PM   #25 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Quote:
Originally Posted by b_randon14 View Post
What I do is Google udev android or something and there is a cm7 wiki page talking about how to make your udev file. And to get our vendor ids and stuff just hook your phone up and have advanced debugging on and type lsusb in the terminal on your desktop. It will list all USB devices and ours will be foxconn. Do the sane for recovery cause the ids are different.

Remember to restart udev again and unplug and plug the phone back in. Also if you want when I get back on my Linux box ill copy my udev rules and post them for easy access!!
Here is my udev code for the Triumph:
Code:
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0489", ATTRS{idProduct}=="c000", MODE="0660", OWNER="brandon" #Triumph Normal Mode
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0489", ATTRS{idProduct}=="c002", MODE="0660", OWNER="brandon" #Triumph Recovery Mode
Change owner to whatever your username is on your linux machine!
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
Chairshot215 (October 31st, 2012)
Old October 28th, 2012, 08:14 PM   #26 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

I just re uploaded a new power select version to my drop box. The only change I did was make it to always show the go back menu item at the bottom of every menu so that you don't have to use the capacitive buttons at all to navigate through the recovery. The zip name is the same so if you have already downloaded it, redownload it and install it. I tested it out and it works great.

As for the weird colors, I have never experienced this at all using these recoveries. And I installed mine using a zip so maybe it was a bad download. But it defiantly should not be doing this!
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
dsmryder (October 29th, 2012)
Old October 29th, 2012, 03:53 PM   #27 (permalink)
Senior Member
 
thangfish's Avatar
 
Join Date: Sep 2011
Posts: 1,311
 
Device(s): Triumph - CM7.2.0 mostly
Carrier: Not Provided

Thanks: 331
Thanked 352 Times in 265 Posts
Default

I get this some too.. It's the old washed out screen thing like stock ROM used to do occasionally. If it comes up like that, I go to reload recovery, under advanced (I know it's hard to read in this condition) and it usually comes back rendered correctly.

Haven't seen this screen condition in ages.
thangfish is offline  
Reply With Quote
Old October 30th, 2012, 12:15 AM   #28 (permalink)
Member
 
Join Date: Jan 2012
Posts: 151
 
Device(s): Motorola Triumph,LG Optimus V
Carrier: Not Provided

Thanks: 21
Thanked 39 Times in 35 Posts
Default

Yeah that works...its weird though...usually first boot is Color faded second boot is almost pure white and cannot be seen while third time is always the charm...like clockwork...lol
jamesd1085 is offline  
Reply With Quote
Old October 30th, 2012, 05:27 PM   #29 (permalink)
Member
 
Join Date: Feb 2012
Posts: 108
 
Device(s):
Carrier: Not Provided

Thanks: 64
Thanked 40 Times in 34 Posts
Default

B_randon14 killing it as always. Awesome.
Cyta is offline  
Reply With Quote
The Following User Says Thank You to Cyta For This Useful Post:
b_randon14 (October 30th, 2012)
Old October 31st, 2012, 08:05 AM   #30 (permalink)
Senior Member
 
thangfish's Avatar
 
Join Date: Sep 2011
Posts: 1,311
 
Device(s): Triumph - CM7.2.0 mostly
Carrier: Not Provided

Thanks: 331
Thanked 352 Times in 265 Posts
Default

Has anyone noticed that backups made with this are friggin huge? Almost twice as big... And that's after wiping cache and dalvik.
thangfish is offline  
Reply With Quote
sponsored links
Old October 31st, 2012, 10:02 AM   #31 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 37
 
Device(s): Nexus 4 Galaxy Nexus EVO V 4G Viewsonic GTab
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 5 Posts
Default

Did you toggle the backup type to .tar? The .dup backup can be huge, especially the first one. Good idea to wipe cache/dalvik to save space. Why didn't I think of that earlier?


Quote:
Originally Posted by thangfish View Post
Has anyone noticed that backups made with this are friggin huge? Almost twice as big... And that's after wiping cache and dalvik.
bluetec is offline  
Reply With Quote
Old October 31st, 2012, 10:46 AM   #32 (permalink)
Senior Member
 
thangfish's Avatar
 
Join Date: Sep 2011
Posts: 1,311
 
Device(s): Triumph - CM7.2.0 mostly
Carrier: Not Provided

Thanks: 331
Thanked 352 Times in 265 Posts
Default

Quote:
Originally Posted by bluetec View Post
Did you toggle the backup type to .tar? The .dup backup can be huge, especially the first one. Good idea to wipe cache/dalvik to save space. Why didn't I think of that earlier?
yeah, I did... found out that appextractor can't read the backups either.

and yeah, wiping first can save 100-200 mb... well it used to anyway.
thangfish is offline  
Reply With Quote
Old October 31st, 2012, 11:45 AM   #33 (permalink)
Senior Member
 
thangfish's Avatar
 
Join Date: Sep 2011
Posts: 1,311
 
Device(s): Triumph - CM7.2.0 mostly
Carrier: Not Provided

Thanks: 331
Thanked 352 Times in 265 Posts
Default

Ok, my mistake!
I took the time to do a comparison between 6015 and 5504 and the backup was only 100mb larger, which is completely understandable.

Seems my ROM installation has grown considerably since I last checked.
thangfish is offline  
Reply With Quote
Old October 31st, 2012, 12:35 PM   #34 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

They should only be about 60mb bigger because it backs up hidden hidden/data and the mobile partition!
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
thangfish (October 31st, 2012)
Old November 1st, 2012, 07:08 PM   #35 (permalink)
Member
 
rebel69ization's Avatar
 
Join Date: Jun 2012
Posts: 193
 
Device(s):
Carrier: Not Provided

Thanks: 114
Thanked 27 Times in 23 Posts
Default

b_randon ics cwm is EXCELLENT! Thank You
rebel69ization is offline  
Reply With Quote
The Following User Says Thank You to rebel69ization For This Useful Post:
b_randon14 (November 3rd, 2012)
Old November 3rd, 2012, 07:57 PM   #36 (permalink)
Member
 
Join Date: Aug 2012
Location: Texas
Posts: 113
 
Device(s): Motorola Triumph, Coby Kyros MID 7015
Carrier: Not Provided

Thanks: 57
Thanked 12 Times in 12 Posts
mattlb0619
Default

Is the blobs folder a temp folder?
mattbodin is offline  
Reply With Quote
Old November 3rd, 2012, 08:20 PM   #37 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Quote:
Originally Posted by mattbodin View Post
Is the blobs folder a temp folder?
If you have the default backup type set to dedupe it is an essential part of the backup. Its where it store information and prices of the backup. See dedupe style backups check to see what has changed and only backs up what's changed. It uses the prices in the blobs folder to check all that. I recommend changing to tar format backups as they are simpler and like the old style!
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
mattbodin (November 4th, 2012)
Old November 4th, 2012, 10:08 AM   #38 (permalink)
Member
 
Join Date: Jan 2012
Posts: 151
 
Device(s): Motorola Triumph,LG Optimus V
Carrier: Not Provided

Thanks: 21
Thanked 39 Times in 35 Posts
Default

Still getting the whitewashed screen constantly...tried mtdev unroot to make sure all the symlinks were intact...used all 4 versions and applied by flashing and using PC...all versions the same...all older cwm versions work fine and twrp...I don't get it...any chance on you guys updating twrp to run like this one...I love twrps UI but the reliability of this cwm is the best I have seen so far...ever since last update I have not had any failed restores
jamesd1085 is offline  
Reply With Quote
Old November 4th, 2012, 03:56 PM   #39 (permalink)
Member
 
Join Date: Aug 2012
Location: Texas
Posts: 113
 
Device(s): Motorola Triumph, Coby Kyros MID 7015
Carrier: Not Provided

Thanks: 57
Thanked 12 Times in 12 Posts
mattlb0619
Default

Quote:
Originally Posted by b_randon14 View Post
If you have the default backup type set to dedupe it is an essential part of the backup. Its where it store information and prices of the backup. See dedupe style backups check to see what has changed and only backs up what's changed. It uses the prices in the blobs folder to check all that. I recommend changing to tar format backups as they are simpler and like the old style!
So if I don't have any dedupe backups I can delete the folder?
mattbodin is offline  
Reply With Quote
Old November 4th, 2012, 06:21 PM   #40 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

Quote:
Originally Posted by mattbodin View Post
So if I don't have any dedupe backups I can delete the folder?
Yeah if you change it to tar backups, the blobs folder is not used!
b_randon14 is offline  
Reply With Quote
The Following User Says Thank You to b_randon14 For This Useful Post:
mattbodin (November 4th, 2012)
sponsored links
Old November 9th, 2012, 10:13 AM   #41 (permalink)
Member
 
Join Date: Apr 2012
Gender: Male
Posts: 450
 
Device(s): LG Nexus 4, Asus Nexus 7, Motorola Triumph, & LG Optimus V - All Hacked & Running CyanogenMod!
Carrier: T-Mobile USA

Thanks: 226
Thanked 194 Times in 129 Posts
Default

Know you're busy with all these recoveries, but I still seem to get reboot when doing backups. b_randon14, can you look into this? Is anyone else experiencing this issue? Otherwise, great job man! Something tells me these issues were bound to happen with a phone that has no relative with official CyanogenMod support, or recoveries. Plus CWM 6 was such a big change from the older ones. Please fix these reboots when you have time.
MikeRL is offline  
Last edited by MikeRL; November 9th, 2012 at 10:19 AM.
Reply With Quote
Old November 9th, 2012, 08:01 PM   #42 (permalink)
Member
 
Join Date: Aug 2012
Location: Texas
Posts: 113
 
Device(s): Motorola Triumph, Coby Kyros MID 7015
Carrier: Not Provided

Thanks: 57
Thanked 12 Times in 12 Posts
mattlb0619
Default

i havent had a problem
mattbodin is offline  
Reply With Quote
Old November 25th, 2012, 12:07 PM   #43 (permalink)
ROM Developer
 
BSydz's Avatar
 
Join Date: Mar 2012
Location: The Mitten
Posts: 951
 
Device(s): Motorola Triumph Sharpened, Samsung Intercept
Carrier: Not Provided

Thanks: 863
Thanked 937 Times in 365 Posts
Default

What's up Brandon? I have been flashing nb0s again, and while I was on Sharp 2.3.5, I had to use tjstyles recovery, because of the kernel. While I was messing around I figured I would see if usb would mount, and it did. I personally have never seen the usb mount in recovery, so this is my first proof that it can work. I know it is a different kernel and the recovery is built from the kernel but I just wanted to let you know. I believe it was 5.0.2.7 but I have refreshed my phone to stock since, so it's not there anymore. I know that most of the X6 recoveries worked on our phone, just different button setups, so I am gonna take a look and see if any of them will mount the SD.

I also pulled a kernel config from the stock Sharp 2.3.5 kernel which I believe is 2.6.35.7. Plus, I found a 2.6.38.6 kernel that has our camera driver, it is the highest version that I have seen that still has the mt9m111 driver. And it is different, I still have to see if it will work in our kernel to see if it works. I know you are not working on kernels at this time but just thought I would put it out there.

Sharp235_defconfig.zip
__________________
"If somethings in your way, you gotta move it or use it." - Me

If you would like to thank me, beyond just saying thanks, you can donate to my coffee fund to keep my eyes open.
Donate
BSydz is online now  
Reply With Quote
Old November 25th, 2012, 08:09 PM   #44 (permalink)
Senior Member
 
RolaAddict's Avatar
 
Join Date: Apr 2012
Location: Virginia
Gender: Male
Posts: 507
 
Device(s): Motorola Triumph (BSydz build testers ICS/JB)
Carrier: Virgin Mobile....unfortunately

Thanks: 160
Thanked 106 Times in 89 Posts
Default

Quote:
Originally Posted by BSydz View Post
What's up Brandon? I have been flashing nb0s again, and while I was on Sharp 2.3.5, I had to use tjstyles recovery, because of the kernel. While I was messing around I figured I would see if usb would mount, and it did. I personally have never seen the usb mount in recovery, so this is my first proof that it can work.
Do you have a link to that recovery and would the USB mounting work on a CM9 Triumph?
RolaAddict is offline  
Reply With Quote
Old November 30th, 2012, 07:07 AM   #45 (permalink)
ROM Developer
Thread Author (OP)
 
b_randon14's Avatar
 
Join Date: Aug 2011
Location: Somerset, KY
Posts: 910
 
Device(s): Galaxy Note II N7100 Samsung Galaxy SII (VM) Motorola Triumph (VM) Samsung Intercept (VM)
Carrier: Virgin Mobile

Thanks: 165
Thanked 627 Times in 263 Posts
Default

I have updated the CWM to v 6.0.1.9, you can view the CyanogenMod recovery repository for more in depth changes. The important one is a buffer overflow fix for dedupe backups, which I am hoping will help with reboots during dedupe backups.

I also changed the kernel I used from the cm9 one to the cm7 one that has been used in most previous recoveries. Hope that will eliminate some of the issues.

USB storage still doesn't work on this. I am working on it!!
b_randon14 is offline  
Reply With Quote
The Following 3 Users Say Thank You to b_randon14 For This Useful Post:
AtticTRON (November 30th, 2012), MikeRL (December 28th, 2012), rukin5197 (November 30th, 2012)
Old January 11th, 2013, 12:02 AM   #46 (permalink)
Senior Member
 
RolaAddict's Avatar
 
Join Date: Apr 2012
Location: Virginia
Gender: Male
Posts: 507
 
Device(s): Motorola Triumph (BSydz build testers ICS/JB)
Carrier: Virgin Mobile....unfortunately

Thanks: 160
Thanked 106 Times in 89 Posts
Default

Any update on this?
RolaAddict is offline  
Reply With Quote
Old January 13th, 2013, 07:51 AM   #47 (permalink)
Member
 
Join Date: Apr 2012
Gender: Male
Posts: 450
 
Device(s): LG Nexus 4, Asus Nexus 7, Motorola Triumph, & LG Optimus V - All Hacked & Running CyanogenMod!
Carrier: T-Mobile USA

Thanks: 226
Thanked 194 Times in 129 Posts
Default Re: [RECOVERY][UPDATE: 11/30/2012] CWM Recovery 6.0.1.9 by b_randon14

I doubt highly that this has already been put to the side. Currently, USB storage needs some tweaks to work in recovery, and a new CWM may already be nearing release. It's probably best to wait until post 6.0.2.3 and then an update will probably come out. Plus, the current one works for me. There are also some Triumph specific bugs that need to be patched.
arcticfix likes this.
MikeRL is offline  
Reply With Quote
Old January 13th, 2013, 08:41 PM   #48 (permalink)
New Member
 
oki doki's Avatar
 
Join Date: Dec 2012
Location: 400 meters due West
Gender: Male
Posts: 9
 
Device(s): Motorola Triumph
Carrier: Virgin Mobile

Thanks: 7
Thanked 2 Times in 1 Post
Default

Does anyone have a backup of the hidden/ and the hidden/data partitions that I could have?
Also a backup of the stock mobile partition?
That would help me so much.

Edit: Nevermind, I answered my own question. I found the stock rom and boot partition here.
http://forum.xda-developers.com/showthread.php?t=1260816
oki doki is offline  
Last edited by oki doki; January 14th, 2013 at 12:33 PM.
Reply With Quote
Old January 14th, 2013, 08:52 PM   #49 (permalink)
Junior Member
 
Join Date: Jul 2011
Posts: 42
 
Device(s):
Carrier: Not Provided

Thanks: 5
Thanked 3 Times in 3 Posts
Default

don't use this to install [ROM] MTDEV-CM7 build 2012-12-28, it causes all kinds of problems....
home button not working, no market.......
realdreams is offline  
Reply With Quote
Old January 14th, 2013, 09:46 PM   #50 (permalink)
Member
 
Join Date: Apr 2012
Gender: Male
Posts: 450
 
Device(s): LG Nexus 4, Asus Nexus 7, Motorola Triumph, & LG Optimus V - All Hacked & Running CyanogenMod!
Carrier: T-Mobile USA

Thanks: 226
Thanked 194 Times in 129 Posts
Default

I am running that on the Triumph for testing purposes with that recovery, and have had no problems. Please redownload and reflash MTDEV CM7, and also reinstall the recovery. Have you forgotten to flash GAPPs (that is needed for the Market to work) and the home button has issues on every single ROM I've used, from stock to CM9. I think it's yet another Triumph hardware fault. The Triumph's hardware is definitely a piece of something, but custom ROMs definitely help. Not all the issues can be resolved with software changes alone, though. Update: I heard it through the grapevine that an update us brewing. But it will not fix USB mounting, that is going to be a massive task, if it's even possible, but some bug fixes will come soon. It's not going to be like when we went from CWM 5.5 to 6.0, but expect some minor patches. Barely any commits from Koush on this one. Most stuff must be working I guess. I do believe some of the errors went away on my Nexus 7 when I upgraded to 6.0.2.7, though. Minor annoyance errors. I have experienced nothing with the current recovery that was a serious bug. We have an update brewing, but everyone at MTDEV has a life unfortunately, so no ETA. Any question of an ETA will be redirected to /dev/null. Sorry b_randon14 if I stole your thunder.
MikeRL is offline  
Last edited by MikeRL; January 16th, 2013 at 09:20 AM.
Reply With Quote
Reply
Tags
cwm, cwm 6, mtdev, triumph


Go Back   Android Forums > Android Phones > Motorola Triumph > Triumph - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:32 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.