Go Back   Android Forums > Android Phones > Samsung Galaxy Nexus > (Verizon) Galaxy Nexus - All Things Root

test: Reply
 
LinkBack Thread Tools
Old January 17th, 2013, 11:02 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Verizon Nexus 4.2.1 - Gmail won't auto-sync and no notifications

I just upgraded to 4.2.1. So far everything seems fine except gmail won't auto-sync. All of my emails are there but if I receive an email it will not show up on my phone until I manually sync it. If I email myself from my phone I will get the email right away as well as a notification. Sometimes an email will trickle in (I haven't narrowed down why) but when it does I won't get a notification. If it does trickle in it's usually 2-5 minutes after I receive it in gmail webmail.

My friend did the same process and to resolve the issue he wiped the dalvak cache (from the App info window) and then rebooted but this did not work for me. I tried to reflash the GApps file but I have the same issue.

What I've tried:
-Reflashed Gapps. Both from GooManager and Clockworkmod
-Turned auto sync on and off
-Wiped cache and dalvik cache
-Fixed permissions
-Deleted app data


Any ideas?

Advertisements
breNTx22 is offline  
Reply With Quote
sponsored links
Old January 17th, 2013, 03:14 PM   #2 (permalink)
Member
 
Join Date: Dec 2012
Posts: 180
 
Device(s):
Carrier: Not Provided

Thanks: 38
Thanked 25 Times in 21 Posts
Default

Have you opened gmail, gone into settings, user, confirm sync?
TritonDroid is offline  
Reply With Quote
Old January 17th, 2013, 03:24 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TritonDroid View Post
Have you opened gmail, gone into settings, user, confirm sync?
Yup, Gmail Sync is ON.
breNTx22 is offline  
Reply With Quote
Old January 17th, 2013, 05:09 PM   #4 (permalink)
Senior Member
 
trophynuts's Avatar
 
Join Date: Jul 2010
Location: SouthEastern US
Posts: 5,598
 
Device(s): Iphone 5 Moto G LTE
Carrier: Verizon

Thanks: 1,843
Thanked 1,882 Times in 1,205 Posts
Default

are you rooted and romm'ed? I thought the lates official version on the VZW G Nex was 4.1.1 or at least not 4.2.1?
trophynuts is offline  
Reply With Quote
Old January 17th, 2013, 05:35 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by trophynuts View Post
are you rooted and romm'ed? I thought the lates official version on the VZW G Nex was 4.1.1 or at least not 4.2.1?
I'm rooted and have a LiquidSmooth ROM.

http://forum.xda-developers.com/showthread.php?t=1965497
breNTx22 is offline  
Reply With Quote
Old January 17th, 2013, 09:21 PM   #6 (permalink)
Senior Member
 
trophynuts's Avatar
 
Join Date: Jul 2010
Location: SouthEastern US
Posts: 5,598
 
Device(s): Iphone 5 Moto G LTE
Carrier: Verizon

Thanks: 1,843
Thanked 1,882 Times in 1,205 Posts
Default

then you should state that info in the OP and also have this thread moved to the All Things Root section. I'm not trying to be a prick but if you want the most help those are things that need to happen. You can edit your OP if you want by adding that info in or You could post in the thread for that ROM also you can report your own OP and ask that it be moved to the ATR section of the VZW Gnex.
trophynuts is offline  
Reply With Quote
Old January 18th, 2013, 07:36 AM   #7 (permalink)
AF Contributor
 
quickaudi's Avatar
 
Join Date: Jul 2010
Location: TN
Posts: 2,961
 
Device(s): VZW G'Note2 VZW SGS3 VZW Galaxy Nexus Droid X
Carrier: Verizon

Thanks: 100
Thanked 348 Times in 288 Posts
Send a message via AIM to quickaudi
Default

What about Phone Settings > Google > check to make sure Gmail sync is checked
quickaudi is offline  
Reply With Quote
Old January 18th, 2013, 08:09 AM   #8 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by trophynuts View Post
then you should state that info in the OP and also have this thread moved to the All Things Root section. I'm not trying to be a prick but if you want the most help those are things that need to happen. You can edit your OP if you want by adding that info in or You could post in the thread for that ROM also you can report your own OP and ask that it be moved to the ATR section of the VZW Gnex.
At that point I had been working on the issue for several hours so I don't recall exactly what I did off the top of my head.

This thread isn't necessarily about rooting so why should it be there?




Quote:
Originally Posted by quickaudi View Post
What about Phone Settings > Google > check to make sure Gmail sync is checked
Yes, the green sync circle is checked. I also clicked on the account and all of the options (browser, calendar, gmail, etc) are checked.
breNTx22 is offline  
Reply With Quote
Old January 18th, 2013, 09:04 AM   #9 (permalink)
Member
 
Join Date: Dec 2012
Posts: 180
 
Device(s):
Carrier: Not Provided

Thanks: 38
Thanked 25 Times in 21 Posts
Default

My only other thought is to go into recovery and reset permissions.
TritonDroid is offline  
Reply With Quote
Old January 18th, 2013, 09:08 AM   #10 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TritonDroid View Post
My only other thought is to go into recovery and reset permissions.
Is this the same as Clockworkmod's "Fix Permissions"?
breNTx22 is offline  
Reply With Quote
sponsored links
Old January 18th, 2013, 09:50 AM   #11 (permalink)
AF Contributor
 
quickaudi's Avatar
 
Join Date: Jul 2010
Location: TN
Posts: 2,961
 
Device(s): VZW G'Note2 VZW SGS3 VZW Galaxy Nexus Droid X
Carrier: Verizon

Thanks: 100
Thanked 348 Times in 288 Posts
Send a message via AIM to quickaudi
Default

Quote:
Originally Posted by breNTx22 View Post
This thread isn't necessarily about rooting so why should it be there?
True, but it does involve a rooted phone, which we wouldn't expect our unrooted brethren to know much about...
quickaudi is offline  
Reply With Quote
The Following User Says Thank You to quickaudi For This Useful Post:
trophynuts (January 18th, 2013)
Old January 18th, 2013, 09:54 AM   #12 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by quickaudi View Post
True, but it does involve a rooted phone, which we wouldn't expect our unrooted brethren to know much about...
I understand but knowledge of rooting isn't relevant when troubleshooting this.
breNTx22 is offline  
Reply With Quote
Old January 18th, 2013, 10:12 AM   #13 (permalink)
AF Contributor
 
quickaudi's Avatar
 
Join Date: Jul 2010
Location: TN
Posts: 2,961
 
Device(s): VZW G'Note2 VZW SGS3 VZW Galaxy Nexus Droid X
Carrier: Verizon

Thanks: 100
Thanked 348 Times in 288 Posts
Send a message via AIM to quickaudi
Default

how did you upgrade? wipe data, cache, etc.?
did you upgrade from a previous LiquidSmooth ROM?

why do you have TWO recoveries flashed?

is this affecting your other email accounts or just Gmail?

which Gmail version number do you have? if it is a themed one, are there any known issues with it?
quickaudi is offline  
Reply With Quote
Old January 18th, 2013, 10:19 AM   #14 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by quickaudi View Post

how did you upgrade? wipe data, cache, etc.?
Wug's Nexus Root Toolkit
Wipe data, cache, dalvik, flash rom, wipe cache/dalvik, get to home screen, test gmail (confirmed it doesn't work), loaded my Android Backup (so I have my apps), open Clockwork, download/install Gapps.

did you upgrade from a previous LiquidSmooth ROM?
No.


why do you have TWO recoveries flashed?

is this affecting your other email accounts or just Gmail?


which Gmail version number do you have? if it is a themed one, are there any known issues with it?
How do I find my version number?
breNTx22 is offline  
Reply With Quote
Old January 18th, 2013, 12:19 PM   #15 (permalink)
AF Contributor
 
quickaudi's Avatar
 
Join Date: Jul 2010
Location: TN
Posts: 2,961
 
Device(s): VZW G'Note2 VZW SGS3 VZW Galaxy Nexus Droid X
Carrier: Verizon

Thanks: 100
Thanked 348 Times in 288 Posts
Send a message via AIM to quickaudi
Default

Quote:
Originally Posted by breNTx22 View Post
How do I find my version number?
in Gmail, hit Menu, then About (or About Gmail, can't remember), then it should be 4.xxxx something or other.
quickaudi is offline  
Reply With Quote
Old January 18th, 2013, 12:35 PM   #16 (permalink)
Member
 
Join Date: Dec 2012
Posts: 180
 
Device(s):
Carrier: Not Provided

Thanks: 38
Thanked 25 Times in 21 Posts
Default

Quote:
Originally Posted by breNTx22 View Post
Is this the same as Clockworkmod's "Fix Permissions"?
Yes
TritonDroid is offline  
Reply With Quote
Old January 18th, 2013, 01:23 PM   #17 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by quickaudi View Post
in Gmail, hit Menu, then About (or About Gmail, can't remember), then it should be 4.xxxx something or other.
4.2.1


Quote:
Originally Posted by TritonDroid View Post
Yes
Yes, I tried Fix Permissions and it didn't resolve it.
breNTx22 is offline  
Reply With Quote
Old January 18th, 2013, 04:06 PM   #18 (permalink)
Member
 
Join Date: Dec 2012
Posts: 180
 
Device(s):
Carrier: Not Provided

Thanks: 38
Thanked 25 Times in 21 Posts
Default

When you went to 4.2 did you check to see if you had the latest gapps?

I see you reflashed but did you use 1212?
TritonDroid is offline  
Reply With Quote
Old January 18th, 2013, 04:40 PM   #19 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TritonDroid View Post
When you went to 4.2 did you check to see if you had the latest gapps?

I see you reflashed but did you use 1212?
Yes, I used 1212. I tried downloading from Clockworkmod and some other source. Both have the issue.
breNTx22 is offline  
Reply With Quote
Old January 20th, 2013, 07:34 PM   #20 (permalink)
A guide with guides
 
teddyearp's Avatar
 
Join Date: May 2010
Location: Randle, WA
Posts: 2,286
 
Device(s): HTC® HTC6525LVW, Samsung® SCH-I515 & Motorola® XT907
Carrier: Verizon

Thanks: 713
Thanked 795 Times in 469 Posts
Default

breNTx22, I don't know if it was moved or not, but it is now in the VZW rooted section and this is where it would belong, since our unrooted brethren would know nothing about wiping Dalvik cache, flashing gapps, custom recoveries, custom roms, etc. And as such, they may not even ever have this problem.

Since all the other solutions in this thread were valid ones but have yet to help you out, it actually sounds to me like you should go ahead and try a fresh install of your rom. You _might_ fix it with a 'dirty' flash, but personally, I always like to wipe data and cache in between rom flashes. Although it can be a pain to set your phone back up after this, it seems to just give me much less headaches down the road. So, either try a 'dirty' re flash of your rom and gapps, or boot into recovery, make a nandroid backup, wipe data/cache and perhaps /system, flash rom, flash gapps, reboot and see if that fixes your problem.

good luck
teddyearp is offline  
Reply With Quote
The Following User Says Thank You to teddyearp For This Useful Post:
trophynuts (January 21st, 2013)
sponsored links
Old January 21st, 2013, 07:27 AM   #21 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by teddyearp View Post
breNTx22, I don't know if it was moved or not, but it is now in the VZW rooted section and this is where it would belong, since our unrooted brethren would know nothing about wiping Dalvik cache, flashing gapps, custom recoveries, custom roms, etc. And as such, they may not even ever have this problem.

Since all the other solutions in this thread were valid ones but have yet to help you out, it actually sounds to me like you should go ahead and try a fresh install of your rom. You _might_ fix it with a 'dirty' flash, but personally, I always like to wipe data and cache in between rom flashes. Although it can be a pain to set your phone back up after this, it seems to just give me much less headaches down the road. So, either try a 'dirty' re flash of your rom and gapps, or boot into recovery, make a nandroid backup, wipe data/cache and perhaps /system, flash rom, flash gapps, reboot and see if that fixes your problem.

good luck
I tried that and unfortunately it didn't work.

However, I think it only happens on "Important" emails in gmail. Gmail had automatically been marking some of my emails as Important so I disabled that and it appears to work much better now.
breNTx22 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Galaxy Nexus > (Verizon) Galaxy Nexus - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:26 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.