Go Back   Android Forums > Android Phones > Samsung Vibrant > Vibrant - Support and Troubleshooting

test: Reply
 
LinkBack Thread Tools
Old September 12th, 2010, 02:56 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 337
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 14 Times in 13 Posts
Default is this normal? phone doesn't know it's own number...

This is probably a dumb question but this is my first phone that uses a sim card. If I go to settings and status for phone number it says unknown. On my previous Android phone with verizon it knew my number. The google voice app doesn't seem to be able to read my number either but the phone itself seems to work fine.

Advertisements
snorge is offline  
Reply With Quote
sponsored links
Old September 12th, 2010, 03:04 PM   #2 (permalink)
Member
 
Join Date: Jul 2010
Posts: 199
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 16 Times in 13 Posts
Default

Mine's the same. I stopped in a TMO store and they said some of their other phones show the same thing. They claimed it's "normal", and shouldn't cause any problems.
wildblue is offline  
Reply With Quote
Old September 12th, 2010, 03:11 PM   #3 (permalink)
New Member
 
Join Date: Jul 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I forget the menu option on the Vibrant to allow this since I returned mine and haven't replaced it yet. But I was able to edit the phone number for the SIM card. Something called the MSISDN1/My Profile entry from what I remember. TMO support should be able to help you with that.

Or an even easier way is to edit the number of the SIM on a Blackberry. I had to do that last year when they replaced my SIM card in the store.
sabooher is offline  
Reply With Quote
Old September 12th, 2010, 05:10 PM   #4 (permalink)
Junior Member
 
Join Date: Aug 2010
Posts: 23
 
Device(s):
Carrier: Not Provided

Thanks: 5
Thanked 1 Time in 1 Post
Default Doesn't sound normal to me

Quote:
Originally Posted by wildblue View Post
Mine's the same. I stopped in a TMO store and they said some of their other phones show the same thing. They claimed it's "normal", and shouldn't cause any problems.
Mine shows the phone number. I would call T Mobile tech support.
RWhittier is offline  
Reply With Quote
Old September 12th, 2010, 06:01 PM   #5 (permalink)
New Member
 
Join Date: Feb 2010
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

I needed the phone number to show in order to use an app ... I called T-mobile and the guy took care of it in less than a minute without asking any question why I would need the number to show
xristian is offline  
Reply With Quote
Old September 12th, 2010, 06:03 PM   #6 (permalink)
Member
 
Join Date: Jul 2010
Posts: 199
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 16 Times in 13 Posts
Default

Quote:
Originally Posted by RWhittier View Post
Mine shows the phone number. I would call T Mobile tech support.
I did call when I first got the phone and noticed it. They had me dial a number (which I've forgotten) that did show my phone #. They had no explanation for why it shows up under Settings as "unknown". I suppose I could pursue it further, but without a more serious problem showing up I'm not all that interested in fixing it.
wildblue is offline  
Reply With Quote
Old September 15th, 2010, 11:26 AM   #7 (permalink)
Junior Member
 
Join Date: Aug 2010
Location: Oklahoma
Posts: 20
 
Device(s): Rooted MyTouch 3g running CM6 WitsTech A81-E Rooted, lagfix Vibrant 2206 Quadrant scrore
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
aksoutherland
Default

I had the same issue with mine. A call to T-Mo support didn't help. So after some researching I found this:
1. Power off phone
2. Remove SIM card
3. Power on phone
4. Once phone is completely booted up power off the phone
5. Insert SIM card
6. Power on the phone

This worked for me, I also had an app that required the phone to know the number, I believe it was one of the PTT apps from the market.
aksoutherland is offline  
Reply With Quote
Old January 12th, 2011, 05:08 AM   #8 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is possible to put your phone number in there, and is easier than you might think:

Go into Contacts -> [Menu] -> More -> Settings -> Own numbers -> [Menu] -> Create and type your phone number into the Number field, now Save.

Then switch your phone off and on again, and it should show the correct number (or whatever number you entered) in the status now.
greatred77 is offline  
Reply With Quote
Old January 31st, 2011, 04:09 PM   #9 (permalink)
New Member
 
J.E.T.'s Avatar
 
Join Date: Jan 2011
Location: Philly
Posts: 4
 
Device(s): TMo Vibrant 2.2 SGH-T959
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

What greatred77 suggested, it does work.
J.E.T. is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Vibrant > Vibrant - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:43 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.