Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 > X10 - All Things Root
X10 - All Things Root Rooting, ROMS, Overclocking, etc.

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old July 29th, 2010, 06:51 PM   #1 (permalink)
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 143
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 9 Times in 9 Posts
Default X10 Stuck at "Sony Ericsson" boot screen

So I did some modding (unfortunately) to the framework-res.apk file and it worked the first time and a few other times but then I changed something and now when I turn on the phone it freezes at the "Sony Ericsson" screen before the logo. What do I do?

I tried pushing the backup framework file but it says "failed to copy framework-res.apk to /sdcard/framework-res.apk: Permission denied

however, when I use adb devices, it does show my device as being attached.

So what can I do now?

Edit
I was also able to pull files...

Also tried manually putting the framework-res.apk in the sdcard and then using adb to copy it to the framework folder. Doesnt work. Saids that the directory cannot be open for read. I guess the device cant read the SD card until it boots up

Advertisements
lolbug is offline  
Reply With Quote
sponsored links
Old July 29th, 2010, 06:55 PM   #2 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

You have figured out more than me if your changing the framework stuff.

Best off posting this on XDA as that is where the guru's lay when it comes to these matters

I'm sure there will be a recovery option so dont stress to much.
powerkiter is offline  
Reply With Quote
Old July 29th, 2010, 07:05 PM   #3 (permalink)
Member
 
Join Date: Jun 2010
Posts: 180
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 25 Times in 23 Posts
Default

Have you tried booting into safe mode and restoring?
huntleth is offline  
Reply With Quote
Old July 29th, 2010, 07:10 PM   #4 (permalink)
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 143
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by huntleth View Post
Have you tried booting into safe mode and restoring?
How do you do that? I tried holding the back button while connecting the cable and then the led turned green but then it got stuck on that screen again.

EDIT
What can you do in safe mode? As long as I can turn on USB Debugging I should be able to reverse this
lolbug is offline  
Reply With Quote
Old July 29th, 2010, 07:14 PM   #5 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

Turn the phone on and hold the options button till it starts up.
powerkiter is offline  
Reply With Quote
Old July 29th, 2010, 07:23 PM   #6 (permalink)
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 143
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by powerkiter View Post
Turn the phone on and hold the options button till it starts up.
Wont boot in safe mode...
lolbug is offline  
Reply With Quote
Old July 29th, 2010, 07:30 PM   #7 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

I did mean hold the options button whilst powering up try that if not head over to the X10 forum on XDA here Sony Ericsson XPERIA X10 - xda-developers
powerkiter is offline  
Reply With Quote
Old July 29th, 2010, 07:33 PM   #8 (permalink)
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 143
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by powerkiter View Post
I did mean hold the options button whilst powering up try that if not head over to the X10 forum on XDA here Sony Ericsson XPERIA X10 - xda-developers
I held button before pressing power button. And I already posted in XDA but its taking a while x_x I have no patience at all now
lolbug is offline  
Reply With Quote
Old July 29th, 2010, 07:47 PM   #9 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

I feel your pain and this is why I held back from editing the framework as I would love to get the default Android smilies but have no clue when it come to that side of it the root was just clicking on a few icons and it happened.

Hope you get it sorted
powerkiter is offline  
Reply With Quote
Old August 9th, 2010, 05:59 PM   #10 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 2
 
Device(s): SE X10i Rooted
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by powerkiter View Post
Turn the phone on and hold the options button till it starts up.
to boot an X10 into safemode im pretty sure you hold the power button till the phone vibrates the press the volume down key
vengeance1990 is offline  
Reply With Quote
sponsored links
Old September 13th, 2011, 04:35 AM   #11 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default i have the same problem

I have recently attempted to start a new run with xrecovery and now it has frozen on the se boot up screen i cant go back into xrecovery again it wont let me so i dunno wat to do help!!!!!!!
Chrisbix555 is offline  
Reply With Quote
Old September 13th, 2011, 12:43 PM   #12 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by Chrisbix555 View Post
I have recently attempted to start a new run with xrecovery and now it has frozen on the se boot up screen i cant go back into xrecovery again it wont let me so i dunno wat to do help!!!!!!!
Probably going to need to run the flashtool and reflash....if it doesn't let you. Try installing an older version and going through all of the steps again.

If it ever gets completely stuck, always try installing an older version and the starting again.

Flash again....turn on Unknown Sources and Debug...install 2.3....root....reboot...install xRecovery from Flashtool
beau420 is offline  
Reply With Quote
The Following User Says Thank You to beau420 For This Useful Post:
Miss_Sha37 (January 11th, 2012)
Old September 25th, 2011, 04:17 AM   #13 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having the same problem..
The phone vibrates as normal when I press the power button.
After a few secs it shows the Sony Ericsson text.
And then nothing

I tried a couple of button combo's while starting the phone but its always the same end result, it being stuck on "Sony Ericsson".
It does blink the green LED ones when I hold the Volume Down and Back key with the power button, but then its stuck again..

I did not do anything with flashing, or even rooting.. I just tried to reboot it, cause Maps was acting weird and it hasn't started since.

Does anyone have any suggestions?

Im on Andoid 2.3.3.

Thanks,
Richard
Shadowing is offline  
Reply With Quote
Old July 18th, 2012, 02:33 PM   #14 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Brother's
Just fixed that issue on one of my friends phone.. he was also worried like you guys are..
Reason for Stuck on Sony Ericsson is that when you forget to check the USB debugging mode in development before flashing using the flash tool, thats why the tool is stuck on open source.
Resolution like you have selected downgrade kernel from the flash tool.. disconnect cable.. close flash tool. restart it. click flash and this time use upgrade kernel. and connect the phone using back button.
Phone will boot up again and you can now check the debugging mode in development and start root process again.
Enjoy
kirtivsingh is offline  
Reply With Quote
Old July 23rd, 2012, 04:06 AM   #15 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by kirtiv***** View Post
Brother's
Just fixed that issue on one of my friends phone.. he was also worried like you guys are..
Reason for Stuck on Sony Ericsson is that when you forget to check the USB debugging mode in development before flashing using the flash tool, thats why the tool is stuck on open source.
Resolution like you have selected downgrade kernel from the flash tool.. disconnect cable.. close flash tool. restart it. click flash and this time use upgrade kernel. and connect the phone using back button.
Phone will boot up again and you can now check the debugging mode in development and start root process again.
Enjoy
So true! Thanks! This worked for me.
cobanoglu is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 > X10 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:53 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.