Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 > X10 - All Things Root
X10 - All Things Root Rooting, ROMS, Overclocking, etc.

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old November 11th, 2011, 01:18 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Xrecovery "device or resource busy"

Hi everyone,

I've been trying to install the new bravia engine, fps uncap, xloud, and the updated timescape (all of which are in .zip files). I've successfully rooted my phone, and installed busybox from the market, however, when I go into the xrecovery menu and try to install "custom zip from sdcard", any .zip files I choose gets an error message saying:

E: Can't mount /dev/block/mmcblk-p1 (or /dev/block/mmcbkl0)
(Device or resource busy)
E: Can't mount SDCARD:bravia_engine.zip
Installation aborted"

After this, if I so much as press the home button to enter the category "Choose custom zip from sdcard", I get the same error message saying:

E: Can't mount /dev/block/mmcblk-p1 (or /dev/block/mmcbkl0)
(Device or resource busy)
E: Can't mount /sdcard

Any help would be appreciated!

Thanks.

disneysora is offline  
Reply With Quote
sponsored links
Old November 11th, 2011, 10:43 AM   #2 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

You are using the wrong version of xRecovery.

http://androidforums.com/x10-all-things-root/420821-problem-installing-xrecovery-2-3-a.html

Quote:
There is version FlashTool version 0.2.9.1 and FlashTool version 0.3.0.0....there isn't a version between the two are there?

I have 2.3 installed and rooted and xRecovery installed. I can boot to it.

But now whenever I try to restore a previous backup or restore a custom ROM I get the error:

E:Can't mount /dev/block/mmcblk0p1 (or /dev/block/mmcblk0)
(Device or resource busy)
(Can't mount SDCard)

Now I am unable to view the SDCard (if I chose to restore again or create a backup or install a custom ROM) until I reboot the phone

I assume it is some sort of rights issue.

Just spent last 5-10 min looking at this...haven't really tried much yet.
I was able to create a backup and it did that error free.
I had the same problem.

If you use the xRecovery 0.3 then it gave me that problem, but when I used the 0.29 GBReady version (not the regular .29 version either)...no problem.

http://azuzu.spice.net.au/tools/X10_GB_Root/FlashTool_0.2.9.1-GBready_root_xRec.exe
beau420 is offline  
Reply With Quote
Old November 11th, 2011, 11:04 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you very much!
Appreciate it.
disneysora is offline  
Reply With Quote
Old February 22nd, 2012, 04:13 AM   #4 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Angry

Quote:
Originally Posted by beau420 View Post
If you use the xRecovery 0.3 then it gave me that problem, but when I used the 0.29 GBReady version (not the regular .29 version either)...no problem.

http://azuzu.spice.net.au/tools/X10_GB_Root/FlashTool_0.2.9.1-GBready_root_xRec.exe
How exactly do i replace my apk installed .3 xrecovery with the files from that x10 flash tool? I haven't been able to get anything to work.
awsam is offline  
Reply With Quote
Old February 22nd, 2012, 08:45 AM   #5 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by awsam View Post
How exactly do i replace my apk installed .3 xrecovery with the files from that x10 flash tool? I haven't been able to get anything to work.
You don't install the APK manually....and using the steps that I have listed, you wouldn't already have xrecovery installed.

If you use a more updated version of xrecovery, then either xrecovery might not work or you won't be able to install any ROMs.

I assume you have freshly reinstalled 2.3 with nothing on the phone.
beau420 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 > X10 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:20 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.