Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X8 > X8 - All Things Root
X8 - All Things Root Rooting, ROMS, Overclocking, etc.

New Android Wear, House and Home & Automotive forums!
Please report any threads you come across that should be moved to these new sections!

test: Reply
 
LinkBack Thread Tools
Old April 2nd, 2011, 02:57 PM   #1 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Mad [MOD] Enable IEEE 802.11N WIFI for Xperia X8

Hi,

I just did this mod for my Xperia X8 running CM7-J005 ROM and it works!

So if you guys want IEEE 802.11N on your Xperia X8 hit the link.

[MOD] Faster WIFI for X8 - N standard enabling <-- here

DISCLAIMER: Please use the info below at your own risk with no warranty of any kind.

Method:

1. <Launch><Root Explorer>

2. go to /system/etc/firmaware <check> that you have the following files:
- fm_rx_init_1273.2.bts
- fm_tx_init_1273.2.bts
- fmc_init_1273.2.bts

3. go to /system/etc/wifi and using Root Explorer <copy><tiwlan.ini> and <paste> to root of SD Card

4a. use USB Cable <mount><copy><tiwlan.ini> file from SD Card to desktop
4b. rename <tiwlan.ini> file on SD Card to <tiwlan.ini.1>

5a. do the necessary modifications according to Graveir's post @ XDA-Developers using NOTEPAD --> <Save> the mods to <tiwlan.ini> file on the PC desktop
5b. there are reports saying that "adhoc" mod is not working so I am not recommending it

Quote:
Look for these lines about halfway down the page: change from 0 to 1

HT_Enable=0 ---> HT_Enable=1
BurstModeEnable = 0 ---> BurstModeEnable = 1
Single_Dual_Band_Solution = 0 ---> Single_Dual_Band_Solution = 1

(Be Careful - just change the numbers - do not add/delete blank spaces)

6a. use USB Cable <mount><copy> modded <tiwlan.ini> file from desktop to SD Card
6b. <unmount> Xperia X8

7. <Launch><Root Explorer>

8. go to SD Card <copy><tiwlan.ini> and <paste><replace> to /system/etc/wifi

9. Reboot

And that's it... say goodbye to 802.11G and enjoy your 802.11N wifi!

cheers

Do or do Not... there is no Try - Yoda



Quote:
NOT WORKING?

Not Connecting to Network
go to <settings><networks><wifi> erase all remembered networks and <reboot>

Reverse the Modification:
USB <mount> Xperia X8 - go to SD Card <delete><tiwlan.ini>
Launch <Root Explorer>
<rename><tiwlan.ini.1> --> <tiwlan.ini>
<copy><replace><tiwlan.ini> back to /system/etc/wifi
<reboot>
Quote:
UPDATES:
Confirmation: Xperia X8 running 802.11N Draft - 2.4GHz @ 65Mbps

Battery Drain? - Nah... left my wifi on all the time with no significant changes in battery usage

miniCM RC1, CM7-J005, CM7-RC4 [Working] - so go ahead and mod
Floyo-0.15 [NOT Working] - so don't try the mod
Stock Android Eclair 2.1.1 [NOT Working] - don't even think about it

gabeyong is offline  
Last edited by gabeyong; April 7th, 2011 at 02:11 AM.
Reply With Quote
The Following 3 Users Say Thank You to gabeyong For This Useful Post:
HaN6787 (April 3rd, 2011), luchiolb (April 4th, 2011), meiaxx8 (September 27th, 2011)
sponsored links
Old April 2nd, 2011, 07:57 PM   #2 (permalink)
Junior Member
 
HaN6787's Avatar
 
Join Date: Feb 2011
Posts: 98
 
Device(s): Sony Ericsson Xperia X8
Carrier: Not Provided

Thanks: 32
Thanked 6 Times in 6 Posts
Default

Not working on stock?
__________________
Migrating from Symbian OS to Android OS
I didn't regret buying Android phone. I'm
enjoying it in every byte and bit.

>> Application and Games I have in my device <<
HaN6787 is offline  
Reply With Quote
Old April 2nd, 2011, 09:23 PM   #3 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by HaN6787 View Post
Not working on stock?
only CM7 ROMs
gabeyong is offline  
Reply With Quote
Old April 3rd, 2011, 03:15 AM   #4 (permalink)
Member
 
Join Date: Nov 2010
Location: Slovakia, Poprad
Posts: 176
 
Device(s): Xperia X8
Carrier: Not Provided

Thanks: 14
Thanked 15 Times in 14 Posts
Send a message via ICQ to Lupajz Send a message via Skype™ to Lupajz
Default

Yea, but the improved battery drain is a big minus for this
__________________
contact
Lupajz is offline  
Reply With Quote
Old April 3rd, 2011, 04:46 AM   #5 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by Lupajz View Post
Yea, but the improved battery drain is a big minus for this
[Updated after 2 days of use]

So far so good. I see improvement in the speed of my wifi connection (65Mbs @ 2.4Ghz) no significant battery drain issues.

24 hours battery life - moderate usage sms, emails, phone calls, media player on the train: 3G, Wifi, Live wallpaper and 3 widgets on homescreen enabled.

Highly recommended mod!!

cheers
gabeyong is offline  
Last edited by gabeyong; April 4th, 2011 at 03:36 PM.
Reply With Quote
Old August 18th, 2011, 06:47 AM   #6 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

help.. I forgot to make a backup so I changed those settings and I've lost "G" so please smb attach that tiwlan.ini if possible.btw I tried to change settings back but still it says that it's not changed and still having "n" so please attach and give me a link.would really appreciate
datatsiko is offline  
Reply With Quote
Old August 18th, 2011, 06:59 AM   #7 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by datatsiko View Post
help.. I forgot to make a backup so I changed those settings and I've lost "G" so please smb attach that tiwlan.ini if possible.btw I tried to change settings back but still it says that it's not changed and still having "n" so please attach and give me a link.would really appreciate
hi,

just reverse the settings from 1 to 0 for the above.

cheers
gabe
gabeyong is offline  
Reply With Quote
Old August 18th, 2011, 08:06 AM   #8 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gabeyong View Post
hi,

just reverse the settings from 1 to 0 for the above.

cheers
gabe
did.. it showed 54mbps too.. but still can't connect to "g"wifi.. so if possible please attach that file..
datatsiko is offline  
Last edited by datatsiko; August 19th, 2011 at 10:40 AM.
Reply With Quote
Old August 18th, 2011, 07:02 PM   #9 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by datatsiko View Post
did.. it showed 54mbps too.. but still can't connect to "g"wifi.. so if possible please attach that file.. tiwlan.ini or maybe if it's possible send me on datatsiklauri@yahoo.com would really appreciate..
Hi,

you can download the original file from here <--

cheers
gabe
gabeyong is offline  
Reply With Quote
The Following User Says Thank You to gabeyong For This Useful Post:
datatsiko (August 19th, 2011)
Old August 19th, 2011, 10:41 AM   #10 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Happy

thanks very much gabe,appreciate that
datatsiko is offline  
Reply With Quote
sponsored links
Old September 27th, 2011, 02:24 PM   #11 (permalink)
Junior Member
 
Join Date: Aug 2011
Location: Malaysia
Posts: 29
 
Device(s): Sony Ericssons Xperia X8
Carrier: Not Provided

Thanks: 22
Thanked 2 Times in 2 Posts
Send a message via MSN to meiaxx8 Send a message via Yahoo to meiaxx8
Default

hi gabe,

can use file manager?
or i must install root explorer?
meiaxx8 is offline  
Reply With Quote
Old September 27th, 2011, 05:27 PM   #12 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by meiaxx8 View Post
hi gabe,

can use file manager?
or i must install root explorer?
Hi,

You gotta use Root Explorer

cheers
gabe
gabeyong is offline  
Reply With Quote
The Following User Says Thank You to gabeyong For This Useful Post:
meiaxx8 (September 27th, 2011)
Old September 27th, 2011, 08:57 PM   #13 (permalink)
Junior Member
 
Join Date: Aug 2011
Location: Malaysia
Posts: 29
 
Device(s): Sony Ericssons Xperia X8
Carrier: Not Provided

Thanks: 22
Thanked 2 Times in 2 Posts
Send a message via MSN to meiaxx8 Send a message via Yahoo to meiaxx8
Cry

Quote:
Originally Posted by gabeyong View Post
Hi,

You gotta use Root Explorer

cheers
gabe
hi gabe,

yup..i alreally do thats..

its cool..

i have another problem,why my X8 lagging?i check about phone,my CPU info is ARMv6-compatible processor rev 5 (v6l)

are i should change cpu or set setting?
i see at Settings>CyanogenMod settings>Performance,it appear a warning..
meiaxx8 is offline  
Reply With Quote
Old September 27th, 2011, 09:04 PM   #14 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by meiaxx8 View Post
hi gabe,

yup..i alreally do thats..

its cool..

i have another problem,why my X8 lagging?i check about phone,my CPU info is ARMv6-compatible processor rev 5 (v6l)

are i should change cpu or set setting?
i see at Settings>CyanogenMod settings>Performance,it appear a warning..

Hi,

yes, accept warning and enable JIT

cheers
gabe
gabeyong is offline  
Reply With Quote
Old September 29th, 2011, 11:59 AM   #15 (permalink)
Junior Member
 
Join Date: Aug 2011
Location: Malaysia
Posts: 29
 
Device(s): Sony Ericssons Xperia X8
Carrier: Not Provided

Thanks: 22
Thanked 2 Times in 2 Posts
Send a message via MSN to meiaxx8 Send a message via Yahoo to meiaxx8
Default

Quote:
Originally Posted by gabeyong View Post
Hi,

yes, accept warning and enable JIT

cheers
gabe
Hi gabe,

Thx for reply,
I alreally accept warning..and JIT alreally enable..
What next i wanna do?
meiaxx8 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X8 > X8 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:13 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.