Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X8 > X8 - All Things Root
X8 - All Things Root Rooting, ROMS, Overclocking, etc.

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old October 11th, 2011, 05:24 AM   #1 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default [ROM] CyanogenMod 7 RC1 V4 [Stock Kernel] for Xperia X8

DISCLAIMER: Please note that I will not take any responsibility for any loss of data or the malfunctioning of your Xperia X8.

Read the instructions below twice before attempting to install this Custom ROM. There is a chance you might "brick" your phone.


SPECIAL THANKS TO:
KUYAGAOL
CYANOGENMOD TEAM
XPERIAFAN 13

Xperia X8 devices can now install CyanogenMod 7 RC1 Android 2.3.5

CyanogenMod 7 RC1 Android 2.3.5 Features:
196 MB FREE IN INTERNAL MEMORY
* Back Button Ends Call
* ICS rotation animations
* ICS animations
* On/Off option for ICS rotation animations
* Gingerbread's screen on/off animation
* Loop Ringtones
* No Bootanimations (now CM7 default)
* Ultra Brightness
* ADW Launcher by CM
* OverClock
* Undervolt
* SdCard Cache Size
* More option on VM heap Size
* Send Mic Mute to Audio Manager
* Camera Button play and pause music on lockscreen
* ext app2sd
* Custom text on carrier level
* Bubble, Ravamped, Holo and Blade stile for ring lockscreen
* [NEWS!] All windows change with the theme, including the volume bar and the phone menu options.
* ThemeChooser now available from Settings/display

BUGS: Radio (working on fix for this bug for V5 release)

You can read about the features...here... <---

Requirements:
- Rooted Xperia X8 E15i NOT E15a
- xRecovery installed
- ClockworkMod Recovery*
- SE Stock Kernel

If you are stuck in a boot loop it's because you have got an old baseband xxx006
Download and flash Baseband 015 using FlashTool

METHOD
(A) Make a backup of whatever ROM you are using ClockworkMod Recovery*
1. Restart Xperia X8
2. Reboot into ClockworkMod Recovery*
by hitting the back button multiple times when you see the SE Logo on the screen
3. Go to Backup / Restore <click><backup>
4. <reboot> your Xperia X8
5. Download:
CM7_RC1_V1
CM7_RC1_V2
CM7_RC1_V3
CM7_RC1_V4

(B) Installation of CyanogenMod 7 RC1 ROM:
1. Copy CM7_RC1_V4.zip to root of SD Card
2. Reboot to ClockworkMod Recovery*
3. Scroll down to <mounts and storage>
3a. and <format /system>
3b. and <format /data>
3c. and <format /cache>
3d. go back to Main Menu <Wipe data / factory reset>
4. Install custom zip <select> CM7_RC1_V4.zip
5. install completed <Reboot>
6. Enjoy super fast and stable Gingerbread 2.3.7 on your X8

(C) Going back to your previous Custom ROM (Are you sure you wanna do that?)
1. Shutdown and Reboot your Xperia X8
2. Reboot into ClockworkMod Recovery*
by hitting the back button multiple times when you see the SE Logo on the screen
3. Go to Backup / Restore <click><restore>
4. When restore is complete <reboot> X8

NOTE*:
For those who do not have ClockworkMod Recovery
a) download ClockworkMod Recovery
b) flash the ClockworkMod Recovery zip file using xRecovery
c) reboot into ClockworkMod Recovery

RESOURCES:
ClockworkMod Recovery 4.0.1.5


SUPPORT:
SONY Ericsson Support Website
PC Companion, USB Drivers for Xperia X8, SEUS & Media Sync...

If you need any help... you can post your problems/issues here.

cheers
gabe

Advertisements
gabeyong is offline  
Last edited by gabeyong; July 20th, 2012 at 05:58 AM.
Reply With Quote
The Following User Says Thank You to gabeyong For This Useful Post:
fauzan89 (November 28th, 2011)
sponsored links
Old October 11th, 2011, 08:51 AM   #2 (permalink)
 
Join Date: Oct 2011
Posts: 100
 
Device(s):
Carrier: Not Provided

Thanks: 22
Thanked 44 Times in 7 Posts
Default

Hi, I've tried to install the new CyanogenMod, but while I launch the .zip install, it returns "assert failed: getprop("ro.product.device") == "E15i" || [...]".

Rebooting the phone, from terminal I have looked for getprop and values are ok.

I have try to install both before and after system format, but the error persist.

Anyone can help me ?
xmancool is offline  
Reply With Quote
Old October 11th, 2011, 04:28 PM   #3 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by xmancool View Post
Hi, I've tried to install the new CyanogenMod, but while I launch the .zip install, it returns "assert failed: getprop("ro.product.device") == "E15i" || [...]".

same problem here
tritonas00 is offline  
Last edited by tritonas00; October 11th, 2011 at 04:39 PM.
Reply With Quote
Old October 11th, 2011, 05:58 PM   #4 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by tritonas00 View Post
same problem here
sorry not enough info to help, so i am guessing...

are you using xRecovery to install?
you should be using clockworkmod recovery to install

cheers
gabe
gabeyong is offline  
Reply With Quote
Old October 11th, 2011, 06:28 PM   #5 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gabeyong View Post
sorry not enough info to help, so i am guessing...

are you using xRecovery to install?
you should be using clockworkmod recovery to install

cheers
gabe
i use clockworkmod 3x

I followed exactly your insructions.Its first time i have this problem.Every other rom installed fine.

Now i use gingerdx 017.Are there any differences with this rom?

Thanks for reply!
tritonas00 is offline  
Last edited by tritonas00; October 11th, 2011 at 08:05 PM.
Reply With Quote
Old October 11th, 2011, 08:47 PM   #6 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

plz help me...i do many time...all the intruction i follow..nothing i skip...but when i use CMW, it always aborted...i tried every way..i enable sign varification, also cannot...what actually must i do? im using 2.1....already rooted installed CWM 4.0.1.5...what i do wrong? thanks for helping me
The Man is offline  
Reply With Quote
The Following User Says Thank You to The Man For This Useful Post:
mitsosgest (October 12th, 2011)
Old October 12th, 2011, 05:09 AM   #7 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

me to :/
mitsosgest is offline  
Reply With Quote
Old October 12th, 2011, 06:27 AM   #8 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

come....anyone, plz help me...or did i need to flash it using flashtool??
The Man is offline  
Reply With Quote
Old October 12th, 2011, 08:30 AM   #9 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by The Man View Post
come....anyone, plz help me...or did i need to flash it using flashtool??
Hi,

Apologies... This ROM is a bit fussy (signed ROM).

It requires Xperia X8 E15i NOT E15a
And baseband 015 = X8 Shakira E15i_2.0.2.A.0.24_ril.ftf

The reason for your error message is either...
Wrong Xperia X8 Model or wrong baseband.

cheers
gabe
gabeyong is offline  
Reply With Quote
Old October 12th, 2011, 02:56 PM   #10 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by gabeyong View Post
Hi,

Apologies... This ROM is a bit fussy (signed ROM).

It requires Xperia X8 E15i NOT E15a
And baseband 015 = X8 Shakira E15i_2.0.2.A.0.24_ril.ftf

The reason for your error message is either...
Wrong Xperia X8 Model or wrong baseband.

cheers
gabe
mine is E15i......baseband also 015 n the file i download is shakira...so whts the problem?? file.ftf? is that means i need to flash it using flashtool???

actually what i need to makesure is done on my x8??
root = done
xrecovery = done
CWM = done

is there anything tht im forgot to install??

tq for helping me
The Man is offline  
Reply With Quote
sponsored links
Old October 12th, 2011, 03:04 PM   #11 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

ok like this...lets assume that my x8 is new hp...then i root my hp...install xrecovery...then install CWM...mine is latest kernal ri8 becoz yesterday, i dont knw how many time i flash my x8 using SEUS...10 hours in front of my laptop bcoz trying to install this cyanogenmod 7.1 @ shakira...so i just need to flash this roms through CMW using ur instruction ri8? all i done but the result is aborted...
The Man is offline  
Reply With Quote
Old October 14th, 2011, 05:27 PM   #12 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

omg...no body here...
The Man is offline  
Reply With Quote
Old October 18th, 2011, 03:44 PM   #13 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm gonna tell anybody who reads this exactly what i've done, and why it is still not working:
a) Rooted my phone.
b) Got all thingys (xrecovery blah blah blah...) installed.
c) Cyanogenmod 6 (android 2.2) previously installed.
d) Got baseband ... 015.
e) My phone model is E15i.

What I did was:
a) download CM7.1 from the website.
b) Copied update-cm-7.1.0-x8-signed.zip to my sdcard.
c) rebooted to clockwork mod.
d) tried to install zip from sdcard.
...
AND I STILL GOT THE ERROR.
if anybody can tell me where i went wrong, i'd be really grateful for it.
Thanks in advance.
troika is offline  
Reply With Quote
Old October 18th, 2011, 03:45 PM   #14 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

...
troika is offline  
Last edited by troika; October 18th, 2011 at 03:46 PM. Reason: inappropriate answer.
Reply With Quote
Old October 19th, 2011, 07:10 AM   #15 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok same problem as everyone else asset failed error my phone is E15i and 15 baseband. Everything done exactly but still the error. Maybe the zip is corrupted?
fash_ric is offline  
Last edited by fash_ric; October 19th, 2011 at 09:35 AM.
Reply With Quote
Old October 19th, 2011, 01:27 PM   #16 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

@fash_ric:

umm, i can see a few reasons why maybe you're wrong:

a) i've downloaded the file from different websites, which means there isn't any problem with cyanogen's servers (and the files stored in it).
b) cyanogen would never release an update which doesn't work.

at the same time, i really really hope you're right, since i heard cm7.1 is awesome, and i'd really love to have it on my x8.
troika is offline  
Reply With Quote
Old October 19th, 2011, 10:12 PM   #17 (permalink)
New Member
 
Join Date: Aug 2011
Location: K0TTayam
Posts: 4
 
Device(s): Sony Ericsson W8
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to shameeltas Send a message via Skype™ to shameeltas shameeltas
Default

i'm also facing the same problem
shameeltas is offline  
Reply With Quote
Old October 20th, 2011, 02:24 AM   #18 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default network problem

Hi,
I am using floyo 1.0b since last month , yesterday onwards i started facing network problem in my fone when i was trying to fix andrd market . As told by Gabe I deleted .android secure and android folder also , but the problem persists.
after that I updated my fone to GingerDX.v17 all went smooth excpt the phone network .

Ironically network re appears after 15 min. or so . Right now i rolled back to floyo

Please Help me out!!!
veervardhan is offline  
Reply With Quote
Old October 20th, 2011, 05:54 AM   #19 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

@veervardhan:

unfortunately, we x8 users have extremely limited options.
CM is the best custom ROM for any phone, since it is extensively tested by loads of people and the developers are pretty good, too.
Other ROMs like the ones you mentioned are developed by a few kind people who have the time and resources to develop ROMs for a particular phone.
These unfortunately cannot match up to CM in terms of stability and performance, since there are always sure to be a few bugs around, and the comparatively less number of users means there aren't as many people to identify such things.

So, maybe what I'm saying is, we're all in the same boat, stuck on an old OS, waiting for someone to identify the problem with CM7.1 for x8, so that we may use it too.

THANK ME IF YOU FIND THIS REPLY USEFUL!
troika is offline  
Reply With Quote
Old October 20th, 2011, 01:09 PM   #20 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

dont know if you guys know this but cyanogenmod requires an unlocked bootloader otherwise it will fail you cant simply just root and xrecovery

heres the guide for noobs


forum.xda-developers.com/showthread.php?t=1267273
seanpr92 is offline  
Reply With Quote
sponsored links
Old October 20th, 2011, 04:49 PM   #21 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

hurm.....................................already unlock bootloader...not done! failed!!!!
The Man is offline  
Reply With Quote
Old October 20th, 2011, 04:50 PM   #22 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by seanpr92 View Post
dont know if you guys know this but cyanogenmod requires an unlocked bootloader otherwise it will fail you cant simply just root and xrecovery

heres the guide for noobs


forum.xda-developers.com/showthread.php?t=1267273
already unlock bootloader...failed also!!!........haizzzzzzzzzzzzzzzz
The Man is offline  
Reply With Quote
Old October 20th, 2011, 07:50 PM   #23 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

orait guys...i solved it!!!!!!!!!! YESSS!!!!.....

its true tht u need to unlock bootloader, but its IMPORTANT for u to change ur kernel too!!!!! go flash FXP028 kernel.....huhuuuuiiiiiiiiiiiiiiiiiiiiiiiiiii OMG, admin, ur information, soooooooooooooooooooooooooooooooooo, not helpful..im sorry...u say for requirement, "latest kernel"....suppose u said, must have FXP kernel!!!!
The Man is offline  
Last edited by The Man; October 20th, 2011 at 08:36 PM.
Reply With Quote
Old October 21st, 2011, 01:58 AM   #24 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by The Man View Post
orait guys...i solved it!!!!!!!!!! YESSS!!!!.....

its true tht u need to unlock bootloader, but its IMPORTANT for u to change ur kernel too!!!!! go flash FXP028 kernel.....huhuuuuiiiiiiiiiiiiiiiiiiiiiiiiiii OMG, admin, ur information, soooooooooooooooooooooooooooooooooo, not helpful..im sorry...u say for requirement, "latest kernel"....suppose u said, must have FXP kernel!!!!
Hi,

Thanks for the update. I have been away for a while.
I have updated the instructions to include flashing FXP043 Kernel

cheers
gabe
gabeyong is offline  
Reply With Quote
Old October 21st, 2011, 03:12 PM   #25 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by gabeyong View Post
Hi,

Thanks for the update. I have been away for a while.
I have updated the instructions to include flashing FXP043 Kernel

cheers
gabe
great...love u!!!!
The Man is offline  
Reply With Quote
Old October 21st, 2011, 05:45 PM   #26 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Done it all got it installed but it just freezes 1 minute after booting and I have to pull the battery to restart the phone. Tried it twice and I get the same result :S

Ok I'm reading in other places too that this is very buggy at the moment and causing a lot of freezing issues, I wouldn't update this until a new kernel is released on Monday.
fash_ric is offline  
Last edited by fash_ric; October 22nd, 2011 at 06:35 AM.
Reply With Quote
Old November 7th, 2011, 05:37 AM   #27 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Proper Way to install this.

Requirements:
- Rooted X8 E15i
- xRecovery installed
- baseband ver. 015

Now:
1) Download the ClockworkMod Recovery (CWM-recovery-4.0.1.4-r2-e15-Amend.zip) and CM7.1 Custom ROM, FlashTool, FXP043 Kernel and Baseband 015
and copy them to SD before you start everything.
2) Start xRecovery, format the existing DATA, CACHE and SYSTEM partition + Delvik, Bat. Stats, and Factory reset on the end of this step.
3) Install custom update -> Select the CWM-recovery-4.0.1.4-r2-e15-Amend.zip file and it will install the ClockWork Mode Reboot.
4) Start CWM (ClockWork Mode) by hitting the back button while the SE logo is on the screen.
5) Install custom update -> select the CM7.1 Custom ROM, FlashTool, FXP043 Kernel and Baseband 015. It will install. Then reboot. That's it.
Cheers.
goranpetrevski is offline  
Reply With Quote
Old November 8th, 2011, 02:14 AM   #28 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default battery life poblem.

Last time I did this with a similar tutorial from this forum my battery time started to suck very badly. 15%+ disappeared everytime I restarted the phone.
And with my my 3G data trafic on about 25% disappeared in about 8 hours of time without me even touching the phone and I have nothing like facebook, email or anything else that needs to check for updates certain amount of times each hour or something like that.
Everytime I turn my phone back to the original 2.1 android everything is fine again.

Also when I use my phone on standby without 3G Data trafic the battery time is still that shit.

Any ideas on how to improve this? or maybe this version is more stable and won't have that problem?

thx in advance
tazbaz is offline  
Reply With Quote
Old November 23rd, 2011, 12:51 AM   #29 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Cry Hi There i also need so help on my Phone

Model Number E15I
Based Version 015
Firmware Version 2.1-upadate1

So i m new about android sys...
I would to Upgrade to 2.2 or 2.3 how??
Where should i fine it and download it??

I been trying to install Xrecovery to my phone but fail..
How should it done pls... guide me to the way, install it...

Thanks For all the Help...
David CVY
Davidcvy is offline  
Reply With Quote
Old November 23rd, 2011, 04:52 PM   #30 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by Davidcvy View Post
Model Number E15I
Based Version 015
Firmware Version 2.1-upadate1

So i m new about android sys...
I would to Upgrade to 2.2 or 2.3 how??
Where should i fine it and download it??

I been trying to install Xrecovery to my phone but fail..
How should it done pls... guide me to the way, install it...

Thanks For all the Help...
David CVY

Hi,

If you want to upgrade to Gingerbread 2.3 have a look at the guides
here AND here
Both are stable and fast.
cheers
gabe
gabeyong is offline  
Reply With Quote
The Following User Says Thank You to gabeyong For This Useful Post:
Davidcvy (November 24th, 2011)
sponsored links
Old November 24th, 2011, 12:25 AM   #31 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

where i can get the V13 download.... and by the way thanks for the help...i already install the Xrecover
Davidcvy is offline  
Last edited by Davidcvy; December 5th, 2011 at 01:19 AM.
Reply With Quote
Old November 28th, 2011, 12:48 AM   #32 (permalink)
New Member
 
Join Date: Mar 2011
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

hello...i already change to 2.3.7. but i got some problem with my wifi..
my wfi doesn't detect other network.....ZZzzz

come anyone pro help me...
fauzan89 is offline  
Last edited by fauzan89; November 28th, 2011 at 01:41 AM.
Reply With Quote
Old November 30th, 2011, 05:19 PM   #33 (permalink)
New Member
 
Join Date: Mar 2011
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Question

hello.....answer me please...
fauzan89 is offline  
Reply With Quote
Old December 1st, 2011, 05:51 PM   #34 (permalink)
New Member
 
Join Date: Mar 2011
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Cry

nobody here??
fauzan89 is offline  
Reply With Quote
Old December 2nd, 2011, 12:54 AM   #35 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by fauzan89 View Post
hello...i already change to 2.3.7. but i got some problem with my wifi..
my wfi doesn't detect other network.....ZZzzz
come anyone pro help me...
Quote:
Originally Posted by fauzan89 View Post
hello.....answer me please...
Quote:
Originally Posted by fauzan89 View Post
nobody here??
Hi,

You have a router incompatibility with the Xperia X8 wifi rom settings?
Change rom or reset your router to <b/g only>.

cheers
gabe
gabeyong is offline  
Reply With Quote
Old December 9th, 2011, 07:00 AM   #36 (permalink)
New Member
 
Join Date: Mar 2011
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

router at my home?please explain me detail..
fauzan89 is offline  
Reply With Quote
Old December 28th, 2011, 03:35 AM   #37 (permalink)
New Member
 
Join Date: Mar 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Where can I see if my phone is E15i or E15a?
In "About phone" I can't see this information. Gingerbread 2.3.5 ROM is installed
kohan is offline  
Reply With Quote
Old December 28th, 2011, 06:49 PM   #38 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I installed CM 7.1 with the instruction in this thread and my mobile phone started well with the mod, but after some seconds it crashed. It removed the battery and started it again but the same problem. It crashes after some seconds. What can be the problem?
Xethon is offline  
Reply With Quote
Old December 31st, 2011, 10:47 AM   #39 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

I think I bricked my phone

I have installed xrecovery + clockworkmod and have been testing several roms for the past 6 months, i'm not a new user...

However I made a tiny mistake today and I think I totally screw it... Instead of selecting the .zip file update-cm-7.1.0-X8-KANG-signed to update, I chose the file that contains the flashtool, the update and the baseband 015... Since then when I reboot the phone I can't go further than the Sony Ericsson startup screen. I can't launch the clockworkmod recovery :S

any advice?
MarianoArg is offline  
Reply With Quote
Old December 31st, 2011, 06:26 PM   #40 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by MarianoArg View Post
I think I bricked my phone

I have installed xrecovery + clockworkmod and have been testing several roms for the past 6 months, i'm not a new user...

However I made a tiny mistake today and I think I totally screw it... Instead of selecting the .zip file update-cm-7.1.0-X8-KANG-signed to update, I chose the file that contains the flashtool, the update and the baseband 015... Since then when I reboot the phone I can't go further than the Sony Ericsson startup screen. I can't launch the clockworkmod recovery :S

any advice?
hi,

you need put your phone into recovery mode and then re-install your phone's software using PC Companion.

cheers
gabe
gabeyong is offline  
Reply With Quote
The Following User Says Thank You to gabeyong For This Useful Post:
MarianoArg (January 1st, 2012)
sponsored links
Old January 1st, 2012, 11:17 AM   #41 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

hey thanks for the help, finally I used flash tools and installed the shakira rom.

The xrecovery is gone though, I'll add it today and see if my old backups are still there
MarianoArg is offline  
Reply With Quote
Old January 1st, 2012, 05:43 PM   #42 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

hey so I had to flash it again with 1.6 since it was easier to root.

The problem now is that I rooted it and reinstalled xRecovery but when I try to restore an old backup I end in the same situation: phone won't pass the sony ericsson screen (or hackdroid screen, depending what backup I'm trying to restore)

I just followed the steps of this guide... do you have any idea what might be going on with my phone?

edit: baseband unknown... it seems I'll have to fix that first, sorry for the confusion. If a mod needs to delet this post, please do it.
MarianoArg is offline  
Last edited by MarianoArg; January 1st, 2012 at 07:32 PM.
Reply With Quote
Old January 11th, 2012, 08:12 AM   #43 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi all friends,

I've read the procedure you detail to install MOD 7 in a Xperia X8 and specified some requirements.
I supose that your requirements are for people that have installed original operating system of their phone.
In my case, I made un upgrade from original OS to Mod Version MiniCM6-1.0.2 (Froyo version of Android (2.2.1), but now I want to make a new upgrade to MOD 7

How could I upgrade fom MiniCM6-1.0.2 to MOD 7.1 in order to have the Gingerbread version of Android (2.3.5). My Xperia was originally Xperia X8 E15a
rubenzfox is offline  
Reply With Quote
Old January 15th, 2012, 11:36 AM   #44 (permalink)
New Member
 
Join Date: Jan 2012
Location: Cornwall, England
Posts: 1
 
Device(s): Sony Erricson Xperia x8
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Isnt It Dangerous Doing This? ive rooted my xperia x8 but to scared to install Cyanogenmod on it, help?
KierFX is offline  
Reply With Quote
Old January 16th, 2012, 09:25 PM   #45 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 725
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 289 Times in 163 Posts
Default

Quote:
Originally Posted by KierFX View Post
Isnt It Dangerous Doing This? ive rooted my xperia x8 but to scared to install Cyanogenmod on it, help?
Do not install Cyanogenmod 7.1 if you are not well versed with flashing custom kernels.

Try using GingerXperia or GingerDX

cheers
gabe
gabeyong is offline  
Reply With Quote
Old January 20th, 2012, 05:58 AM   #46 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default gingerxperia

ive'd been wondering...my x8 has already a cm7 mod rom..i installed a gingerxperia v12....its version is 2.3.7 ... whats the difference between this new rom that gabeyong posting...thanxz....
khroaxe is offline  
Reply With Quote
Old January 20th, 2012, 08:07 PM   #47 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up v22 gingerxperia rom

i successfully installed gingerxperia v22....when i first install v22 i bricked my phone...all i did is update my w8 walkman phone (E16i) using SEUS...then i choose the xperia x8 phone for the software update....when i booted it,it shows xperia x8 on model E16i...i rooted it using superoneclick...then installed busybox installer on android market....then install xrecovery01....after that i booted it on xrecovery and create a backup....then turn it off...after that i flash it using flashtool and flash x8 shakira e15i baseband version 015....reboot the phone and enable usb debbuging mode and unknown sources...reboot the phone on xrecovery and run custom zip installation...choose the gingerxperia v22.... and reboot the phone...and success! it booted and successfully installed v22 gingerxperia...

to those who exerted efforts in this mods....thank you so much and keep up the good work...thanxz gabe...ur post helps us newbie a lot.....
khroaxe is offline  
Reply With Quote
Old January 24th, 2012, 05:43 PM   #48 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

PLS upload clockwork! plssss i cant download from fileserve... -.-'
axell is offline  
Reply With Quote
Old February 8th, 2012, 01:00 PM   #49 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey guys, I managed to backup with clockwork mod but I get stuck at point where I have to flash with the custom kernel (flashtool) it just aborts with

08/056/2012 20:56:42 - ERROR - Error flashing. Aborted
08/056/2012 20:56:42 - INFO - Now unplug the device and power it on
08/056/2012 20:56:42 - INFO - Then go to application settings
08/056/2012 20:56:42 - INFO - turn on Unknown Sources and Debugging

Phone is rooted, and unknown sources and debugging are already turned on. What the heck? With the latest version of flashtool (0.6.7.0), I get this:

08/058/2012 20:58:41 - ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ER R_DYNAMIC="SIN header verification failed"

I've tried many methods to fix these errors, none of them worked. Anyone has a clue what is wrong? Thought the .ftf file was corrupted, but winrar didn't show any CRC errors.
Porgos is offline  
Reply With Quote
Old February 8th, 2012, 06:09 PM   #50 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok so I figured out how to unlock the baseband and flash it to 015. Still the same error.
  • Phone is rooted
  • Has custom kernel FXP042
  • Has xRecovery and CWM
  • Baseband 015
  • is model E15i
Any ideas?
Porgos is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X8 > X8 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://androidforums.com/x8-all-things-root/427467-rom-cyanogenmod-7-rc1-v4-stock-kernel-xperia-x8.html
Posted By For Type Date
Update Guide to Cyanogenmod 7.1??? - CyanogenMod Forum This thread Refback March 9th, 2012 12:38 AM


All times are GMT -5. The time now is 06:54 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.