Go Back   Android Forums > Android Phones > ZTE Warp Sequent

Like Tree1Likes
  • 1 Post By alpha2k

test: Reply
 
LinkBack Thread Tools
Old October 14th, 2012, 11:34 PM   #1 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 861
 
Device(s): Classy Samsung Epic 4g Touch
Carrier: Boost Mobile

Thanks: 9
Thanked 104 Times in 80 Posts
Default Is high CPU usage normal on android?

I'm not sure exactly what's going on because I'm not a really in-depth android guru, so I will post what I do know and understand and maybe it can be resolved.

I noticed today in task manager that cpu usage was hovering at 45% to 55% on avg, and spiking to 85% clear up to 98% at times. Well this had me puzzled and wondering so I started digging, and thought perhaps an app was flaking out, or maybe I needed to ditch an app of sorts.
So it began I started uninstalling apps, checking task manager, no change, another app, and so on for about 10 apps I thought might be the issue, namely all the notification ones and background apps, such as widgets.
I checked once again with no change so I rebooted. Same thing.

So now I am at the point I am going to just reset to factory defaults with NO apps, ALL factory settings set as they are so nothing can be blamed for interfering.

Now here I am, all factory reset, with zero apps installed other than the phones default ones, and have touched no settings at all throughout the system. Same shortcuts and such on the desktop, havn't changed a single thing.

I have run task manager and I'm idleing at 45% - 55% cpu usage.

I let the phone set for about 10-20 mins, re-check it and it hovering at 20%-30%, then finally sticks around 18%-23% area.

When I checked with an app called OS Monitor, it showed that the active process that was so high usage was called "system" (not android os thats is a different process) this was before I factory reset the phone and the phone had a 45%-55% CPU usage at idle doing nothing.

So I guess my questions are...
-Is this normal with android the high spikes and staying so high CPU usage?
-Doesn't the high CPU usage drain the battery faster? if so how much faster?
-Could low battery have any effect on the CPU usage at all? My batter was between 14% and 20% when I noticed this happening this evening.

Advertisements
alpha2k is online now  
Last edited by alpha2k; October 15th, 2012 at 01:16 AM.
Reply With Quote
sponsored links
Old October 15th, 2012, 07:24 AM   #2 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 861
 
Device(s): Classy Samsung Epic 4g Touch
Carrier: Boost Mobile

Thanks: 9
Thanked 104 Times in 80 Posts
Default

Ok this is getting a bit irritateing now!
I have a total of 4 apps installed, they are as follows:
-Digi clock widget
-Wigiestsoid - Two 4x1 toggle bars in notification (not on homescreen) with 5 toggles on each
-App Backup & Restore
and
-Alarm Clock Plus

When I went to bed last night I checked the task manager and it was idleing at between 9% and 12%, this I can handle and am fine with.
My 3g/data is off, as is my wifi, gps, live wallpapers, animations, pretty much any thing that can suck the battery I turn off and toggle what is needed when it is needed.

I wake up this morning and check the task manager and when I first see it it reads 37%, then jumps a few seconds later to 87% and idles between 87% and 98%. I have let the phone sit for up to 30 mins like this without a change and without seeing it go down.

I have rebooted, killed every app possible except for the system specific ones that need to run ie: the ui type files.
I have also shut down and restarted, thinking it was something stuck in a loop or something. When I shut down and restarted, I decided why not pull the battery, so I have done that also, just for safety measures.

So what gives?!?!?!?!?

I'm now wondering if I am plagued once again with a faulty product.


HELP! I'm desperate now, anyone have any suggestions, other than root which isn't at a perfect stage right now anyways.

Anyone, anyone? Zte reps??

I've exhausted everything I know to do.
alpha2k is online now  
Reply With Quote
Old October 15th, 2012, 08:07 AM   #3 (permalink)
Senior Member
 
kevindroid's Avatar
 
Join Date: Oct 2010
Location: baltimore
Gender: Male
Posts: 924
 
Device(s): htc one m8/nexus 5/nexus 7 v2
Carrier: t-mobile

Thanks: 226
Thanked 226 Times in 189 Posts
Default

if the phone is not running hot i wouldnt worry too much
kevindroid is online now  
Reply With Quote
Old October 15th, 2012, 11:41 AM   #4 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 861
 
Device(s): Classy Samsung Epic 4g Touch
Carrier: Boost Mobile

Thanks: 9
Thanked 104 Times in 80 Posts
Default

It's not a matter of heat. It doesn't heat up at all.

It's a matter of 2 things.....
1- saving or cutting down on the battery usage and battery draining fast
2- smoothness and or laggyness of the phone and phone use.

It also is a matter of if this phone has issues, I need to know about it so as to either not make the same mistake, or fix the issue at hand.
rlphbgby likes this.
alpha2k is online now  
Reply With Quote
Old October 15th, 2012, 10:12 PM   #5 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 861
 
Device(s): Classy Samsung Epic 4g Touch
Carrier: Boost Mobile

Thanks: 9
Thanked 104 Times in 80 Posts
Default

So....only 1 reply, and that's it, not a single ZTE Rep decided to help.
Real assuring to see this. (that's sarcasm for those who were interested)

I guess I'll start by my final findings.
I chose 4-6 apps to install, and stuck with those 4-6 apps all day. I've done 4 phone resets total today, and 2 yesterday. I have installed these 4-6 apps in no particular order, one at a time, making sure to test each one to see if the cpu usage spiked at all. At between the 4-6 app, is where I get the cpu spike. I then reset the phone to factory default again, and since I was thinking that last app was the bad app, I install THAT app fist this time. Well to my shock and surprise, nothing went wrong. So all this install of the apps in no order, each time is a different order, and still the same result between the 4-6 app install, and bingo it happens the same way EVERY time.
So I uninstall EVERY app I installed already, reboot the phone, pull the battery, count 10 seconds (1001, 1002, etc..), put the battery back in the phone and boot the phone up. No app installed, and only factory default items/apps....I check task manager, and bingo, cpu spike 85%-95%.
I can replicate this EVERY time I do this, not using a pattern of apps to install, but it happens every time. I've been on my phone this reset about 6 hrs now, and every time I check task manager, I get the cpu spike.
Another note I will add is every time I reset to factory default, the cpu spike didn't happen until between that 4th to 6th app, so I know once I reset the phone again I will have magically fixed the cpu spike. If I keep the phone in this state, it's fine as long as I do not install any apps. I ran my phone this way early this morning for about 2 hours with no cpu spike.


I am going to exchange the phone out and see how the next one fairs, but I don't really hold much hope in it, because it seems ZTE has abandoned this phone too. After spending a wasted 30 mins of my life on the phone with ZTE tech support, the broken language barrier, and the not understanding anything, I don't expect much in the way of them replying or responding back to my threads either. I'm cool with that I guess, not like I have a choice in the matter, I guess if anything I wish I could get that 30 mins of my life back.

I am also leaving both zte reps a private message with my phone number, so PLEASE feel free to call voice, because I will truly be surprised if I even get a call.
alpha2k is online now  
Last edited by alpha2k; October 15th, 2012 at 10:22 PM.
Reply With Quote
Old October 15th, 2012, 10:31 PM   #6 (permalink)
Junior Member
 
Join Date: Sep 2012
Posts: 47
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 8 Times in 4 Posts
Default

hi,just saw your topic there. For urgent issue you can email me in order to I know that in time.

Here is my email: wu.qing2@zte.com.cn
QingWu is offline  
Reply With Quote
Old October 16th, 2012, 10:00 PM   #7 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 861
 
Device(s): Classy Samsung Epic 4g Touch
Carrier: Boost Mobile

Thanks: 9
Thanked 104 Times in 80 Posts
Default

Well it is a sad day for me today.
I traded out my phone for another one, and did the same steps, and yep, got the same results, 85% to 95% cpu usage.

Zte said they were looking into it, so I will at least give them the benefit of the doubt, before I decide to ditch it.

I love the phone, it has a lot of potential, if not for this extremely high cpu usage, the phone would be a nice fit for me. I would imagine others are having the same issue as I do, but not sure, no one posts so it's hard to even tell. I'm thinking everyone has moved on to other phones.

Update:
Some way some how, the phone worked out all it's kinks lol. I have NOT a clue why or what happened, but it's working fine now. I have everything on I did before and cpu is avg idle of 8%-13%, norms while active can range from 25%-45%, and spikes up to 65%-78%, but the spikes drop down to norm or idle percentages quickly....it's expected when activity is going on.

So in my head I am throwing a BIG party right now .
alpha2k is online now  
Last edited by alpha2k; October 17th, 2012 at 07:56 PM.
Reply With Quote
Old October 23rd, 2012, 01:16 PM   #8 (permalink)
Junior Member
 
Join Date: Feb 2012
Location: New York
Posts: 20
 
Device(s): Samsung Galaxy S3 4g LTE
Carrier: Boostmobile

Thanks: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by QingWu View Post
hi,just saw your topic there. For urgent issue you can email me in order to I know that in time.

Here is my email: wu.qing2@zte.com.cn

Hi, cpu and ram runs very high, please, can you place solutions here?
mauricio1717 is offline  
Reply With Quote
Old October 25th, 2012, 09:31 PM   #9 (permalink)
Junior Member
 
Join Date: Sep 2012
Posts: 47
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 8 Times in 4 Posts
Default

Quote:
Originally Posted by mauricio1717 View Post
Hi, cpu and ram runs very high, please, can you place solutions here?
Could you take a screen shot for me to analyze?

Holding power key and volume down key at same time for 3 seconds, you will get a screen shot.
QingWu is offline  
Reply With Quote
Old October 29th, 2012, 10:20 PM   #10 (permalink)
Member
 
chrisjv3393's Avatar
 
Join Date: Apr 2012
Gender: Male
Posts: 342
 
Device(s): Samsung Galaxy Prevail, ZTE Warp Sequent
Carrier: Not Provided

Thanks: 24
Thanked 33 Times in 23 Posts
Default

My phone is doing the same n its reeaallyyy annoying!!! How did ur high cpu usage suddenly stopped??
chrisjv3393 is offline  
Reply With Quote
sponsored links
Old November 1st, 2012, 01:58 PM   #11 (permalink)
Junior Member
 
Join Date: Aug 2012
Posts: 32
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 4 Posts
Default

If your phone is new, give it a couple of days for it to settle down. This is Android "remembering" your phone usage - it actually optimizes itself.

I had the same thing happen to my S3 and was going nuts because I was doing the same as you.

Give it a couple of days, and if it's still no good, then it's a hardware issue (faulty battery maybe).

Get JuiceDefender and monitor with Watchdog Task Manager Lite.
Serdroid12 is offline  
Reply With Quote
Old November 1st, 2012, 08:22 PM   #12 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 861
 
Device(s): Classy Samsung Epic 4g Touch
Carrier: Boost Mobile

Thanks: 9
Thanked 104 Times in 80 Posts
Default

If your using the task manager, don't, it will ALWAYS show cpu usage high.
I learned that in task manager, and also an app called OS monitor, in both the cpu usage was high. I'm not sure why exactly but when in those apps they were high. I think it's the way the system is reading the usage.

A better way to check is download OS Monitor from the play store, and use it via the notification tray, you should notice better cpu usage.

When I was in Task manager and OS Monitor, inside the apps, both read 85% to 95% most all the time. When useing OS Monitor in the notification it showed quite a bit lower cpu usage.
alpha2k is online now  
Reply With Quote
Old November 1st, 2012, 09:48 PM   #13 (permalink)
Member
 
chrisjv3393's Avatar
 
Join Date: Apr 2012
Gender: Male
Posts: 342
 
Device(s): Samsung Galaxy Prevail, ZTE Warp Sequent
Carrier: Not Provided

Thanks: 24
Thanked 33 Times in 23 Posts
Default

I just realized it aint the cpu thats high.. its the RAM... ill only have like 75mb free of 579mb
chrisjv3393 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > ZTE Warp Sequent
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:00 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.