1. Check out our companion app, Forums for Android! Download from Google Play

Support 0% Battery. Unable to charge

Discussion in 'Android Devices' started by WadeLogan, Oct 3, 2012.

  1. WadeLogan

    WadeLogan New Member
    Thread Starter

    Oct 3, 2012
    I'm not sure where exactly I would ask this and it's been such a pain to find information for...

    In August I went on a camping trip to which 6 inches of rain in an hour took it's toll on my tent and my stuff. LG Thrill included.

    I set the phone in a bowl of rice and dried it out entirely. Ever since the phone will turn on if and only if it's plugged into a charger. If it's not plugged into a charger it automatically turns off about two seconds after the loading screens goes away.

    When it's plugged into a charger it maintains 0%. I've tried every trick coming and going and still nothing. 0%.

    Here's what I've done:
    -Tried about 5 different chargers and USB cords. No effect.
    -Bought a replacement battery. No effect. (This battery also says 0%)
    -Reformatted phone. No Effect.
    -Purchased external battery charger (thinking my micro USB is fried) No effect. All batteries are charged up, but once placed into the phone and turn the phone on it says 0%.

    The phone is not rooted.

    Every little trick from leaving the battery out for 30 seconds, to pressing down, home and power key for 15 seconds. Etc etc etc.

    Any advice would be amazingly helpful... I've done everything except shooting it.

    Thank you.
    - Wade


  2. sjrooney84

    sjrooney84 New Member

    Nov 9, 2012
    I have the same issue. Sorry.
  3. SaberJ2X

    SaberJ2X New Member

    Nov 27, 2012
    I think your board is fried mate... warranty time

Share This Page