1. Are you ready for the Galaxy S20? Here is everything we know so far!

1.5 compatibility issues with the new 2.2 SDK

Discussion in 'Android Development' started by lms5400, Aug 9, 2010.

  1. lms5400

    lms5400 Newbie
    Thread Starter

    I recently installed 2.2 and since then my 1.5 simulators and phones crash immediately with a runtime exception. I do have multiple resolution support (1.6 and later) and I have always been able to run my app both on new phones with larger resolutions, and the older phones running 1.5 even though I get the red X warning in the device select launch window the 1.5 simulator would still work (I was running SDK 2.0 at the time on my machine). Now since I have updated, to 2.2, the app crashes. Has anyone else encountered this problem? I would like my app to work on pre-1.6 phones and newer phones as well that take advantage of layout and drawable identifiers for dpi and scree size.


    I also recently updated my eclipse android plugin to 0.9.7 (that may have caused this issue too. I'm not 100% which it was because i did both at the same time :thinking:



    here are my target's in the manifest:
    [FONT=Courier New, monospace]<[/FONT][FONT=Courier New, monospace]uses-sdk[/FONT][FONT=Courier New, monospace] [/FONT][FONT=Courier New, monospace]android:minSdkVersion[/FONT][FONT=Courier New, monospace]=[/FONT][FONT=Courier New, monospace]"3"[/FONT][FONT=Courier New, monospace] [/FONT][FONT=Courier New, monospace]android:targetSdkVersion[/FONT][FONT=Courier New, monospace]=[/FONT][FONT=Courier New, monospace]"4"[/FONT][FONT=Courier New, monospace] [/FONT][FONT=Courier New, monospace]android:maxSdkVersion[/FONT][FONT=Courier New, monospace]=[/FONT][FONT=Courier New, monospace]"8"[/FONT][FONT=Courier New, monospace] [/FONT][FONT=Courier New, monospace]/>[/FONT]


    [FONT=Courier New, monospace]
    [/FONT]
     


  2. lms5400

    lms5400 Newbie
    Thread Starter

    looks like lot cat was giving me a resource not found error on the very first resource on my very first screen. I think its because 1.5 can't recognize the layout and drawable folders with identifiers, so i put the old folders back and it worked. Funny part is, it worked pre 2.2... odd. Anyway, I better check the larger resolutions because i probably broke them. Anyway, hope this helps someone.
     
  3. cp1

    cp1 Android Enthusiast

    Yeah, 1.5 doesn't have the same resolution categories for drawables/layouts. I found an article on how to make it work, but it just seemed like such a pain that I made my app 1.6+
     
Loading...

Share This Page

Loading...