1. Are you ready for the Galaxy S20? Here is everything we know so far!

........1 Click Root Optimus m (Gingerbreak)..............

Discussion in 'Android Devices' started by blaxican25, May 15, 2011.

  1. blaxican25

    blaxican25 Android Expert
    Thread Starter


    1. Download the Forums for Android™ app!


  2. 93stallion302

    93stallion302 Newbie

    Do we need to switch to the Gingerbread CM7 Rom to use this?
  3. blaxican25

    blaxican25 Android Expert
    Thread Starter

    it was made for gingerbread but this specific exploit may work on various Froyo and Honeycomb versions as well.
  4. reppard

    reppard Android Enthusiast

    You have to be rooted before you can use cm7 so...you wouldn't need this.
  5. mikekelso421

    mikekelso421 Android Enthusiast

    lol,i was thinking the same thing..and after all the hell we all went through to root our 2.2.1 phones,i have a feeling this wont work for them..but i could be wrong..it would be nice to have a ONE CLICK ROOT option for the 2.2.1's though.
  6. wilsonbx198st

    wilsonbx198st Well-Known Member

    This actually worked it rooted my optimus m. I had to reformatted my SD card tho
  7. blaxican25

    blaxican25 Android Expert
    Thread Starter

    glad it worked :D
  8. 93stallion302

    93stallion302 Newbie

    I meant it as in do you need to have gingerbread to use this, or would it work for 2.2.1. I already went through the heartache of rooting 2.2.1 the long way. It be nice to use a one click option on a few friends phones.
  9. blaxican25

    blaxican25 Android Expert
    Thread Starter

    with the oneclick method you would not have the custom recovery but you could still get rid of the metro bloat and use the root only apps.
  10. mikekelso421

    mikekelso421 Android Enthusiast

    but once you root you can download ADB and flash the recovery..:D
  11. blaxican25

    blaxican25 Android Expert
    Thread Starter

    yes this works on the optimus m
  12. mooranda

    mooranda Newbie

    I rooted with gingerbreak. can you install custom rom after using this program or is there any way to customize?
  13. mooranda

    mooranda Newbie

    worked on the optimus m for metro pcs
  14. blaxican25

    blaxican25 Android Expert
    Thread Starter

    i posted steps to flashing custom recovery and flashing a new rom at the bottom of post
  15. puNANI209

    puNANI209 Lurker

    The GingerBreak WORKS!!!! it rooted my stock optimus m 2.2.1 in like 30 secs. since im no good at rooting my phone the hard/long way, i waited for someone to make a ONE-CLICK root kit for the optimus m! rooted my optimus m with just ONE-Click of the GingerBreak at 1:41am on 5/22/11

    Stock 2.2.1 optimus rooted with just a CLICK!!!
    it works, trust me!

    THANK U SOOOOO F**K**G much for this dude!! thank you thank you
  16. redDEATH82

    redDEATH82 Newbie

    I'm new to all this so this will prob sound like a real noob question but how do I get the apk on my phone? And does it matter which file I use? Thanks
  17. blaxican25

    blaxican25 Android Expert
    Thread Starter

    place the apk on your sd card then download AppInstaller by FunTrigger from the market then open app installer and scroll down tell you see the gingerbreak apk and install it.
  18. kazhugu

    kazhugu Lurker

    This is by far the easiest method to root - it took me like 5 mins or so. Thank you so much!!

    I did it on my LG Optimus One P500 (India) which came with 2.2.1.
  19. kazhugu

    kazhugu Lurker

    I followed all the steps - and finally when I powered up the phone, it gets stuck showing the LG logo, nothing happens after :( It doesn't matter if I press only the power button or along with home/volume down buttons.

    Please help! Thanks.
  20. kazhugu

    kazhugu Lurker

    OK I unbricked it, if that's the term - thanks to this post: [Resolved] [HOW TO] Unbrick LG Optimus One P500 from fastboot mode started udc_start().. - xda-developers. Now the phone has stock rom. But what did I do wrong? The only step where I got an error was when it could not find the install-recovery.sh. I found from some other place that it's not there in all roms, so I thought it was OK. Well, I am going to root it again of course and get a custom rom, but I need some help here to understand what could have gone wrong. Thanks.
  21. blaxican25

    blaxican25 Android Expert
    Thread Starter

    this part of the forums is for lg optimus m and the recovery was made for the optimus m
    you can

    If the phone is frozen, hard reset it through buttons

    1. Turn the power off. If the phone is frozen, pull the battery out and inplace it back again
    2. Hold the Home and Volume Down button
    3. Press and hold the Power button until the phone turns on
    4. Follow the on-screen instructions to hard reset the phone handset

    heres recovery for your model
    kazhugu likes this.
  22. kazhugu

    kazhugu Lurker

    I finally got it to work - thanks to blaxican25. Two mistakes - used the wrong recovery and tried to use the wrong rom - the sense again was done for the optimus M and it didn't work for me, but thankfully I had the correct recovery at that time, so I just downloaded the correct rom for my phone (went with Prime) and everything worked out fine. I am a happy man :)
  23. Thanks man. This is awesome!! Props. I was about to root my friend's 2.2.1 today the hard way. Man am I relieved. haha
  24. blaxican25

    blaxican25 Android Expert
    Thread Starter

    glad it helped:d
  25. trapspringer

    trapspringer Newbie

    Ok So I got to the point where i'm installing joneidy's custom recovery when I got to the step of

    mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    it gave me error message

    failed on '/system/etc/install-recovery.sh' - No such file or directory

    i did everything exactly... what should i do here?


    Ok I got past that point. But when I got to the last line:

    flash_image recovery /sdcard/recovery-2.2.1-joneidy.img

    it gave me the following error message:

    mtd: not writing bad block at 0x00120000
    error closing recovery: No space left on device

    I have 35 megs available on the device the img file is about 5 megs. I've already restarted various times. what advice can i get.

    Thanks in advance.
    elf83 likes this.

Share This Page