1. Are you ready for the Galaxy S20? Here is everything we know so far!

100% CPU Usage, Poor Performance, Poor Battery Life - Solved

Discussion in 'Android Devices' started by iron_city, Nov 5, 2010.

  1. iron_city

    iron_city Member
    Thread Starter

    Greetings! I searched this forum for a similar issue, but I don't think any of them compare to what I was experiencing. Sorry for the long post, I am writing this in case anyone has a similar problem, and hopefully this solution will work for you.

    My X recently (within the last week) started having extremely poor battery performance under the same usage conditions as the previous week (K-9 syncs every 15 min, maybe 2 texts per hour, 2-3 emails per hour, maybe 5 total minutes of phone use). After 4 hours, the battery would be at 20-30%

    To make matters worse, most functions were extremely slow to respond (contact loading, test message loading, recent calls, bookmarks, any scrolling was choppy, etc.) The delay when trying the most basic things (opening the browser, making a call) was getting unbearable.

    I started backtracking the changes in the last week. Although I started tinkering with Google's App Inventor over three weeks ago, that's where I focused. I uninstalled all App Inventor programs, including the Eyes-Free Text to Speech engine. This engine was recommended by Google to do things like read text messages in the Apps you create.

    Still no luck.

    I decided to investigate the battery use a little more. In Battery Manager, I found that "Android System" was using about 70% of my battery. I was typically used to seeing things like "display" at the top.

    I have an app called Android System Info. This showed my CPU usage pegged at 100% (even after a reboot). It never got lower than 99%. The biggest CPU hog was "Android System" at 75-80%, consistently.

    This App has a tab to view the log, and I noticed several recurring error messages in the log. They were occurring at the rate of about 180 times per second! The error? "Invalid TTS Engine" Well, the TTS is controlled by the "Android System". The "Android System" was constantly trying to load the uninstalled TTS engine.

    I went into "Settings...Voice input and output", and, although the Eyes Free TTS engine wasn't available, the default TTS was not set. I checked the box to have the native TTS as the default, and checked the box for "Always use my settings".

    Everything immediately went back to normal. CPU usage is now around 10-20%, and "Display" is back at the top of my battery hogging functions.

    Battery life is back to over 10 hours, and the delays are gone.
     


    momsdear, javamann, danonh and 9 others like this.
  2. DroidXCase

    DroidXCase Guest

    Do you mean Pico TTS? Took me a second to figure out TTS is Text To Speech btw.
     
  3. bigbadwulff

    bigbadwulff Android Expert

    Yup, if you are gonna use abbreviations, please the first time write what the abbreviation is for.
     
  4. iron_city

    iron_city Member
    Thread Starter

    Yes, I meant Pico TTS as the default ... Sorry

    WD! (will do)
     
    nevergonnauseth likes this.
  5. bassett

    bassett Newbie

    Great post. This kind of effort is what make Android Forums such a wonderful resource.

    P.S. TTS is a commonly known "word" to geeks, much like yup and btw to others. ;)
     
  6. Thank you for the post. Thanks also for explaining what tts was. I am not a geek but I do know what btw means. I am very new to droid x having updated from a moto q9c which I hated from the beginning. :)
     
  7. lennydude

    lennydude Android Expert

    Great job !

    I also have run into issues with certain apps i have d/loaded (download/downloaded) on my phone.
    You just either need to d/load apps one at a time and try them or do search and rescue missions like the OP (original poster)
     
  8. jbell255

    jbell255 Lurker

    Problem NOT solved.

    Android System still using 99% of my CPU and I can't figure out how to fix it. Rooted and running apex 131. Only recently having this problem.
     
  9. johnszy72

    johnszy72 Newbie

    Ok so now you have me wondering since I just looked at my battery statistics. If my Android System is at 51% and the display is only 23% would that sound normal given that I have the brightness on my screen set to 0% all the time?
     
  10. nycebo

    nycebo Android Enthusiast

    Great post. Much appreciated Iron City.

    Guys, you are going to have to install a more detailed logger (Watchdog, Android System Info, etc) so you can see what exactly is eating up your processor. It's my contention that it's generally or setting or app that is deviating from the norm and one just needs to track it down. For me recently, it has been Gallery3D (the nexus 1 gallery, not the stock Droid X gallery which is actually pretty nice also). Turns out that Gallery3D just churns data and processor while it is updating and populating photos. Watchdog would alert me to it constantly. Got JustPictures instead in order to access my Picasa account and all is good again.
     
  11. iron_city

    iron_city Member
    Thread Starter

    ^^ Great point about the logger. Although the issue I had was very specific, I think the main reason I posted this was because the approach can be used regardless of the problem.

    It was a nice lesson (for me) of how little issues can have extreme consequences. My phone was almost unusable.
     
  12. nycebo

    nycebo Android Enthusiast

    Couldn't agree more. I'm convinced that most of the bad experiences that folks have with the phone is completely related to an experience like yours. Alas, it takes a little more leg work, elbow grease, and eventual know-how in order to resolve it...especially for folks coming from iOS who aren't used to doing anything....but are also limited by what they can do.

    Glad to hear that all is well for you again. While I didn't have your issue (yet), I adjusted my TTS settings as per yours so as to prevent this one.
     
  13. ikroot

    ikroot Lurker

    Same thing happened with my Droid2 Global. Sudden severe degradation in performance, CPU continuously at 100%, battery life of nanoseconds. I tried app uninstalling, and even did a full factory reset, with no resolution to the problem. I was just about to junk it and buy a new phone when I Googled the problem and came upon your note. One click on "Always use my settings" in the Voice output--Text-to-speech settings screen and the problem was instantly resolved.
    The interesting thing is that I've never knowingly used anything involving text to speech on my phone, nor have I knowingly installed any apps that might have changed the defaults.
    Many, many thanks. Your post has saved me several hundred dollars!
     
  14. iron_city

    iron_city Member
    Thread Starter

    That's awesome, ikroot

    Welcome to the forums :)
     
    Argelius likes this.
  15. Argelius

    Argelius Lurker

    ASUS transformer TF-101 had the same problem. Thanks for the tip. I was stumped but setting the TTS options fixed my CPU consumption problem. TF owners beware.
     
  16. vipul619

    vipul619 Well-Known Member

    came across this today..
    nice tip :D
     
  17. Saxx358

    Saxx358 Lurker

    Make sure you reboot after you make the changes to regarding the tts (or anything else for that matter) I made the changes (selecting "always use my settings" and nothing happened. At first I was like crap then I restarted my phone and it's like a whole new phone now! Thanks for the help!
     
  18. danonh

    danonh Lurker

    Thanks iron_city for the tip! For some reason, it appeared that my default text-to-speech engine, PicoTTS, is broken, so I set my Samsung GSII E4GT on SamsungTTS as default and my CPU usage went from90-100% to maybe 10% or so.

    Phone cooled off quite a bit too and doesn't eventually reboot itself like it was doing (due to heat maybe?)!
     
  19. momsdear

    momsdear Newbie

    hi...
    your post helped me a lot in solving my problem of CPU load in GS2...
    thanX A lot....
     
  20. SuMeRiaNs

    SuMeRiaNs Lurker

    Typed out a long question a bout a problem I was having. It included a link so I was directed here. NOW I cant go back to my previous post.
     
  21. Davidkemp

    Davidkemp Lurker

    I


    I can't seem to find the text to speech settings. Where is the always use my settings?
     
  22. Davidkemp

    Davidkemp Lurker


    I can't find these settings that you mentioned for TTS. Where is the "always use my settings"????
     
  23. Davidkemp

    Davidkemp Lurker

    @iron_city

    I can't find these settings that you mentioned for TTS. Where is the "always use my settings"????
     
  24. Sindi

    Sindi Lurker

    Cheers @iron_city - seems to have helped me out (sept 2018!)...as you say, tiny thing with massive impact, this and clearing another glitch has helped loads - my system now at 5%.
    Was numerously on verge of smacking tablet against a wall to improve performance as borderline uselessness was raising blood pressure (&had already done factory reset).
    Cheers!
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...