1. Check out our companion app, Forums for Android! Download from Google Play

Support 100MB of internal storage... but "insufficient space on device"???

Discussion in 'Android Devices' started by spiritualflow, Jul 28, 2012.

  1. spiritualflow

    spiritualflow New Member
    Thread Starter

    Jul 28, 2012

    First off, I must say that I am extremely new to Android, (like... a day old user lol) and I know pretty much nothing when it comes to terms, so if you have a suggestion, please write it as if I don't know what you are talking about :)

    So basically I am trying to download an app called Doodle Fit (free) and it needs 28.72MB. When I try to install it it tells me I have insufficient space on my device. So I went to check it out... I THINK in the right area and saw this:

    Settings > Applications > Running Services > Avail: 105MB+75MB in 10 (although those numbers keep changing...)

    Settings > SD card and phone storage settings > SD card: Total space 1.84GB, Available space 1.78GB and Interval phone storage : 106MB.

    So I am assuming I have at least 100MB of space right? but I cant download something under 30MB??? why is this?

    Also, I tried downloading flash and it failed... I got the archived version 10.1 from the adobe site and put it on the sd card but it wouldn't install, so I deleted that file. I heard people talking about "bad flash", is this what they mean?

    And lastly, I technically have a Samsung Galaxy Q because I'm Canadian, but it's still a SGH-T589R

    Thanks in advance!


  2. gblues

    gblues Well-Known Member

    Mar 19, 2012
    Caldwell, Idaho
    The Google Play store downloads apps to the cache partition which has a whopping 20mb. So, regardless of how much space the rest of your phone has, the phone will not download any app larger than 20mb from the Google Play store.

    Check the Amazon App Store to see if you can get it there. The Amazon App Store does not have such a limitation.
  3. nettttie

    nettttie New Member

    Sep 18, 2012
    hi, does anyone know if this problems occurs when downloading apps from the laptop as opposed from directly from the browser? It's driving me mad and I'm tempted to return the phone!

    I don't really want to root it as I've no idea what this is/how to do it/and worry if my warranty will still be valid.

    Thanks for any help!
  4. horsecharles

    horsecharles Well-Known Member

    Dec 14, 2010
    To fix that quickly + kinda ensure problem does not reappear
    you do need to be rooted, otherwise it'll be very cumbersome/difficult.
    If U change ur mind about rooting we can offer fairly simple solutions.
    But then again, the rooting process could turn out not so easy.
    But it's worth that initial effort.
  5. johnkm

    johnkm Member

    Oct 1, 2012
    Dear all and especially to horsecharles,

    I am a newbie to the forum and
    I am vy new to android phones (3 weeks) and I have just got
    my Galaxy Q in Canada (I guess it is called Gravity Smart in the US).
    The low internal memory of 184M is really the biggest limitation of the phone so I had to root it the first week of my procession LOL! After following some
    Youtube videos, I was able to set default install location to 2 (meaning SDcard). So I thought I was done as I have 8G there.

    But I now have the same problem of the OP!!
    Now most apps will install on the SDcard but some apps bigger than
    20M or so from Google play will refuse to install, saying insufficient space,
    while I still have about 60M internal memory left.

    U had mentioned that it would be easy with a rooted phone and I love to
    hear from u how to lift that 20M limitations.

    Thanks in advance! John
  6. johnkm

    johnkm Member

    Oct 1, 2012
    Found a workaround. :) I was trying to install the 100 floors game into my Galaxy Q but it was too large at 47.5M via google play.

    So I tried to locate the 100floors.apk file on the web and once I found it, I copied it into my SDcard via USB cable. (mounting required).
    I put it under the download folder. Then I use file expert (file manager app) to open the file. It then prompted me to install this huge game and was successful! yay! My phone memory was low at around 62M and it was still successful! No rooting required!

    So I now know it is a google play problem for the 20M file size limitation.

    But I still haven't solved the original problem with google play LOL!

    Another question I have is that now I can pretty much place the apps on SDcard
    but the data files are still on the phone, slowly eating up my tiny phone memory!

    Can we move the app generated data files into SDcard?

    Thanks! John
  7. johnkm

    johnkm Member

    Oct 1, 2012
    Ok, 20M google play download file size limitation resolved! Thanks to hotdogfriend:



    The Cache Fixer App really kicked butt for me! Tmpfs option worked for this phone (Galaxy Gravity Smart/ Q) & boosted my cache size from 20M to 138M!

    No problem downloading apps > 20M's now. Just tried a 29M app and was fine!

    After the download I quickly restored the cache to its original state to avoid any possible problems...
  8. goodshape

    goodshape Member

    Nov 26, 2011
    I have found what is causing the memory to disappear.
    When looking at the email app I noticed that it's size is increasing every day by a MB or two and today it was at 120MB almost the whole size of the memory. I don't keep ANY emails on the phone. I only use the email app to receive, read and then delete emails.
    HOWEVER when you send or delete emails the app keeps a copy in the SENT file and the TRASH file.
    Make sure that you delete these emails unless you absolutely want to save some.
    Deleting some 4000+ TRASH messages reduced the email client back down to 250kb from 120MB.
    I now have lots of internal space.

Share This Page