1. Are you ready for the Galaxy S20? Here is everything we know so far!

[1st Gen] [How To] Successfully Install Swype - Root Required

Discussion in 'Android Devices' started by Airmaxx23, Dec 29, 2011.

  1. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    Here's how I got Swype installed and working on my Kindle Fire: You will need to be rooted to do this.

    1) Download the installer from your beta email or transfer it from one of your other devices (If you get an error saying "Sorry! This is not an Android Phone..." make sure your browser is set to mobile view and not desktop.)

    2) Log in

    3) Select your Beta version

    4) Install the Swype keyboard

    5) Use Root Explorer and navigate to /data/apps and find the Swype apk

    6) Move the Swype apk (not the installer) to /system/apps

    7) Make sure permissions are rw- r-- r--

    8) Reboot your device

    9) Long press on a text field, select input method, then Swype

    10)When you use Swype it will constantly Force Close

    11)Go back into system/app and press install on the swype apk file that you placed there

    12)Then delete the same apk from system/app and reboot.

    That's it, Swype should work after that without any FC issues. To minimize the keyboard swype from the Swype key to the backspace key.

    Froyoyo, jarome, gtFlue and 14 others like this.

    1. Download the Forums for Android™ app!


  2. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    So has anyone used this yet?
  3. Little John

    Little John Lurker

    Tried to install SWYPE. Get to the screen to select the keyboard. I cannot find the data directory on my device. I don't want to root the machine. Any other suggestions?
  4. tstarky

    tstarky Newbie

    Do you have to be rooted to do this?
  5. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    You do need to be rooted, I'll make a note in the OP.
  6. leemurta

    leemurta Lurker

    Yes got it working followed your instructions fine thank you very much.:D
  7. Bohn101

    Bohn101 Newbie

    2 of you got this to work which is awesome. What devices did you use to get this to work? I've got an Epic 4G Touch, and continually get this 'the application Swype(process com.swype.android.inputmethod) has stopped unexpectedly'

    Can you guys post the swype install file that you have or let us know what devices you were using to get your Kindle Fire swype keyboard to work?

  8. brh01

    brh01 Lurker

    Swype beta installed and working fine on KF running CM7 (no dragon dictation). no issues. no additional steps. :)
  9. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    That will happen until you get everything done, you can also try downloading it from the beta email. Any version should work once you go through all of the steps.
  10. gdude

    gdude Lurker

    Thanks, your instructions worked like a charm! I never used Swype before, but I like it already. :)

    By lack of another Android device, I simply did everything straight on my (rooted) Kindle Fire. Meaning:

    I obtained the apk file by registering on beta.swype.com, opening the registration email in the GMail app on my Kindle Fire, clicked the link in the email to open it in Opera, downloaded the apk file, chose "Open" when downloading was done.

    (I guess the GMail app and Opera don't matter, just saying what worked for me.)

    The file I moved was called /data/apps/com.swype.android.inputmethod-1.apk.

    markbc likes this.
  11. psellnow

    psellnow Lurker

    I got it to work, but what a pain in the arse. How can Amazon think that letting customers install Swype will create less problems than forcing us to root the device?!? (This is the ONLY reason I would have bothered to root the device... although now that I've done it I supposed I may find more...)

    Anyway, thanks for the instructions!!!
  12. psellnow

    psellnow Lurker

    I only meant that figuring out how to root the device was a pain in the arse -- these instructions were brilliant, just to be clear.
  13. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    It's good to know that you found them easy to follow.
  14. originalgadz

    originalgadz Lurker

    Great instructions, but I got one small problem. My Fire is rooted, but when I go to the beta.swype registration page, there is no check box on the "I agree to the Terms and Conditions" statement so I can't register and get the email. Tried in Amazon Browser and in Claystone Browser. I remember seeing this before a long time ago. Is there something I need to change to be able to check the box?

    Loved the video of your Fire. I have the Go Launcher already also.

    Another thing I wanted to ask you, how do you keep your wallpaper when you restart your Fire. My wallpaper always gets replaced by the starting splash screen and I don't know how to turn off.


  15. Chris407

    Chris407 Lurker

    Hi, great post and very easy to follow. The problem im running into is when i try to move the apk file to the system/app folder it is saying i cannot paste here because the file system is read only. please help
  16. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    Just sign up through your computer, I've run into similar problems with check boxes on different sites with different browsers.

    To get the qallpaper to stick go into data/data/com.android.settings**/files and long press on wallpaper and select permissions. They should currently be: Owner XXX Group XOX Other XOX. To make the wallpaper stick change them to: Owner XOX Group XOX Other OOO. Then just back out, the only thing is when you want to change wallpapers you need to go back in and change it to the original permissions, then just change them back once your done.
  17. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    If you're using Root Explorer you need to press the little grey button on the top, center of the screen that says Mount R/W, you'll then see that the small text to the left of it says r/w.
  18. originalgadz

    originalgadz Lurker

    Done and done. Swype and Wallpapers fixed. Then got OTA Rootkeeper installed and working so I have video back. A late but productive night last night. Thanks for all the help!!
  19. alprazolam

    alprazolam Android Expert

    I'm working on installing this keyboard now but I wanted to note that I tried to d/l the installer using Silk Browser and I got a message that said, "Sorry! This is not an Android Phone..." I'll just install from an existing .apk installer file I have, but you guys above must be more advanced than me to get no errors. I'm on stock ROM BTW.
  20. originalgadz

    originalgadz Lurker

    I had the same issue. If you read the Swype FAQ it tells you to change your browser from desktop to mobile in preferences. I did this and it worked fine.

    Airmaxx23 and alprazolam like this.
  21. alprazolam

    alprazolam Android Expert

    That fixed it. Thanks a bunch!
  22. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    I'll add this bit of info to the OP, thanks for pointing it out.
  23. raaron1990

    raaron1990 Lurker

    My swype apk is in my downloads folder and I can't move it. It says the file cannot be moved. What do I do?!
  24. Airmaxx23

    Airmaxx23 Android Expert
    Thread Starter

    You need to install it from there first and then go into data/apps and move that file.
  25. raaron1990

    raaron1990 Lurker

    I tried to install it using the installer. It sends me to a screen with two buttons. "Enable Swype" and "Select Swype". The "Select Swype" button is unavailable. The on-screen directions say :Licensing complete, almost done! Now enable Swype - Press "Enable Swype" and 1) check the box next to Swype then, 2) hit the BACK button to return and "Select Swype".

    Also, when I try to install directly from the apk file, it says that installation not complete.

    I tried doing what it says, but no matter what I do, I can't get the "Select Swype" button to be available.

    Can someone just email me the Swype apk file? It'd be greatly appreciated.

Share This Page