1. Are you ready for the Galaxy S20? Here is everything we know so far!

[1st Gen] Restore Kindle Fire To Out Of Box State

Discussion in 'Android Devices' started by nuttmeg, Dec 30, 2011.

  1. nuttmeg

    nuttmeg Extreme Android User
    Thread Starter

    if you wish to restore to stock from CM7 or just go back to stock with no root or FireFireFire at all, TWRP works for it. quick tutorial:

    1. download amazon's stock software: http://www.amazon.com/gp/help/custom...deId=200790620

    2. rename it to update.zip and place on root of sdcard

    3. boot into TWRP and wipe cache, dalvik cache and factory reset

    4. flash update.zip, however it will stop the install mid-way and say it can not find the misc volume or something, but fear not

    5. boot up and you'll be restored to stock! note FireFireFire and TWRP will have to be re-installed as well as re-root

    I had issues at first boot like WiFi not working, but a factory reset changed that.

    SashaBee and mike28 like this.

    1. Download the Forums for Android™ app!


  2. KX4SAM

    KX4SAM Member

    at the risk of sounding ignorant, WHAT SD card? I though the Fire did not have a slot for SD cards.
  3. b0bness

    b0bness Newbie

    someone correct me if im wrong, but the kindle is partitioned into two sections one for apps (internal storage) and one for music,movies, books etc. (external storage) so the sdcard portion is referring to the external storage section of the kindles memory. they both are internal, just separated so that android can recognize an "SD card"
    nuttmeg and KX4SAM like this.
  4. Zachintosh

    Zachintosh Lurker

    OMGOMGOMG!!! Thank you so much! Just a word of advice to people: you can just put your update.zip folder in the "kindleupdates" directory of your kFire.
  5. nuttmeg

    nuttmeg Extreme Android User
    Thread Starter


    what he said.

    i have done so many things to both of my kindle fires even brick it, and manage to restore the kindle fire to out of box state. I even have TWRP recovery so i can flash stock,cm7, and ics within a couple of minutes, and if you are on version 6.2.1 download Kindle Fire Utility 7 and install google apps and also you can install root with temp or perm to the kindle fire using the utility.

    Here is a video of how the recovery looks and how easy it is to install ics, How to install Android 4.0 on the Kindle Fire - Liliputing
  6. KX4SAM

    KX4SAM Member

    My kindle shows 1g for user apps, and 5 for kindle stuff, Can I rearrange the storage in TWRP?
  7. vegoddard

    vegoddard Lurker

    I am a true dummy when it comes to any kind of technology so please forgive a stupid question. I was given a 2nd Generation Kindle Fire that is rooted with MIUI Android OS. I want to go back to Kindle Fire as it was out of the box. In the instructions you say FireFireFire and TWRP, what are these? Hope I'm able to do this, otherwise I think I have a yard sale item. I don't know how to work this Android OS.
  8. themadhatter1

    themadhatter1 Lurker

    I am having trouble returning my 1st gen KF to original state.
    I downloaded, renamed and copied the KF rom file; booted into TWRP; wiped the Cache, the Dalvik Cache, and performed the TWRP factory reset; while still in TWRP I hit the back button, hit install, selected update.zip, and tried to install. The error I am getting says

    assert failed: getprop("ro.product.device") == "blaze" ||
    E:unknown command [err_string]
    getprop("ro.build.product") ++ "blaze" ||
    E:unknown command [err_string]
    E:Error in /sdcard/kindleupdates/update.zip (Status 7)
    Error flashing zip '/sdcard/kindleupdates/update.zip'

    I found out that if you downgrade TWRP to version, the OS flashes properly.
    Did Amazon change the rom to not allow this?
    Should I have rebooted back into TWRP before trying the update?

    Any help would be appreciated.
  9. deals345

    deals345 Lurker

    Hi themadhatter1,

    I am also stuck with same error as you were. How did you downgrade TWRP to



    Please be gentle, this is my first detailed post. Since i went through alot, i wanted to post my experience so that others can benefit.

    My Kindle fire was stuck on the Kindle Fire (Blue) screen with Booting... at the bottom. I could not get into TWRP. I had to Boot in normal mode to be able to fix my problem. Other thing which was bothering me was that my KF kept shutting down after every 10 secs once it boot normally on to KF home screen. Tried charging it for 4-5 hours and using fastboot i was able to make KF stable enough to start working on the TWRP downgrade.

    I used below fastboot command:
    fastboot oem idme bootmode 4000

    I was able to download TWRP from (http://goo.im/devs/OpenRecovery/blaze/openrecovery-twrp-

    The latest version of TWRP 2.5.0 doesn't let you update to Kindle factory ROM v6.3.2 and gives below error:

    assert failed: getprop("ro.product.device") == "blaze" ||
    E:unknown command [err_string]
    getprop("ro.build.product") ++ "blaze" ||
    E:unknown command [err_string]
    E:Error in /sdcard/kindleupdates/update.zip (Status 7)
    Error flashing zip '/sdcard/kindleupdates/update.zip'

    Below Steps helped me in Restoring my KF to factory ROM:
    1. Download KFU 0.9.9
    2. Download TWRP from above link or just search on Google (Make sure the size of the file is around 4.6MB).
    3. Extract the contents of KFU zip file to a folder.
    4. There will be a recovery folder with 'twrp.img' file (twrp v2.5.0). Take a backup of this file somewhere and delete it.
    5. Now the twrp img file that you have downloaded, rename it to "twrp.img" and put it in the recovery folder.
    6. Connect your KF to your PC with USB cable.
    7. In the KFU, double click on run.bat (a new window will open up)
    8. Make sure the ADB status is 'Online' and Boot status is either 4000 or 5001
    9. Now press option 3 in KFU to install the latest TWRP but actually you are just installing twrp version
    10. Once you get success message. disconnect and reboot your KF.
    11. you should be able to get into TWRP now.

    After that you can follow the steps in this video to continue your restore

    Hope this helps.
    samanthasue likes this.
  10. Lafi

    Lafi Lurker

    Thanks for your post
    Boot Status is always uknown, how can I change it to 4000 or 5001
    The problem I can not access my kindle fire, when I start it only shows logo "Kindle Fire"
  11. nuttmeg

    nuttmeg Extreme Android User
    Thread Starter

    Download the Kindle Fire Utility and set the boot mode to 4000.
  12. samanthasue

    samanthasue Lurker

    I just wanted to let you know that this SAVED me. I was so pissed when I realized the reason why the amazon rom wasn't working had to do with the newer version of twrp. I could not figure out how to get it back to the working version until I finally dug up your post. THANK YOU!!

Share This Page