1. Download our Official Android App: Forums for Android!

Root [1st Gen] [Root] BurritoRoot - Unleash your fire - Works on 6.2.1!

Discussion in 'Android Devices' started by jcase, Dec 25, 2011.

  1. jcase

    jcase Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    361
    Joined:
    Mar 24, 2010

    Mar 24, 2010
    361
    261
    88
    *Notice*
    BurritoRoot may not work on the 6.0 firmware, please update to a newer firmware if it doesn't work for you.

    BurritoRoot is an application that allows the android debug bridge (adb) to be ran as root simply by running the command 'adb root'.

    As of today, it is the only software based way of gaining root on the Kindle Fire. It also happens to be 100% working and reliable. Unlike other solutions it does not require modified hardware/cable, or exploiting a vulnerability that can cause instability (and doesn't work on current firmware).

    I will keep this updated with a current link to BurritoRoot as I update it, and BurritoMOD when I finish it.

    Burrito Root: http://www.androidpolice.com/2011/1...on-kindle-regardless-of-its-software-version/

    Currently supporting all known firmware but 6.0.

    After running BurritoRoot, and clicking 'Root', adb can be forced to run as root by running the command 'adb root'. It is that easy.

    The unroot option only disables the 'adb root' command. It DOES NOT reverse changes you have made to your system.


    I am actively seeking to bring other variations of BurritoRoot to more tablets and phones. My track records is fairly good, but lack of hardware is keeping me down. If my solution has helped you, and you wish to help me spread the Burrito, consider buying one of my apps. If non intrest you, consider buying the donation app that does nothing (will serve as a license key for BurritoMOD when it is released). https://market.android.com/developer?pub=Cunning+Logic


    This ad below is annoying, really does it have to be IN the post?
     

    Advertisement

  2. b0bness

    b0bness Member
    Rank:
    None
    Points:
    36
    Posts:
    33
    Joined:
    May 30, 2011

    May 30, 2011
    33
    7
    36
    the link for burrito root isn't working
     
  3. jcase

    jcase Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    361
    Joined:
    Mar 24, 2010

    Mar 24, 2010
    361
    261
    88
    fixed
     
  4. ovrrdrive

    ovrrdrive Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,215
    Joined:
    Dec 18, 2009

    Dec 18, 2009
    1,215
    389
    163
    Used this again yesterday to get root again after the 6.2.1 update. Worked like a charm both times.

    I went ahead and installed twrp this time. Hopefully it sticks.
     
    BDDKKRJ likes this.
  5. Airmaxx23

    Airmaxx23 Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,142
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    3,142
    1,039
    313
    I installed TWRP today and it has survived a few reboots.
     
  6. b0bness

    b0bness Member
    Rank:
    None
    Points:
    36
    Posts:
    33
    Joined:
    May 30, 2011

    May 30, 2011
    33
    7
    36
    got my kindle last night and used this to root the same hour i bought it, works great. have TWRP and have been switching between cm7 and ics pre-alpha with no problems. great work! :D
     
  7. Xtizzy

    Xtizzy Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Apr 8, 2011

    Apr 8, 2011
    6
    1
    6
    Student
    Midwest
    Not sure where I went wrong here but when I eject the kindle and locate the rootzwiki apk file in my file manager to install I get an error message saying that the file type is not supported instead of loading and continuing on to the disclaimer. Any help would be much appreciated : ) Thanks
     
  8. ovrrdrive

    ovrrdrive Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,215
    Joined:
    Dec 18, 2009

    Dec 18, 2009
    1,215
    389
    163
    What file manager are you using?

    Did you try rebooting the kindle?
     
  9. Chairshot215

    Chairshot215 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    767
    Joined:
    Aug 20, 2011

    Aug 20, 2011
    767
    669
    163
    Male
    Test hardware, software fo company named Field Dia
    Illadelvall Pennsy
    Quick question, Rooted last night without any issue, this morning I see a market update available for Superuser, should I update or continue with the version I pushed via ADB?
     
  10. b0bness

    b0bness Member
    Rank:
    None
    Points:
    36
    Posts:
    33
    Joined:
    May 30, 2011

    May 30, 2011
    33
    7
    36
    The market update wont unroot you or mess anything up. A system update, however, is something you should stay away from. I would actually recommend staying up to date on superuser. They update pretty often so that might explain why the superuser with burrito root is already outdated
     
  11. ovrrdrive

    ovrrdrive Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,215
    Joined:
    Dec 18, 2009

    Dec 18, 2009
    1,215
    389
    163
    Unless you're having a problem with su there really isn't much need to update it. All it does is give root permissions to programs. It either works or it doesn't...

    I've updated it before but it was only to get it out of the update list. Do whatever suits you.
     
  12. KX4SAM

    KX4SAM Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    75
    Joined:
    May 18, 2010

    May 18, 2010
    75
    1
    16
    Electronic Repair
    Summerville, SC
    Worked like a champ, after I got ADB working!
     
  13. ndoren

    ndoren Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    168
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    168
    46
    43
    Albuquerque, NM, USA
    It is safe to do this update. There are a list of improvements in the latest SuperUser app, but they may or may not be noticeable on the KF. If you don't want to see SuperUser (or any app) in the update list within the "my apps" section of the market, use Titanium Backup (or similar) to break the market link.
     
  14. ndoren

    ndoren Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    168
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    168
    46
    43
    Albuquerque, NM, USA
    By the way I used BurritoRoot2 (older version) and it rooted 6.2.2 with no problem.
     
  15. originalgadz

    originalgadz Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    7
    2
    6
    So I just noticed I got updated to 6.2.2 and lost my root. Even though OTA says it has a saved su and says it restores when I hit restore, it does not give me root. Have re-booted. Do I need to go through the steps of rooting again from my PC? Also noticed that OTA has a new button to protect su. Must have been part of an update that I didn't see until now and am too late. So I assume next time need to protect su so as not to worry about updates to the OS? Thanks for the advice! -OG
     
  16. ndoren

    ndoren Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    168
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    168
    46
    43
    Albuquerque, NM, USA
    I hadn't rooted before 6.2.2, so I don't know how effective any version of OTA Rootkeeper would have been. It's effectiveness relies on the OTA update not overwriting the partition where it stashes a copy of root, and that's unknown for future updates. So, OTA Rootkeeper provides no guarantee at all. I think the best use of OTA Rootkeeper is to provide a "one click" solution to unrooting and rerooting an already rooted Kindle, so that you can unroot quickly to use the Amazon streaming video feature. Click again and root back. Again, no guarantees it'll work after an OTA update.

    As far as rooting from your PC, the biggest challenge I had was getting my darned PC and my version of the Android SDK to see the attached Kindle via ADB. Having done that, rooting was trivial (even 6.2.2). So, assuming you still have your PC set up for the task of using ADB, re-rooting is almost as easy as running the rootkeeper app. The big fear is that future OTA updates will patch the exploits that the current rooting tools use to gain su. Neall
     
  17. originalgadz

    originalgadz Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    7
    2
    6
    So finally getting around to trying to re-root my kindle after the 6.2.2 update. Everything is in place. Have burrito, have superuser, have root explorer. can see my device on ADB. But when I type the line "adb root" I am getting back "adbd cannot run as root in production builds"

    Any suggestions??

    Thanks as always!!!
     
  18. originalgadz

    originalgadz Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    7
    2
    6
  19. chiph411

    chiph411 Member
    Rank:
     #1,283
    Points:
    23
    Posts:
    67
    Joined:
    Dec 10, 2011

    Dec 10, 2011
    67
    38
    23
    Daytime bartender
    Ocean City, MD
    I was able to use this method today to successfully root my Fire. Then I used the Kindle Fire Utility to install recovery, go launcher and google apps. It worked like a charm.:)
     

Share This Page

Loading...