1. Are you ready for the Galaxy S20? Here is everything we know so far!

[1st Gen] [ROOT][ONE-CLICK] How-To Get ADB running AND Root with SuperOneClick

Discussion in 'Android Devices' started by death2all110, Nov 16, 2011.

  1. death2all110

    death2all110 Android Expert
    Thread Starter

    So I was messing around with different one clicks since I got ADB going on my kindle fire and I was able to Successfully use SuperOneClick 2.2 to root my kindle fire!

    Sorry for the mess. Its late, and I wanted to type this up so I could crash...

    To get adb going you must already have the sdk on your machine and used it.

    goto: %USERPROFILE%\.android and edit the adb_usb.ini and add this to the end of the file and save:
    Code (Text):
    1. 0x1949
    then go into where you have the sdk at and open the google-usb_driver folder and edit android_winusb.inf and add this to the [Google.NTx86] section and [Google.NTamd64] section:
    Code (Text):
    2. ;Kindle Fire
    3. %SingleAdbInterface% = USB_Install, USB\VID_1949&PID_0006
    4. %CompositeAdbInterface% = USB_Install, USB\VID_1949&PID_0006&MI_01
    save and close

    If you have already plugged your kindle into the usb you may have to open device manager and find "Kindle" under other devices and choose the android_winusb.inf file.

    Turn on Installation of apps from unknown sources: tap the top bar>choose more...(+)>device

    open a command prompt and run adb kill-server then try adb devices..

    you should see a device listed.

    go here: [APP]SuperOneClick v2.2 (now with zergRush and su 3.0) - xda-developers

    download and run SuperOneClick and choose the "root" option. let it go!



    b0bness, davekaye, Craigb1 and 9 others like this.

    1. Download the Forums for Android™ app!


  2. Matt H

    Matt H Newbie

    Awesome work!
  3. Fantastic! Right away, what does this give us?
  4. Ekimalito

    Ekimalito Lurker

    I would love some of the people working on this project to make the apk for the kindle e-reader app available so we can use it on other Android Devices.

    As you may know, the Kindle app on the Android Market lacks functionality. You cant change the line spacing or the font type. However, the version of the Kindle App on the Fire is different. It has all the options that regular kindles do... and i want that to improve my reading experience on my Android HP Touchpad
  5. vobguy

    vobguy Well-Known Member

    Awesome and quick work!

    Sorry for the newb question here - anyone know if you can get VPNC Widget installed and working on the Fire once you have root?

    I really need a pure IPSec/cisco VPN client since our wireless network at work requires you authenticate via VPN to connect to anything useful.

    Just taking a shot in the dark.
  6. parkerskouson

    parkerskouson Android Enthusiast

    Do you have to have adb working to root it? Or can I do it without?
  7. dots

    dots Android Expert

    Pretty sure you need adb working per guide to use superoneclick. Since the exploits that superoneclick uses require adb access.
  8. himurak

    himurak Newbie

    If you're not comfortable. Give it a week and they'll be one click custom methods all over the place.
  9. ylexot

    ylexot Android Expert

    I was wondering if anybody has tried sideloading z4root and seeing if it works. Since this already-existing multi-device root method works, maybe another would as well...
  10. That's a lot of clicks for one click. :)
  11. vobguy

    vobguy Well-Known Member

    Especially if you dont have the SDK yet.. having a hard time figuring out what I need and where to find the google-usb_driver folder, so far not a whole lot of luck.
    That is what I get for being a newb trying to catch up.

    Ahh nevermind, found it. Down under all the Android versions in the SDK is Extras, the "Google USB Driver Package" is under that. Install that and you find the inf file.

    Still more clicks than I expected when the headline on many sites today is "one click", but then again what was it Mark Twain said about believing what you read?.

    This still seems pretty straightforward despite my newbness.
  12. thewebblogger

    thewebblogger Lurker

    Can't post links yet, but there is a tutorial (based on the instructions in here) that details a bit better the "prerequisites" for the one click root.
  13. ylexot

    ylexot Android Expert

  14. Practicality

    Practicality Lurker

    Oh no! A self-referencing loop! If you keep clicking the link in the article and this one in the forum you will continue looping until eventually the universe implodes.
  15. Or else we finally find a way to distract all the blondes while we eat their chocolate.
    death2all110 likes this.
  16. jem417

    jem417 Newbie

    Just a bit of info for any one thinking of rooting the Kindle fire. If you plan on streaming videos with Amazon Prime don't root it just yet.
    I rooted mine and I wasn't able to stream I called Amazon Support thinking it was a problem with my account and they said the error message I was getting was do to rooting, of course I played dumb. I unrooted the device and video streaming is working again.

    The error message was something like...."Your device is no longer configure correctly for video playback" or something along those lines.

    Just a bit of info :)
  17. ylexot

    ylexot Android Expert

    Yeah, it's been mentioned in the tech blogs and there's already a work-around:
    Rooting Kindle Fire Breaks Amazon Video (And How To Make It Work)
    Encerspay and Craigb1 like this.
  18. imalive

    imalive Lurker


    I encountered some problem while run adb commands, therefore ROOT end up failure.

    the command output seems wrong, the status is "offline"
    does anybody know the reason?

    C:\Program Files\Android\android-sdk\platform-tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    **********00000001 offline

  19. wgregori

    wgregori Lurker

    I've followed this instructions a couple of times... on three different computer... two xp and one windows 7 but adb finds no devices...

    any ideas?

    C:\android\platform-tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached

  20. RawRmon

    RawRmon Newbie

    What worked for me was that I manually input the 0x1949 code, if you copy and paste it to the notepad document it registers it as something else. I had the same problem.
    wgregori likes this.
  21. iceman99393

    iceman99393 Newbie

    IF i have adb setup for other android devices, do i need to change some of the things that were stated in the op in order for superoneclick to work

  22. babaduchi1

    babaduchi1 Lurker

    I am having the same issue. Tried the rooting process on two different computers with the same result :(
  23. Xeddicus

    Xeddicus Newbie

    If it's not what RawRmon said about the 0X1949 text being pasted in wrong then: Did you guys plug your Fires into the PC before you had ADB installed and updated? May need to point the Fire at the new driver if so. Open the Fire in device manger, update driver, manually select the folder with the inf file you updated.

    Oh and iceman99393: As I understand it: Yes, you still need to edit the files so adb recognizes the Fire. That's the whole point of that. Without doing that it has no clue what the hunk of circuits is on the end of the micro-usb cable.
  24. iceman99393

    iceman99393 Newbie

    maybe its just me but im not fully understanding what i need to do clearly to adb in order to root the kindle fire. Could anyone give a little more detailed and clear explanation? thank you

Share This Page