1. Check out our app, Forums for Android! Download and leave feedback here!

Support 2.2 update failed... stuck help!

Discussion in 'Android Devices' started by jimlad, Aug 1, 2010.

  1. jimlad

    jimlad Well-Known Member
    Thread Starter
    36

    Jun 14, 2010
    132
    6
    36
    OK update failed, i have tried posting in other threads but the pace is to quick with other stuff.

    i had a flashed stock phone, as took my branding off, i have since been told that you need to keep the gold card in when doing updates.

    i have also tried resetting but no joy. im told i need to re flash the orginal 2.1 stock and then re do the update with the gcard in. only trouble is my phone keeps resetting on its own and i can't seem to enable hd mode on the sd card which i need :(
     

    Advertisement

  2. rydeboyz

    rydeboyz New Member
    5

    Aug 1, 2010
    4
    0
    5
    Exactly the same problem for me.. I have a Desire on Orange (UK) and debranded it and then had to get an unlock code.

    Installed the 2.2 update today (after having to free up some space) and things just went wrong. I can get to the 'slide to unlock' screen and says I have no service but when I unlock it it goes a white screen with the green htc logo and has a rising % box.. Then it just goes into a loop. I can't do anything!
     
  3. UKseagull

    UKseagull Well-Known Member
    43

    May 30, 2010
    326
    27
    43
    York UK
    I have an unbranded phone and after the update had downloaded and the phone had rebooted, I also got the white HTC screen with a rotary icon and a percentage count. I just left it to do it thing and eventually it completed. Hope you guys get your phones working.
     
  4. rydeboyz

    rydeboyz New Member
    5

    Aug 1, 2010
    4
    0
    5
    No it's screwed..

    Can't get signal and won't recognise my micro sd card.. Touch screen keeps crashing and reboots itself randomly. Not sure what to do now.
     
  5. pyr03k

    pyr03k Member
    15

    Aug 1, 2010
    14
    0
    15
    Brighton
    I had same problem as tried to update without goldcard in...... just kept loading progress screen and then rebooting.

    so to fix I....

    plugged it into computer and ran the offical generic 2.1 RUU (the exe file that does the flashing for you) this set me back to stock HTC 2.1

    when it booted up I then did the OTA update to 2.2 with the goldcard in and it al went fine.
     
  6. rydeboyz

    rydeboyz New Member
    5

    Aug 1, 2010
    4
    0
    5
    I can't do that if it doesn't read sd cards anymore though can I?
     
  7. theretroandroid

    theretroandroid Well-Known Member
    16

    Jul 9, 2010
    67
    4
    16
    India
    @rydeboyz
    I have the same problem :(
    Unfortunately i dont have time to fix it now, since i have to get to work!

    I'm guessing we flash the 2.1 stock and run the update again! I got the same loop over and over again, I should've let it run but i thought it got ****ed and i rebooted the phone!
    Then the problems mentioned above started! Another 9 hours for me to try again!

    *Kill ME*
     
  8. Zetetic

    Zetetic Member
    16

    May 9, 2010
    17
    1
    16
    Keep rebooting and leaving it to run. I had this problem and couldn't get anywhere. Eventually it settled enough for me to get into settings and turn on debugging usb, connect to HTC sync and reinstall the 2.1 Rom. Haven't tried updating with the gold card in yet. Will do when I get back in and see how I go.
     
  9. sunilnc

    sunilnc Member
    5

    Apr 24, 2010
    6
    0
    5
    OK this is what you have to do, start up the HTC sync software, plug the usb cable into your phone and it will connect (you will be able to tell because the gray sync icon in your taskbar will turn green).

    now WITH the gold card inserted, load the generic rom which will downgrade it, then once that is done, do the OTA 2.2 update. All the while with your goldcard in the phone, only once has the phone finished updating take out the goldcard.
     
  10. pyr03k

    pyr03k Member
    15

    Aug 1, 2010
    14
    0
    15
    Brighton
    mine was same when I plugged my USB in it was not reading nor showing up in notification bar but when I ran the stock 2.1 RUU it still picked the phone up ok and flashed it
     
  11. rydeboyz

    rydeboyz New Member
    5

    Aug 1, 2010
    4
    0
    5
    Can you point me towards the 2.1 rom please..?

    I found one but I got a "customer id" error.. jesus..
     
  12. jimlad

    jimlad Well-Known Member
    Thread Starter
    36

    Jun 14, 2010
    132
    6
    36
    thats sorted it for me
     
  13. saup

    saup New Member
    5

    Aug 1, 2010
    3
    0
    5
    same problem here. my phone is o2 branded.i yesterday debranded it and today installed the 2.2 update and my phone just reboots,no wifi, no sd card detection and no network signal.the problem is i am not able to make a gold card now. i have my gold card image with me as i had made one yesterday but after that i had formatted the card but now i am not able to make one as i am not able to format my sd card through the phone. i tried formatting the card from windows and followed the process of making the gold card but it seems you need to format the card through the fone only. plz help....
     
  14. Si Pie

    Si Pie Well-Known Member
    38

    Apr 24, 2010
    189
    23
    38
    Turn off phone.
    Hold the volume down button and power at the same time and it will take you to the boot menu.
    Use the down vol key to move down to the 'clear storage' setting. Use the power button to select that.

    That should hopefully work.
     
  15. saup

    saup New Member
    5

    Aug 1, 2010
    3
    0
    5
    tried but it just clears the phone storage and not the sd card...:thinking:
     
  16. theretroandroid

    theretroandroid Well-Known Member
    16

    Jul 9, 2010
    67
    4
    16
    India
    Has someone found a work around for this? Im so totally frustrated! I have a goldcard.img file on my computer. Would it work if i formatted the sd card and pasted that file on the card and then run a 2.1 stock rom?
     
  17. theretroandroid

    theretroandroid Well-Known Member
    16

    Jul 9, 2010
    67
    4
    16
    India
    Okay im trying this! Lets see if it works :S
     
  18. theretroandroid

    theretroandroid Well-Known Member
    16

    Jul 9, 2010
    67
    4
    16
    India
    Okay it doesnt work if we just paste a goldcard img on the card, we DO have to format it using the phone! Now i think we're screwed unless we get a working goldcard.
     
  19. theretroandroid

    theretroandroid Well-Known Member
    16

    Jul 9, 2010
    67
    4
    16
    India
    Okay, you actually dont need the phone to format your card, you can format it normally through windows. THANK GOD I had a goldcard.img saved, followed the process and flashed it to 2.1 custom rom! Phone's now working!

    All i have to do it let the OTA run completely now!

    THANK heavens!


    F this shit! Second time, same problem! I aint installing the OTA till the official final update comes up :X . Sticking to 2.1 for sometime! Installing generic again!
     
  20. saup

    saup New Member
    5

    Aug 1, 2010
    3
    0
    5
    My problem sorted.U just need a gold card and you dont need to format it in the phone.Just make sure it is fat32 formatted. I was not able to make a gold card because i was using n95 as a mass storage device to access my micro sd card as i wasnt having a micro sd adapter. As soon as i got the adapter it took 15 mins for the whole process as i was having my gold card image ready already. If you are stuck in the infinite loop and your phone booting up continuously after the update then just download the 2.2 ota update( search google), rename the file to update.zip and put it in the gold card and follow the standard steps of putting the phone into recovery etc and you are done.
     
  21. rbex1967

    rbex1967 New Member
    5

    Aug 25, 2010
    2
    0
    5
    +1 for me too.

    My only question is that does the goldcard have to be present for any future updates?
     
  22. DjLukeW

    DjLukeW Well-Known Member
    43

    Jul 9, 2010
    143
    25
    43
    Mobile Retail
    Chester
    did you root it aswell as debrading?

    Im positive you cant do an OTA update if you did .as it does cause errors. Why not just install a custom 2.2 rom instead. they are much better
     
  23. rbex1967

    rbex1967 New Member
    5

    Aug 25, 2010
    2
    0
    5
    I originally rooted with unrevoked and installed LeDroid v2.0a, this ROM was absolute shite (nothing more than a hammer and chisel Nexus ROM) IMHO, restored through nandoid and went down the goldcard route with the stock HTC
     
Tags:

Share This Page

Loading...