1. Are you ready for the Galaxy S20? Here is everything we know so far!

2.3 Voice search or text not working

Discussion in 'Android Devices' started by TheHerd84, Jun 3, 2011.

  1. TheHerd84

    TheHerd84 Newbie
    Thread Starter

    I updated to 2.3 this morning. I am not rooted or modded in any fashion. Just got the update and now my voice recognition (stock) software isn't working in handscent, stock messenger, or Google search bar. The Mic isn't moving at all like the thing isn't picking up any sound.

    Anyone else having the problem?

    anup raj kohli likes this.
  2. GeorgeGrump

    GeorgeGrump Lurker

    I have the exact same problem, that, and the Navigation won't stay open. It's pretty lame, as those two where the apps I easily used most. What gives?
  3. TheHerd84

    TheHerd84 Newbie
    Thread Starter

    I called Sprint went through some steps and they are sending me another EVO. I am not sure what the problem is, but that was sprints solution.

    KENNECTED Android Expert

    Both work just fine for me after the update.
  5. justryan

    justryan Newbie

    My wife and I are both experiencing the same issue with our Evos following the 2.3 update. It also deleted her alarms but not mine.
  6. justryan

    justryan Newbie

    I just launched the voice search app again and it asked if I wanted to turn on "personalized recognition" and I said yes. The speech to text now works. You can find that setting under voice input in settings.
  7. NeoteriX

    NeoteriX Android Expert

    I'd try rebooting or giving it another shot. Mine was definitely not working on Friday, but has been working since.
  8. justryan

    justryan Newbie

    I spoke too soon. It's not working anymore.
  9. TheHerd84

    TheHerd84 Newbie
    Thread Starter

    Mine has been working intermittently since Friday, but my new EVO is set to arrive on Monday from sprint. I'll let you know once I get the phone updated if it is having the same issue.
  10. justryan

    justryan Newbie

    I think I've figured out the cause. When I'm in an area with lots of ambient noise, it wont recognize my voice. This includes areas like my vehicle, the mall, theme parks. It only seems to work in very quiet areas like my home or office. There needs to be a software adjustment to it.
    KENNECTED likes this.
  11. Bane313

    Bane313 Lurker

    Same issue + VM icon issue, getting tired of clearing notification. I agree with justryan that when there's more noise the issue is worse. On my third EVO and this one was flawless untill 2.3 guess ill deal until my 3D arrives.
  12. stv1a

    stv1a Lurker

    I can absolutely verify that voice search does not work properly on my Evo (stock, unrooted) phone after OTA update to 2.3.

    Here is where it gets weird. Works fine at home, works fine in car GOING LESS THAN 25MPH! Once the car is moving more that about 25mph, the mic no longer registers voice input. I have tested it over and over and over - reset the phone, done battery pulls, everything. GPS is off, toggling on GPS does not make a difference.

    How does it know???? I have no idea, but try it for yourself - I would be interested to know if anyone has the same results. This is a real deal breaker for me as I use voice to text and voice command on the road a lot.

    Also, while I have not had any issue with the infamous voicemail icon getting stuck, I did notice that my wi-fi signal is not nearly as good. I have read it is because wireless N is no longer supported, but I have not been able to verify that. All I know is I do not get signal in my house in places where I used to, like my bedroom and bathroom.

    Last but not least, I have noticed some 3g drop out while moving - I will be surfing and all the sudden I have no data connection and the only way to get it back is to toggle mobile data and it comes right back. Probably happened 10x yesterday on a 2 hour drive in metro area.

    Right now, I am waiting for unrevoked 3.4 to come out so I can root this thing and go back to 2.2.
  13. drew231506

    drew231506 Lurker

    Yep stv is correct. I am having the same issue. I thought you were nuts about it not registering only while moving. But sure enough I stopped and it worked fine. This is TERRIBLE, I use the voice function all of the time while im driving, for directions etc...

    If anyone figures out the fix for this please post it up. I am not technically savy enough to know how to root the phone and revert back to 2.2. But I'll do some research because I really like the voice feature.

    I even tried having it fix itself. "Phone fix voice recognition." No luck. ;-)

    EDIT: I think it has to do more with the ambient noise. When I am stopped it will not pick up my voice with the a/c on. I have to turn it off, then it will hear my voice and work fine.
  14. Obviously background noise is a big problem after the 2.3 update. Here's a possible solution to the problem for now.

    Try going to the android market and download Google Voice and Google Voice Search. (an old version if possible)
    A similar problem happened with the Nexus one upon the 2.3 update and this was one of the solutions to fix the problem. It may be worth a try? I just downloaded and installed the google voice app and all seems to be well. We'll see how well it works when I'm in an environment with more background noise such as my car going down the road with the A/C on. So far I believe I can see an improvement, though but I have not yet fully battle tested it on the highway yet.

    Update: Sorry folks. That was a waste of time. I should have driven with it before even posting. I was optimistic since it appeared to work fine in my job with background noise but not so much in the car.
  15. justryan

    justryan Newbie

    I can't download or uninstall Voice Search as it's already "installed". I did uninstall and reinstall Google Voice. Not sure that this will make a difference as they are two entirely different apps.

    I spoke to Sprint technical support about this today and they made a note of it with the revisions support team. I recommend everyone call to help bring this issue higher in priority.
  16. planoevo

    planoevo Lurker

    Ambient noise is definitely the problem. I have downloaded Google voice and the problem still exists. Oddly enough Voice search was updated when 2.3 was installed. Hopefully someone can figure this out asap as I like 2.3 but not the bugs.
  17. stv1a

    stv1a Lurker

    UPDATE: I can also verify that voice command (search) works on the same phone if you use Vlingo.
  18. dirtyred

    dirtyred Lurker

    People go to your settings,apps. Find voice and clear data and it should fix
  19. Texas Cop

    Texas Cop Newbie

    I tried this fix but it didn't work. Oh well.

    KENNECTED Android Expert

    To me it seems/appears that the update made the microphone uber sensitive. So any background noise(s) interfere with whatever you're saying.

    I don't use my voice command unless I'm inside, I dont want people in my business, so this wasn't noticeable until I went outside to try it.
  21. Harristj

    Harristj Lurker

    I have the same exact issues after the update. Hopefully they find a fix soon.
  22. cheeze70

    cheeze70 Lurker

    I also have the same thing, its when driving especially, this is super annoying...don't they test this stuff before releasing it!!!!! What ever they did its worse now with 2.3 I may go back to 2.2 just cause this is so annoying!!! is there any updates coming that anyone has heard about yet to fix this issue, They should just go back to what was on 2.2 now even....it was better than this version!!
  23. justryan

    justryan Newbie

    I read on the Spint Community Forums last night that Sprint is aware of the issue, among others, and is working on a 2.3 update that will fix things. No word on a release date.
  24. davidstjohn1

    davidstjohn1 Lurker

    Thats exactly what i get, the microphone shuts off if ur moving. I can tell cuz when u look at the screen u can see there is no recognition in the microphone icon on the screen. No matter how quiet it is in the car and my car is very quiet. I can get it to work as soon as i stop! So im thinking its something google did to stop us from texting and driving, but what if were the passenger? I hate being restricted like that. How do we break this so we can get back to our normal voice search.
  25. neno1313

    neno1313 Lurker

    Same problem here.Haven't tried this while moving, but in my noisy workspace I can hold my finger over the mic. (small hole on bottom, left of center) and it works fine. Annoying but still a temporary fix.
    justryan likes this.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page