1. Download our Official Android App: Forums for Android!

Support 3g and wifi.

Discussion in 'Android Devices' started by tonyb81, Oct 15, 2010.

  1. tonyb81

    tonyb81 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    78
    Posts:
    507
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    507
    88
    78
    If anyone here uses wifi, does your 3g stay connected while wifi is on? I know when wifi is on, the phone will use it for data. I mean up in the notification bar does it show the wifi icon, and the 3g icon for anyone here? Also in settings when you go to about phone then to status, under "Mobile network state" does it still say "connected" when you have 3g on.



    The reason why I ask this is because since I've had my Fascinate, when wifi is on, "mobile network state" is disconnected, and I only have the wifi icon in the notification bar at the top. However as of 10 mins ago when I put wifi on, the 3g icon is still on up at the top, and under status "mobile network state" is staying connected.
     

    Advertisement

  2. Fynx

    Fynx Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    124
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    124
    5
    56
    Newport, RI
    My wifi and 3g work together. I typically put the wife on speaker phone or bluetooth, turn on the wifi, connect to the network, look up directions for her via google maps, and continue the call. I have not had a loss of 3g while I am on wifi also, because I typically am at home or starbucks, some place where I am static and not swithcing cell towers.

    If your wifi is off, during calls does your 3g go in and out?
     
  3. tonyb81

    tonyb81 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    78
    Posts:
    507
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    507
    88
    78

    Do this for me if you can, with your wifi on, go to settings, status, about phone, and tell me what "mobile network state" says.

    When my wifi is off, my 3g signal goes all over the place, i'll have 4 bars, drop to 1, then back up to 4, all over the place.
     
  4. Fynx

    Fynx Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    124
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    124
    5
    56
    Newport, RI
    <a href=http://s582.photobucket.com/albums/ss265/fynxsyndct/?action=view&current=snap20101015_074925.png target=_blank><img src=http://i582.photobucket.com/albums/ss265/fynxsyndct/snap20101015_074925.png border=0 alt=For your consideration></a>
     
  5. tonyb81

    tonyb81 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    78
    Posts:
    507
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    507
    88
    78
    The pics that show up don't have wifi on.
     
  6. Fynx

    Fynx Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    124
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    124
    5
    56
    Newport, RI
    its on, just not connected. no wifi where I am at now.
     
  7. honeymic

    honeymic Newbie
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Aug 29, 2010

    Aug 29, 2010
    14
    0
    15
    So are we saying that it is normal to NOT have 3G while using wifi. I'm connected to Wifi right now and mobile network state = "Disconnected"....
     
  8. tonyb81

    tonyb81 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    78
    Posts:
    507
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    507
    88
    78
    That is how it always has been for me, until today. Nothing has changed on my side so I'm gonna chalk it up to another wonderful glitch on my Fascinate.
     
  9. OfTheDamned

    OfTheDamned The Friendly Undead
    Rank:
    None
    Points:
    813
    Posts:
    9,692
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    9,692
    8,365
    813
    Right Behind You
    Typically, when you connect to Wifi your 3G connection goes into hibernation until you disconnect from Wifi. You are still able to make calls and send text while on Wifi because that doesn't use 3G. If your phone is trying to stay connected to Wifi and 3G at the same time then it is really just burning through your battery faster as it is trying to use two networks at once.

    Unfortunately the Fascinate does not offer the option to turn off the mobile network itself, which has always been a great way to save battery life.
     
  10. tonyb81

    tonyb81 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    78
    Posts:
    507
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    507
    88
    78
    Yeah I know thats how it is supposed to be, but i was freaking out today because it had the icons for both up at the top.
     
  11. b00t

    b00t Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    1
    0
    5

    Actually, correct me if I'm wrong, but can't you just turn on airplane mode to do this?

    My fascinate does seem to correctly switch between 3G and Wifi whenever I tell it to. It also can still use Wifi when I turn on airplane mode, which completely blocks all mobile network (including 3G) services.
     
  12. lasportsfan

    lasportsfan Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    88
    Joined:
    Oct 9, 2010

    Oct 9, 2010
    88
    1
    16
    When I have wi fi on I also see my 3g network go in and out like they are working together. Is this suppose to happen? Is there a benefit? I also assume this would burn through your battery quicker. Right now I have my phone in airplane mode with wi fi on like b00t suggested to see if it conserves more battery life.
     
  13. Foxcow

    Foxcow Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    206
    Joined:
    Mar 14, 2010

    Mar 14, 2010
    206
    31
    43

    That would not be the same thing. I upgraded from a Droid Eris and enjoyed the fact that you could turn of your mobile network without disabling the cellular radio. HTC's sense has a nice toggle switch for it. Airplane mode disables everything.
     

Share This Page

Loading...