1. Download our Official Android App: Forums for Android!

Support 3G Connection constantly working

Discussion in 'Android Devices' started by Dreed, Dec 6, 2010.

  1. Dreed

    Dreed Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    3
    0
    5
    Doncaster
    My X10 Xperia has in the last too days started using the 3G connection constantly, I noticed it when I got a txt from Vodafone saying my allowance was nearly gone ( I mostly use wireless connection) I downloaded a app showing internet usage and it was constantly going up even after using task killer to kill apps, I have got lookout mobile installed and did a virus/malware scan and it came up with nothing.
    Any ideas?
    Is there a way that I can see exactly what is using the connection?
    I have had to disable 3G in the settings for now.
     

    Advertisement

  2. x10iii

    x10iii Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    143
    Joined:
    Oct 25, 2010

    Oct 25, 2010
    143
    4
    36
    just use the APN on/off widget to easily enable/disable 3g with just one click..
     
  3. pyromatic18

    pyromatic18 Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    90
    Joined:
    Sep 5, 2010

    Sep 5, 2010
    90
    8
    16
    Australia
    It could be Timescape, do you have it set to sync often?
     
  4. nb_mitch

    nb_mitch Android Enthusiast
    Rank:
    None
    Points:
    88
    Posts:
    604
    Joined:
    May 28, 2010

    May 28, 2010
    604
    42
    88
    Male
    DB2 DBA
    Florida
    I would pull the battery if you can't find the issue. never hurts.

    I downloaded 2 apps yesterday which seemed to help me allot, Battery Booster and Memory Booster (yes, same developer).

    But then, I also haven't used any 3G for over a week, (Yes, I need to get out more :D
     
  5. Dreed

    Dreed Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    3
    0
    5
    Doncaster
    I have tried taking the battery out that hasnt helped, Im not using timescape and I do have a widget to disable it but it keeps switching itself back on.
     
  6. rosered

    rosered Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,129
    Joined:
    Jul 4, 2010

    Jul 4, 2010
    2,129
    317
    163
    UK
    Also are you running a task killer because that could be killing your Data Switch app thus letting the 3g reconnect.
     
  7. werthers

    werthers Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    262
    Joined:
    Apr 14, 2010

    Apr 14, 2010
    262
    15
    58
    Manchester UK
    If you go into settings > wireless & network > mobile network > then turn off data traffic without using a widget (that's for 2.1 think its slightly different for 1.6).
    I've had no end of trouble with 3G and the X10 but mine has been the other way round I had to reinstall to get it working again.
     
  8. Dreed

    Dreed Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    3
    0
    5
    Doncaster
    Thanks for all your posts, I have finally figured it out, I installed an app called Webkey which allows you to remotely log into your phone using the internet, turns out this app was constantly connected to the internet, I went in the settings and disabled this and the problem was solved.
    Thanks.
     

Share This Page

Loading...