1. Download our Official Android App: Forums for Android!

Support 3g doesn't connect when i turn wifi off...

Discussion in 'Android Devices' started by Lol mahmood, Jun 24, 2010.

  1. Lol mahmood

    Lol mahmood Well-Known Member
    Thread Starter
    16

    May 3, 2010
    85
    9
    16
    ...until i reboot phone! Anyone else have this problem?
     

    Advertisement

  2. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    Does it do this every time you use wifi or has it just done this once or twice.

    It might help if you post the firmware version you have and if your phone is rooted, also if you have downloaded any apps that specifically use wifi.
     
  3. Lol mahmood

    Lol mahmood Well-Known Member
    Thread Starter
    16

    May 3, 2010
    85
    9
    16
    From a similar thread on the Spica forum it looks like APNDroid may be the culprit!
    I've uninstalled it for now. Is there another way to stick a shortcut on the homescreen to turn 3G on and off?
     
  4. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    I'm not sure why you would want to but I'm sure you can just create a shortcut to the process that does it.
     
  5. Lol mahmood

    Lol mahmood Well-Known Member
    Thread Starter
    16

    May 3, 2010
    85
    9
    16
    Turning 3G off preserves battery life. The Desire does allow you to set up a shortcut for 3G, but i haven't yet found a similar option on my Portal.
     
  6. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    I was under the impression that 3g was not "always on" the symbol you see just lets you know that your in a compatable area and the phone switches to 3g when it needs it.
     
  7. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    However, if your desperate for this setting then on android 2.1 goto settings> wireless networks> mobile networks> and select "use 2g networks only"

    Im not sure if there is an option in android 1.5/1.6
     
  8. Beerkan

    Beerkan Android Enthusiast
    93

    Apr 14, 2010
    720
    166
    93
    Blighty
  9. Iqoniq

    Iqoniq Newbie
    16

    Jun 17, 2010
    25
    2
    16
    NHS
    Notts
    On my phone I have an app called Switchers which was installed by default (I'm on 2.1). This allows me to flick 3G, WiFi, GPS and the synching on and off. If you have that on your phone, just add a shortcut to your home screen. Hope this helps.
     
  10. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    Hate to point it out but switchers controls wifi, sync, gps and bluetooth not 3g.
     
  11. Lol mahmood

    Lol mahmood Well-Known Member
    Thread Starter
    16

    May 3, 2010
    85
    9
    16
    Yeah. The Desire has a shortcut for controlling 3G, but not my Portal.
     
  12. Iqoniq

    Iqoniq Newbie
    16

    Jun 17, 2010
    25
    2
    16
    NHS
    Notts
    Yeah, my bad. I realised when I was travelling that I'd goofed, but didn't get back until yesterday. Sorry :|
     
  13. Huawei Sean

    Huawei Sean Newbie
    16

    Apr 3, 2011
    29
    2
    16
    I noticed that my 3G box with arrows pointing up and down at the top of my screen is missing. that is why when im on 3G, i cant connect to internet. i have tried switching all the settings, getting a widget to toggle it on/off, and airplane mode. how can i get my mobile 3G internet back? it used to work fine.
     
  14. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    You can try going to you wireless settings and choosing you network oporator again, or more simply, take the back off your phone, eject your simcard, replace your simcard, and your phone will automatically reboot. upon reboot you should get your 3g back.
     
  15. Huawei Sean

    Huawei Sean Newbie
    16

    Apr 3, 2011
    29
    2
    16

    nm, i just had to restart my phone. its weird how it was doing that
     
  16. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    If thats the case, try the other option I mentioned, take your sim out, put it back in and reboot.
     
  17. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    Fyi you should be able to get to network oporator settings via either,

    Options button> settings> wireless & internet > mobile networks

    Or

    Options button > settings > call settings > mobile networks

    But as stated, replacing the sim is just easyer.
     
  18. cheryls1390

    cheryls1390 Lurker
    5

    May 18, 2011
    2
    0
    5
    I did that on Sunday and it worked for 24 hours, when the wifi was off I was on 3g, and then it popped off and I can't get back on it again, I have a new sim card and i turned off the wifi to see if i can get the 3g on again and it's not working, it's driving me bonkers
     

Share This Page

Loading...