1. Download our Official Android App: Forums for Android!

3G/HSDPA does not reconnect after Wi-Fi

Discussion in 'Android Devices' started by ijb, Apr 20, 2010.

  1. ijb

    ijb Newbie
    Thread Starter
    16

    Apr 8, 2010
    22
    2
    16
    London
    Hi

    Often, after I leave a Wi-Fi hotspot, the 3G/HSDPA fails to reconnect and I get the "Unable to connect to the internet, check your settings" message. I've tried toggling the data connection on/off, airplane mode on/off, GSM/WCDMA on/off, but the only thing that seems to work is turning the phone off and on again. "Enable always-on mobile data connection" is checked.

    There seem to be a few people over at the XDA forum experiencing similar problems, and I've sent a message to HTC support. Does anyone else here have this issue?
     

    Advertisement

  2. Anthony1

    Anthony1 Android Enthusiast
    43

    Jan 5, 2010
    399
    45
    43
    Luton UK
  3. jaspabt1

    jaspabt1 Member
    36

    Apr 13, 2010
    61
    2
    36
    work for BT
    UK
    is your mobile network option ticked within settings?
     
  4. Cleargrey

    Cleargrey Member
    16

    Mar 23, 2010
    48
    5
    16
    I think, think not know, that if the wifi is on then it will only attempt to do data through the wifi channels. If that fails, it will not adjust to available data connections.

    I.e. it's kindof a snob. If the best is not available, then it will choose nothing. You'd have to tell the phone that wifi is not available and turn the wifi off.
     
  5. ijb

    ijb Newbie
    Thread Starter
    16

    Apr 8, 2010
    22
    2
    16
    London
    @Anthony1: T-Mob UK; thanks for the links.

    @jaspabt1: "mobile network option"? Can you please be more specific.

    @Cleargrey: You make it sound more like a feature than a bug :) Manually switching wifi on/off doesn't initiate the 3G/HSDPA connection, and frankly, I shouldn't have to be switching anything. I hope the bug is squashed in an update soon!
     
  6. Anthony1

    Anthony1 Android Enthusiast
    43

    Jan 5, 2010
    399
    45
    43
    Luton UK
    That is incorrect. The phone will always use mobile data as a default. If WiFi is on and there's a valid and accessible WiFi network, then it will switch to WiFi, but if it loses WiFi at all then it will....or Should, switch straight back to mobile data.

    That's what it should do, and that's what mine does 95% of the time. However, what I am experiencing (if only very occassionally) and others by the sound of it, is that sometimes it simply won't reconnect to mobile data after being on Wifi, and in my case, after being in standby for some time.
     
  7. jaspabt1

    jaspabt1 Member
    36

    Apr 13, 2010
    61
    2
    36
    work for BT
    UK

    Go to settings>wireless&networks>mobile network. Ensure Mobile network should be ticked as this states "use phone for data connection when wi-fi is unavailable.
     
  8. Cleargrey

    Cleargrey Member
    16

    Mar 23, 2010
    48
    5
    16
    @ Anthony1 - I should probably be clearer that I'm saying that this issue seems to come when wifi is on AND the phone has connected to wifi network then lost it. It should go back to available wireless data, but doesn't.

    In a similar way, like my Desire, when it's doing voice and data at the same time, should it loose data connection for whatever reason (though it seems to be when it looses 3G) it will rarely regain that connection until the call is dropped. BTW, this is not including wifi.

    The Desire does not seem as good as it can be at shimmying around wireless connections. But you are right, it should. Just by coincidence, yesterday I was wifi browsing. I was far away from the wifi source which seemed to make my connection intermittent. But it didn't go back to 3G/HSDPA until I turned off the wifi.

    @ijb - Trust me. There are many things that almost seem like they meant it to be like that. Overall, I'm happy with the phone but it certainly has a need for updates!
     
  9. BadByte

    BadByte Newbie
    15

    Apr 29, 2010
    14
    0
    15
    Store manager
    Oslo, Norway
    Yes :mad:
     
  10. Scuffers

    Scuffers Newbie
    16

    May 3, 2010
    10
    1
    16
    me too :thinking:

    any progress on this? only way out is re-boot at the moment... not good.
     
  11. lekky

    lekky Lover
    313

    Not everyone tho, it moves back to 3G/HSDPA ok for me when i leave my house (and move out of range of my WiFi)
     
  12. dunbad

    dunbad Well-Known Member
    38

    Apr 22, 2010
    117
    11
    38
    Hi, this was driving.me crazy, dropping internet 4 or 5 times a day please read a potential solution by Cgrec on page 5. Also from another post I picked up to go into advanced WiFi settings and select to time out after 15 minutes if not used. It appears to have worked for me, please someone try and report back
    Thanks

    Data connection problem on my HTC Desire - Page 5 - xda-developers
     
  13. Scuffers

    Scuffers Newbie
    16

    May 3, 2010
    10
    1
    16
    this is really starting to tick me off now.....

    tried just about every combo of settings, but it's just not playing ball...

    Suggestions?
     
  14. nx1977

    nx1977 Android Expert
    163

    Feb 8, 2010
    2,421
    174
    163
    UK
    Are those having the issue keeping wifi on all the time, or turning off via the power bar widget?

    I've had an issue recently where the phone is changing itself to GSM only or WCDMA only after a poor signal area, and then the data wont reconnect.
     
  15. Scuffers

    Scuffers Newbie
    16

    May 3, 2010
    10
    1
    16
    tried disabling wifi when leaving, still won't pickup GPRS/3G/etc
     
  16. nx1977

    nx1977 Android Expert
    163

    Feb 8, 2010
    2,421
    174
    163
    UK
    Odd, as mine does.

    What routers are you guys connecting to? Perhaps its an issue with the router.
     
  17. jaspabt1

    jaspabt1 Member
    36

    Apr 13, 2010
    61
    2
    36
    work for BT
    UK
    Hi, i have had this problem but only a couple of times. I found switching to "Airplane" mode then back again resolved the issue which saves you having to do a full reboot. I have wifi always on and have several router etc remembered on my handset. It does it at random times so thankfully not all the time as this would annoy me
     
  18. asdf

    asdf Lurker
    5

    Dec 29, 2009
    4
    0
    5
    I am having the same problem. I want to try this solution but where is the advanced wifi setting?
     
  19. petehtc

    petehtc Newbie
    15

    May 7, 2010
    20
    0
    15
    Just to add I've also experienced this issue. I just switched the mobile network off and on again and it rejoined.
     
  20. dunbad

    dunbad Well-Known Member
    38

    Apr 22, 2010
    117
    11
    38
    Advanced WiFi settings can be found by going settings, wireless networks, WiFi settings, then hit the menu button. This will get you into advanced WiFi settings. Go connections and you will see that the default setting is to always leave WiFi on. Theirs an option for it to time out after 15 mins of inactivity, which if nothing else is a good battery saver should you forget to turn it off. When you press the wake button, WiFi comes back on provided you haven't manually turned it off. I've done A LOT of reading about this issue on many different forums. Somehow it doesn't seem to effect all handsets. Sometimes it takes a while to rear its ugly head so don't think your safe if it hasn't happened to you just yet. This issue use to drive me crazy, but the above method, together with the other link I posted has worked for me and others, although oddly not everyone. What I do occasionally get now is a kinda connection freeze that lasts about 30 seconds. I can see the data connection struggling with the arrows, and sometimes I get the time out. But after a refresh, it kinda forces its way back and then I'm good. But I haven't had the no data connection issue since I done this.
     
  21. dejayem

    dejayem Newbie
    15

    May 12, 2010
    10
    0
    15
    Reading, UK
    Hi,
    I tried the advanced wifi setting but on my T-Mobile Desire that was already the default. Have just tried the cgrec92 *#*#4636#*#* solution so will see what happens. I seem to get the problem when go from wifi at home to GPRS location at work.
     
  22. mike0775

    mike0775 Lurker
    5

    May 17, 2010
    1
    0
    5
    I think there is an issue with the desire particularly... I have a problem where my desire often continues to download pages and mail etc over my data connection even when it is connected to a wireless network. Only a reboot seems to reset it!
     
  23. twist123

    twist123 Well-Known Member
    56

    Feb 17, 2010
    118
    8
    56
    My Nexus and Desire do this, Desire less often but I do use wifi less on it. All I do is a network search and it fixes it temporarily till I use wifi again. Or turn wifi on and off again using the power control widget.
     
  24. dejayem

    dejayem Newbie
    15

    May 12, 2010
    10
    0
    15
    Reading, UK
    I set the Network to GSM auto (PRL). This did not make any difference to the WiFi to GPRS transfer problem but I think the GPRS connection was better when it worked. Also the 15min WiFi timeout doesn't make any difference nor switching to airplane mode. Only solution so far is to Power down. (GSM signal was -97 to -95 dBm and after power down still got GPRS with -101dBm signal).

    Tried switching off WiFi before leaving home - when I got to work the GPRS connected OK.

    NB don't use Phoneinfo app - this killed my connection when it was working. I have been using Signal Radar which seems quite useful although always says connection is EDGE which can't be right.
     
  25. mad

    mad Lurker
    6

    May 30, 2010
    7
    1
    6
    I've the same problem with my Desire on SFR Network (France).

    I tried the GSM auto (PRL) trick, seems to work !
     
Tags:

Share This Page

Loading...