1. Download our Official Android App: Forums for Android!

Support 3G turning off when screen is locked

Discussion in 'Android Devices' started by Aced56, Jan 12, 2012.

  1. Aced56

    Aced56 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 12, 2012

    Jan 12, 2012
    9
    0
    5
    [FONT=&quot]I have a Samsung Galaxy Ace. I have turned on 3G and it is working but as soon as my screen locks it goes off and I do not receive emails or whatsapp messages.[/FONT]
    [FONT=&quot]
    [/FONT]
    [FONT=&quot]When I pick up my phone and unlock the screen, the 3G symbol is not there but a few seconds later it appears and my emails and whatsapp messages come through.[/FONT]
    [FONT=&quot]This is very annoying I want my 3G to be on all the time and emails and messages to come through immediately without me having to touch my phone.[/FONT]
    [FONT=&quot]Can anyone help?[/FONT]
    [FONT=&quot]
    [/FONT]
    [FONT=&quot]I have had the phone for 2 weeks and 3G was working fine until yesterday. I started using WIFI for the first time yesterday at the office and I noticed this problem with the 3G yesterday evening. I definitely have my 3G turned on. As it works but only when the screen is unlocked. [/FONT]
     

    Advertisement

  2. bigbaldbloke

    bigbaldbloke Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    199
    Joined:
    Apr 8, 2011

    Apr 8, 2011
    199
    50
    53
    If you go into Settings, Accounts & Sync, is Background Data ticked?
     
  3. Aced56

    Aced56 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 12, 2012

    Jan 12, 2012
    9
    0
    5
    Yes it is
     
  4. bigbaldbloke

    bigbaldbloke Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    199
    Joined:
    Apr 8, 2011

    Apr 8, 2011
    199
    50
    53
    Can you go to Settings, About Phone, Battery Use, click "Mobile Standby" and tell me the percentage please?
     
  5. Aced56

    Aced56 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 12, 2012

    Jan 12, 2012
    9
    0
    5
    It is 42%
     
  6. bigbaldbloke

    bigbaldbloke Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    199
    Joined:
    Apr 8, 2011

    Apr 8, 2011
    199
    50
    53
    Hmm, that should be around zero. Can you do this next please?

    Download "Any Cut" from the Market.
    Open it & click New Shortcut
    Choose Activity, then Testing.

    That'll put a new shortcut on your Home Screen. Click on it & choose "Phone Information"
    What's it showing under "Set preferred network type"?
     

Share This Page

Loading...