1. Are you ready for the Galaxy S20? Here is everything we know so far!

4.08.605.15 won't update

Discussion in 'Android Devices' started by grunt58, Aug 14, 2012.

  1. grunt58

    grunt58 Lurker
    Thread Starter

    I can't install the 4.08.605.15 update. It counts down to reboot to install but doesn't do anything. I'm currently on build 4.08.605.2. Every few days it pops up after I try to install it. I can't find a fix for 605.15 just fixes for 605.2. If no one can help my next try will be to call verizon complain and try and get it swapped. Perhaps they will give me an Incredible 2....


    1. Download the Forums for Android™ app!


  2. sdrawkcab25

    sdrawkcab25 Extreme Android User

    A factory reset usually solves it, or you can attempt to manually install it from recovery.
  3. grunt58

    grunt58 Lurker
    Thread Starter

    I'd rather not reset and lose everything. How do you install from a recovery?
  4. sdrawkcab25

    sdrawkcab25 Extreme Android User

    Have to download the update file to SD card and boot into recovery... I'll get you a link and instructions when I get to a PC.
  5. sdrawkcab25

    sdrawkcab25 Extreme Android User

    Here's the file:

    Need to download it to your sd card. It can't be within any folders and has to be named: update.zip

    Then power off your phone... Next, press and hold the volume DOWN button, while continuing to hold, press the power button till your phone turns on. A screen with a white background will eventually show up. Use the volume keys to highlight "recovery" and press the power button. This will then take you to another screen with green arrows and a black background. At this point your phone MAY automatically try and load the update file, if it doesn't (give it a minute first) press volume UP and power at the same time and you will be presented with options. Select "install update.zip" using the volume keys and press the power button. The file should install. If it doesn't, report back with any errors you receive.
    DIncNewbie likes this.
  6. Dandapani

    Dandapani Member

    Wipe your cache. Found that trick in another thread.
  7. Babalistic

    Babalistic Lurker

    I've been having the same problem, so I gave this a try, but I first got "Unknown volume for path," "Can't mount SDCARD:update.zip," "Installation aborted." Then below it went through finding, opening, verifying update package, "E: failed to verify whole-file signature," "E: signature verification failed," installation aborted. Ugh.
  8. aj88cab

    aj88cab Lurker

    I've been having this same issue for months and must give a BIG thank you to sdrawkcab25 for the solution.

    While following sdrawkcab25's directions one thing different occured. After starting with the Volume Down-Power Button combo the white screen came up. While I was reading his instructions again, the screen changed by itself after a couple seconds, I did not have to manually go to the "recovery" menu. This all happened quickly so I did not see what specific screen was up. The install proceeded automatically at that point. After that the phone restarted a couple times. Then the "droid-eyeball" appeared and it looked like the phone was stuck. But just give it time (maybe 3-5 minutes on my phone) and it will eventually re-boot (maybe twice), and it is a longer than normal reboot, just be patient, and now all is well!

    A couple of other things I did first that may or may not have helped, but if you still have a problem do these too:
    -I moved most all apps that could to the SD card.
    -I cleared the cache for the biggest apps (settings/applications/storage use/menu(at bottom of phone)/sort by size if not done...then pick the 5-10 biggest apps and "clear cache", also if you are careful you can "clear data" on some, but that will wipe logins, saved info, etc. so only do if you know what your affecting, if in doubt...don't).
    -I cleared the process cache (settings/applications/running service/menu(at bottom of phone)/show cached processes...then pick each and "stop").
    -make sure you rename the file "update.zip" and that it is in the root directory of the SD card.

    Again...THANK YOU!
  9. DIncNewbie

    DIncNewbie Newbie

    sdrawcab25, not getting any Android love from this update! First time I rebooted the phone to HBOOT it tried to install the update without my having to go to recovery. However, after I got the green arrows screen and a progress bar as it was trying to load, it halted about 20% of the way through and I got the dreaded red triangle/exclamation icon.

    On subsequent tries, it did not try to load the file from HBOOT, but when I went to recovery it attempted to load and then gave me the same error indication above.

    I'm stock GB 4.08.605.2, S-OFF and was rooted prior to reinstalling this stock ROM (not sure if it unrooted me as HBOOT 0.92 won't tell me).

    Thanks for any help or ideas.

    Oh, and I have to ask the (probably) stupid question: why am I "updating" 4.08.605.2 to 4.08.605.15? Numerically, I'm going down instead of up!? :thinking:
  10. sdrawkcab25

    sdrawkcab25 Extreme Android User

    I'd just ignore the update and install a rom that has the update already baked in. It sounds like you've been unrooted from trying to install the update. I'll get you a couple links to help you out.
    To get root back:

    Updated rom:

    605.15 is a higher version than 605.2 ...I know it doesn't follow proper decimal numbering though :thinking:
    DIncNewbie likes this.
  11. JVacha

    JVacha Lurker

    I've been having this issue as well. On the last update, I called Verizon and they had me do a hard reset on the phone which was annoying. I don't see anything in here about it, but I'm assuming this method is not going to wipe all my data. Is that correct? I'm also looking for a simple method to root that will not require me to wipe my device as well.

  12. DIncNewbie

    DIncNewbie Newbie

    sdrawcab25, thanks for the guidance. Will see about getting re-rooted per your instructions.

    Before I do the above, should I update HBOOT?

    Confused about something, though...why wouldn't an OTA install if I were in fact unrooted?

    Also, is there anything particularly noteworthy in the .15 update? (BTW, just dawned on me how they numbered these versions... 15>2, d'oh!)
  13. sdrawkcab25

    sdrawkcab25 Extreme Android User

    That update is very quirky, I couldn't even get it to install on one of my completely unrooted stock incredibles. I tried everything I could think of, but kept getting a CID error :thinking:

    Don't think that update brought much, some Bluetooth fixes I think.
    DIncNewbie likes this.
  14. DIncNewbie

    DIncNewbie Newbie

    Well, got hosed again! :mad: Phone is now stuck at the white htc Incredible start screen. What I did to arrive at this lovely place was:

    1) booted to HBOOT to check if I was still S-off (I was);
    2) flashed HBOOT 1.07 from a PB31IMG.ZIP file, booted into it (and it showed that I was still unlocked);
    3) flashed CWM;
    4) put the updated 4.08.605.2 ROM file (that you linked above) as well as a new radio file (from that same thread) on the SD card;
    5) booted into CWM and had it flash the ROM update, which appeared to complete successfully;
    6) had CWM try to flash the radio, but it aborted;
    7) rebooted to HBOOT, just to see if the radio updated (it didn't);
    8) rebooted normally to see if the system would start up, and got stuck at that white screen;
    9) pulled battery to completely cycle everything, but still no joy.

    What I did not do was flash superuser again, but didn't think that I had to. Did I? Or did I mess up somewhere else along the line?

  15. sdrawkcab25

    sdrawkcab25 Extreme Android User

    Superuser would be included in the rom, so need to flash superuser... But the radio would be installed from hboot, not CWM (probably why it won't boot). Reflash the rom, doing a complete wipe and see if you can boot.
    DIncNewbie likes this.
  16. DIncNewbie

    DIncNewbie Newbie

    sdrawcab25, thanks for the hints. I didn't realize that you had to install the radio from HBOOT (presumably as a PB31IMG.ZIP, right?). I tried wiping things down and reflashing the ROM, but still didn't work. So I dropped back to the stock GB 4.08.605.2 and got things running again.

    Any ideas about what I might have done to bring that issue on?
  17. DIncNewbie

    DIncNewbie Newbie

    sdrawcab25, on a related subject, I've seen what apparently is the radio from 4.08.605.15 floating around (also slugged as radio version number Know anything about that? And what do you think about it working OK if I just flashed it onto 4.08.605.2?
  18. holmes182

    holmes182 Lurker

    sdrawkcab25 - I tried your instructions...downloaded that zip file, named it "update.zip" (should it be named "update" since it is already a zip file?), saved it in the main folder of my sd card, I hold the volume down key and hit the power button and select recovery, when I do this for a brief instant there is a phone with a green circle on the screen, then it changes to a phone with a red triangle and exclamation point for a while, I left it like this for like 15 minutes and nothing happened...at that point I just restarted the phone and the update still didn't install...any other ideas?
  19. sdrawkcab25

    sdrawkcab25 Extreme Android User

    When you had the red triangle on the screen... did you press volume up and power?
  20. adg9

    adg9 Lurker

    If you do a factory reset the phone will auto update after. You will lose all your data, phone cotntacts, pics, etc... so back it up to your pc first. I am no running latest version. Major flaw but it works.

    Good Luck

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date
Similar Threads - 605 won't update
  1. Seawolf
  2. annie333
  3. godlovingman
  4. Spirit84
  5. Cinque8
  6. Minuous
  7. Berder
  8. Alex Ethridge
  9. markdoc
  10. Kyoshioo

Share This Page